summaryrefslogtreecommitdiff
path: root/sci-libs/vecmath-objectclub
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-libs/vecmath-objectclub
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-libs/vecmath-objectclub')
-rw-r--r--sci-libs/vecmath-objectclub/Manifest5
-rw-r--r--sci-libs/vecmath-objectclub/metadata.xml17
-rw-r--r--sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild39
3 files changed, 61 insertions, 0 deletions
diff --git a/sci-libs/vecmath-objectclub/Manifest b/sci-libs/vecmath-objectclub/Manifest
new file mode 100644
index 000000000000..dffd4a25a83c
--- /dev/null
+++ b/sci-libs/vecmath-objectclub/Manifest
@@ -0,0 +1,5 @@
+DIST vecmath1.2-1.14.tar.gz 75291 SHA256 d32c53e48471d7de1d097fe199a3df765472cc8d872315d4caf9934833573c93 SHA512 b61c60c4c8341327a7494475da380685220a6ecf193f4005bbe9ac2b9c98b5f587607c136ac8ba19425ba57c9d19d2994c1f474ca4cfa3f5a06cebb7d1c5c020 WHIRLPOOL 0139c64265398e8a603b05fe255c791265c401e0e7477d9690346fb784b6e04b86b051d39559ea7beaadbe1d097cf0579b2fb7952466948c84833c0a5e110160
+EBUILD vecmath-objectclub-1.14.ebuild 825 SHA256 2e29fb85ec53ed3b75c470063841525880e73f3d7a50316672411e0a42c1f814 SHA512 b646d86f84f5c893af3a277017b956e0e9fe23c7ff82aa3d790b93beb03e93db017353e852024903215730321fef99c4b3769f3f8743943c7b547eea2b795260 WHIRLPOOL 5a85591e96bda969c86a189e8f2a0f21886cde3a5d3caff9e4e7a1e58501b0709f13122cb98f3b611bbba39c9c4e5ea6abd53c7c57fdde5ff9df366aaaa5bb83
+MISC ChangeLog 2972 SHA256 1ecba88371f75634c6c31eb8b1f0f10f1a618cef625500ca938739c4ced64551 SHA512 7637f33828adf2d4b5731823234435589d14cd64bad6925d1646ac7e18b58e219a20bd3b9c1e48bcf82d83329e473211e317a054905697fa366cccd2a80450b6 WHIRLPOOL f66b2ad0ef0c11cb893a4e3cee2ae0c6f0ce3076ffa1757233cdc7a523621bf288a0bf140ca02591c6ea0353b1441768d81407b0b90a1dc4520ff71a2ab2a398
+MISC ChangeLog-2015 764 SHA256 5da5cd65a675bdd8c349af504ba1bf4d5a813b01f6e5a60149b60ead2f67feb0 SHA512 6d0094e98c764953f206dde2aa6fc81c8f21a58d3d95e44e4764050d691ffad9292089528fc80842c8bf6e0e11f08d8add7e409ff246d6e49b513c87ebfe32d1 WHIRLPOOL 5eccd17c2c4a4ce06541869f41f32960d50089aebb72544c26f01d291a5ccc94b70055d75807aa65836dd44682a525f5f86e0ae0edc19f78d4aa8e62afa39173
+MISC metadata.xml 743 SHA256 ae403dd5897ed7a39be5101be39edb3a884dbea5e2b5e538ca62fa3f378c25c4 SHA512 77534c2084b740b4cdbe6ce6cdb9c8f9a57d95324a2a0e2240c5a0b9edf34d7292b047b5c0509135d56a583cf41d0370342c646aaf4275bb66443d6f2a4cf2e2 WHIRLPOOL 6d4109af1be1d48ff2312c26ed4db2a6e1f983ceb9aaa29678f00f0431b2dd4982828712a620a7024f1023c13413a3226a1412ce560e794d146996df79b250c9
diff --git a/sci-libs/vecmath-objectclub/metadata.xml b/sci-libs/vecmath-objectclub/metadata.xml
new file mode 100644
index 000000000000..6eb27f16c309
--- /dev/null
+++ b/sci-libs/vecmath-objectclub/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<longdescription lang="en">
+ This is unofficial implementation(java source code) of the
+ javax.vecmath package specified in the Java(TM) 3D API 1.2
+ The package includes classes for 3-space vector/point, 4-space vector,
+ 4x4, 3x3 matrix, quaternion, axis-angle combination and etc. which are
+ often utilized for computer graphics mathematics. Most of the classes
+ have single and double precision versions. Generic matrices' LU and SV
+ decomposition are also there.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild b/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild
new file mode 100644
index 000000000000..8d0a0986818f
--- /dev/null
+++ b/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit java-pkg-2
+
+MY_PN="${PN/-objectclub/1.2}"
+
+DESCRIPTION="Unofficial free implementation of Sun javax.vecmath by Kenji Hiranabe"
+HOMEPAGE="http://www.objectclub.jp/download/vecmath_e"
+SRC_URI="http://www.objectclub.jp/download/files/vecmath/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ mkdir classes
+}
+
+src_compile() {
+ find javax/ -name "*.java" > "${T}/src.list"
+ ejavac -d "${S}/classes" "@${T}/src.list"
+
+ cd classes
+ jar -cf "${S}"/${PN}.jar * || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ dodoc README
+}