summaryrefslogtreecommitdiff
path: root/sci-libs/vtk/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-12 09:24:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-12 09:24:43 +0000
commit09d1923fc1fee6007fbd5692399ffa7fbff7e410 (patch)
tree3bc02ed7aec08ca35a6dcaa011cda9f5ed760cd9 /sci-libs/vtk/files
parent0d2f8392c6680b637f072c5b5af8ccbbf7ab9bf6 (diff)
gentoo auto-resync : 12:12:2022 - 09:24:43
Diffstat (limited to 'sci-libs/vtk/files')
-rw-r--r--sci-libs/vtk/files/vtk-9.2.2-VTKm-respect-user-CXXFLAGS.patch81
-rw-r--r--sci-libs/vtk/files/vtk-9.2.2-link-with-glut-library-for-freeglut.patch18
-rw-r--r--sci-libs/vtk/files/vtk-9.2.2-vtkGeometryFilter-add-missing-mutex-header-file.patch20
3 files changed, 119 insertions, 0 deletions
diff --git a/sci-libs/vtk/files/vtk-9.2.2-VTKm-respect-user-CXXFLAGS.patch b/sci-libs/vtk/files/vtk-9.2.2-VTKm-respect-user-CXXFLAGS.patch
new file mode 100644
index 000000000000..c47bced20f22
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-9.2.2-VTKm-respect-user-CXXFLAGS.patch
@@ -0,0 +1,81 @@
+From 225a077898eb714e5ecb80255796aa70625e6cea Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sat, 12 Nov 2022 02:01:35 +0100
+Subject: [PATCH] VTKm respect user CXXFLAGS
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/Accelerators/Vtkm/Core/CMakeLists.txt
++++ b/Accelerators/Vtkm/Core/CMakeLists.txt
+@@ -79,6 +79,16 @@ if (TARGET vtkm::cuda)
+ vtk_module_set_properties(VTK::AcceleratorsVTKmCore
+ LANGUAGE CUDA
+ CUDA_SEPARABLE_COMPILATION ON)
++
++ string(STRIP ${CMAKE_CXX_FLAGS} _cmake_cxx_flags)
++ string(REPLACE " " ";" cmake_cxx_flags_list ${_cmake_cxx_flags})
++ set(cxx_flags -Wall)
++ foreach(cmake_cxx_flag ${cmake_cxx_flags_list})
++ list(APPEND cxx_flags $<$<COMPILE_LANGUAGE:CUDA>:-Xcompiler=${cmake_cxx_flag}>)
++ endforeach()
++ vtk_module_compile_options(VTK::AcceleratorsVTKmCore
++ PUBLIC
++ ${cxx_flags})
+ endif()
+
+ if (MSVC)
+--- a/Accelerators/Vtkm/DataModel/CMakeLists.txt
++++ b/Accelerators/Vtkm/DataModel/CMakeLists.txt
+@@ -89,6 +89,16 @@ if (TARGET vtkm::cuda)
+
+ vtk_module_compile_options(VTK::AcceleratorsVTKmDataModel
+ PUBLIC $<$<COMPILE_LANGUAGE:CUDA>:-Xcudafe --diag_suppress=extra_semicolon>)
++
++ string(STRIP ${CMAKE_CXX_FLAGS} _cmake_cxx_flags)
++ string(REPLACE " " ";" cmake_cxx_flags_list ${_cmake_cxx_flags})
++ set(cxx_flags -Wall)
++ foreach(cmake_cxx_flag ${cmake_cxx_flags_list})
++ list(APPEND cxx_flags $<$<COMPILE_LANGUAGE:CUDA>:-Xcompiler=${cmake_cxx_flag}>)
++ endforeach()
++ vtk_module_compile_options(VTK::AcceleratorsVTKmDataModel
++ PUBLIC
++ ${cxx_flags})
+ endif ()
+
+ if (MSVC)
+--- a/Accelerators/Vtkm/Filters/CMakeLists.txt
++++ b/Accelerators/Vtkm/Filters/CMakeLists.txt
+@@ -138,6 +138,16 @@ if (TARGET vtkm::cuda)
+
+ vtk_module_compile_options(VTK::AcceleratorsVTKmFilters
+ PUBLIC $<$<COMPILE_LANGUAGE:CUDA>:-Xcudafe --diag_suppress=extra_semicolon>)
++
++ string(STRIP ${CMAKE_CXX_FLAGS} _cmake_cxx_flags)
++ string(REPLACE " " ";" cmake_cxx_flags_list ${_cmake_cxx_flags})
++ set(cxx_flags -Wall)
++ foreach(cmake_cxx_flag ${cmake_cxx_flags_list})
++ list(APPEND cxx_flags $<$<COMPILE_LANGUAGE:CUDA>:-Xcompiler=${cmake_cxx_flag}>)
++ endforeach()
++ vtk_module_compile_options(VTK::AcceleratorsVTKmFilters
++ PUBLIC
++ ${cxx_flags})
+ endif ()
+
+ if (MSVC)
+--- a/ThirdParty/vtkm/vtkvtkm/vtk-m/CMake/VTKmCompilerFlags.cmake
++++ b/ThirdParty/vtkm/vtkvtkm/vtk-m/CMake/VTKmCompilerFlags.cmake
+@@ -126,6 +126,12 @@ elseif(VTKM_COMPILER_IS_ICC)
+ elseif(VTKM_COMPILER_IS_GNU OR VTKM_COMPILER_IS_CLANG)
+ set(cxx_flags -Wall -Wcast-align -Wextra -Wpointer-arith -Wformat -Wformat-security -Wshadow -Wunused -fno-common -Wno-unused-function)
+ set(cuda_flags -Xcompiler=-Wall,-Wcast-align,-Wpointer-arith,-Wformat,-Wformat-security,-Wshadow,-fno-common,-Wunused,-Wno-unknown-pragmas,-Wno-unused-local-typedefs,-Wno-unused-function)
++ string(STRIP ${CMAKE_CXX_FLAGS} _cmake_cxx_flags)
++ string(REPLACE " " ";" cmake_cxx_flags_list ${_cmake_cxx_flags})
++ foreach(elem ${cmake_cxx_flags_list})
++ list(PREPEND cxx_flags ${elem})
++ list(PREPEND cuda_flags -Xcompiler=${elem})
++ endforeach()
+
+ #Clang does not support the -Wchar-subscripts flag for warning if an array
+ #subscript has a char type.
+--
+2.38.1
+
diff --git a/sci-libs/vtk/files/vtk-9.2.2-link-with-glut-library-for-freeglut.patch b/sci-libs/vtk/files/vtk-9.2.2-link-with-glut-library-for-freeglut.patch
new file mode 100644
index 000000000000..39b7e7ab0f15
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-9.2.2-link-with-glut-library-for-freeglut.patch
@@ -0,0 +1,18 @@
+From 801654a5f1c3991ff9bb3ea5798afdd252d214b6 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Mon, 21 Nov 2022 15:35:58 +0100
+Subject: [PATCH] link with glut library for freeglut
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/Rendering/External/Testing/Cxx/CMakeLists.txt
++++ b/Rendering/External/Testing/Cxx/CMakeLists.txt
+@@ -12,5 +12,5 @@ if(NOT APPLE)
+
+ vtk_test_cxx_executable(vtkRenderingExternalCxxTests tests)
+ target_link_libraries(vtkRenderingExternalCxxTests PRIVATE
+- ${GLUT_LIBRARY})
++ ${GLUT_LIBRARIES})
+ endif()
+--
+2.38.1
+
diff --git a/sci-libs/vtk/files/vtk-9.2.2-vtkGeometryFilter-add-missing-mutex-header-file.patch b/sci-libs/vtk/files/vtk-9.2.2-vtkGeometryFilter-add-missing-mutex-header-file.patch
new file mode 100644
index 000000000000..287d804847bb
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-9.2.2-vtkGeometryFilter-add-missing-mutex-header-file.patch
@@ -0,0 +1,20 @@
+From https://gitlab.kitware.com/vtk/vtk/-/commit/57767732c4d54db89004c685022ac828bb51eccd
+
+From 57767732c4d54db89004c685022ac828bb51eccd Mon Sep 17 00:00:00 2001
+From: Andrew Bauer <bauer.andrew.c@gmail.com>
+Date: Wed, 27 Jul 2022 09:31:13 -0400
+Subject: [PATCH 033/614] vtkGeometryFilter: add missing mutex header file
+
+--- a/Filters/Geometry/vtkGeometryFilter.cxx
++++ b/Filters/Geometry/vtkGeometryFilter.cxx
+@@ -52,6 +52,7 @@
+ #include "vtkWedge.h"
+
+ #include <memory>
++#include <mutex>
+
+ vtkStandardNewMacro(vtkGeometryFilter);
+ vtkCxxSetObjectMacro(vtkGeometryFilter, Locator, vtkIncrementalPointLocator);
+--
+2.38.1
+