summaryrefslogtreecommitdiff
path: root/sci-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-22 00:31:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-22 00:31:30 +0000
commit6fe1dafaa446d9bc41dea28a43551fffa73f6b87 (patch)
treec6ef70a96add765cc1bfc88ac4d1ece5595cc9bf /sci-libs
parentae832415103492f73a8351ed7a91cb596392d779 (diff)
gentoo auto-resync : 22:03:2025 - 00:31:29
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/Manifest.gzbin40350 -> 40356 bytes
-rw-r--r--sci-libs/htslib/Manifest2
-rw-r--r--sci-libs/htslib/htslib-1.21.ebuild52
-rw-r--r--sci-libs/indilib/Manifest2
-rw-r--r--sci-libs/indilib/indilib-2.1.1.ebuild80
5 files changed, 54 insertions, 82 deletions
diff --git a/sci-libs/Manifest.gz b/sci-libs/Manifest.gz
index fa7cfeb82eb1..33db6a21ca18 100644
--- a/sci-libs/Manifest.gz
+++ b/sci-libs/Manifest.gz
Binary files differ
diff --git a/sci-libs/htslib/Manifest b/sci-libs/htslib/Manifest
index 5581096e30ea..ff026cb06072 100644
--- a/sci-libs/htslib/Manifest
+++ b/sci-libs/htslib/Manifest
@@ -1,5 +1,7 @@
DIST htslib-1.19.1.tar.bz2 4775086 BLAKE2B 3af6770ade9505a3c71f6d522c0971eb77ea2549670043a539a2a4681e583554dc154b9b9fb33f1faa94be336a09945a28c57aa4bcfe0f39b03dd7585c49269a SHA512 a40de47ecae68756c158c1c7b578fa2a5c13bf6f98626e863af31a20d7880ffd415d966280c00bfe726f496d913eb0fcf014dd4beb8c1dbe36ed9735a48bd01e
DIST htslib-1.20.tar.bz2 4779028 BLAKE2B def7a135f37a4c7a167ada554b92b0e0107ab3dcbdab69abdea387035159f40fb183477275c137b0d786fdfc7264303898f98c54acb1714f9b7cb21e22612143 SHA512 a156f5c895fdae77f976f463a2d4d1111dc056893ef45b7e9cf62e9115898bc8cb47465bb1779e534c26943df478892385d44646e97bd0fa67fceb83ef7a649b
+DIST htslib-1.21.tar.bz2 4781943 BLAKE2B 7bbf62021a48503922a459ee18280d1e4af03247f31ef7de204f26a9f5526e8f49253301d6546149985bec93ca262ab8668e73f6b4b6f3c84e70665a66cb59bb SHA512 4989d9fd3702893d2b275e6de593a2109a0ebd10c0329ddca82cd3d53893a93197b9ca9f3756c480c88dc345e14527b1a540810089a480d839814e018a736bee
EBUILD htslib-1.19.1.ebuild 1074 BLAKE2B fa229ef5727c85228457d016736c6edf3258b1ea5d94dc2e441d7095bcaf7be20a079ec6f1838889b69f2c492aa3467070e3860ca7da5ce7cc6f12be7540ff1b SHA512 d9bdcd736f6e669f81a0c221666fc349253f1f5b00f1476bba69a4673690b04e0c8f07346c22be4900062b51274e8c1f27a6674b263463dba32f028955504e79
EBUILD htslib-1.20.ebuild 1074 BLAKE2B fa229ef5727c85228457d016736c6edf3258b1ea5d94dc2e441d7095bcaf7be20a079ec6f1838889b69f2c492aa3467070e3860ca7da5ce7cc6f12be7540ff1b SHA512 d9bdcd736f6e669f81a0c221666fc349253f1f5b00f1476bba69a4673690b04e0c8f07346c22be4900062b51274e8c1f27a6674b263463dba32f028955504e79
+EBUILD htslib-1.21.ebuild 1074 BLAKE2B 8765891b75e294c45445039667e1b729906fa9731710db322d487f344e244050524a76fd7864de1e2f9560bcb1c259b8a22c69f462955467955e4301bcf3e120 SHA512 47fcb23c5c589984433123198806a1681f1a2c505c27ed8a04c2204f5825be2583a58b1f34942309663e94c13e8fcda77662e054388719240ea5f0b7f5bfd3b4
MISC metadata.xml 342 BLAKE2B 1c27212ba39cbbd235e2b023af977d5dffbb53dab193e21c989b2da52641fec13317110cfb52fd73cbe7fbdd5aa6b3628ee7cd55ae919551fa82267b05f93e2d SHA512 5b61d1b204a33d6328d3964346c48dc35bc4e29c56dc7920a63caf2fc510be35b10f74f2649a2670239de90cff5ed4652fa99d4ef51a55245b7fc4b31f29674b
diff --git a/sci-libs/htslib/htslib-1.21.ebuild b/sci-libs/htslib/htslib-1.21.ebuild
new file mode 100644
index 000000000000..19cb872f2c6b
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.21.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bzip2 curl +lzma"
+
+RDEPEND="
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ curl? ( net-misc/curl )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # upstream injects LDFLAGS into the .pc file,
+ # which is a big nono for QA
+ sed -e '/^\(static_l\|Libs.private\|Requires.private\)/d' \
+ -i htslib.pc.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-gcs \
+ --disable-plugins \
+ --disable-s3 \
+ $(use_enable bzip2 bz2) \
+ $(use_enable curl libcurl) \
+ $(use_enable lzma)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ # doesn't use libtool, can't disable static libraries
+ find "${ED}" -name '*.a' -delete || die
+}
diff --git a/sci-libs/indilib/Manifest b/sci-libs/indilib/Manifest
index 9be1ffd1584b..55cb5faf1c60 100644
--- a/sci-libs/indilib/Manifest
+++ b/sci-libs/indilib/Manifest
@@ -1,5 +1,3 @@
-DIST indilib-2.1.1.tar.gz 2929685 BLAKE2B 565199451a2ebbf6757bb854e0dad576397a6154c6043543243364b6072375afd775ed0b54ed116b2702bdea222b47e4f68673da617e68ebf626d1725e66d2a7 SHA512 3224afb13776462e906398be2b85802807e739042494b29701d106731423640a4dceaeb262cd62d3a87f032ba0655da7ceaa150e6912be20508e090ad93c3ba7
DIST indilib-2.1.2.1.tar.gz 2941118 BLAKE2B 43928220243867a2c648855a38de3c3e49c754b135694215b24ddda6b71eb8a421a1d11dd199b5df9adcedb8c63de46288a8fe246f4ba27adfd6e98c38d825a2 SHA512 b59b23a26509922fae33d6080510a7fdce170baa59d86f5abbb955313e0a62d45f489b08021144a44cc0ca1d172825a6b524c778bb2bb24148b246e574fc0918
-EBUILD indilib-2.1.1.ebuild 1774 BLAKE2B 8ca6b34c559118a344321380145f824949cd7ecdd1ede2d07aa3a61ebd61e98c6e4ad585f91f1b65bb395d276e01e9cc8c94794ba1b31276625139347b173404 SHA512 8751a102de63c176e732a53257a6a0edc236ab69c73b602ada4842fe2ade8d2661b4346160f1b269ef120854841cba50b90f4abc911c15d06baee5b7c6dd2c29
EBUILD indilib-2.1.2.1.ebuild 1774 BLAKE2B 8ca6b34c559118a344321380145f824949cd7ecdd1ede2d07aa3a61ebd61e98c6e4ad585f91f1b65bb395d276e01e9cc8c94794ba1b31276625139347b173404 SHA512 8751a102de63c176e732a53257a6a0edc236ab69c73b602ada4842fe2ade8d2661b4346160f1b269ef120854841cba50b90f4abc911c15d06baee5b7c6dd2c29
MISC metadata.xml 562 BLAKE2B 675fbd88b6ea5004a89e4d86f397e924317f56ad98743d1d8cd9758f92b516cf70386f4eb59c8869451acd6b312c50a05b37a9ca3cedac87599bd90cd46d6ddd SHA512 ebef1f64112d45534b6ea13ce54b2ee57349d11486b881be277d669e984891fe9d8ca3839aadbbece908f55bd027060739460929bd7e0400cd04e639c7d2186f
diff --git a/sci-libs/indilib/indilib-2.1.1.ebuild b/sci-libs/indilib/indilib-2.1.1.ebuild
deleted file mode 100644
index 2225fceea0be..000000000000
--- a/sci-libs/indilib/indilib-2.1.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2025 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake udev
-
-DESCRIPTION="INDI Astronomical Control Protocol library"
-HOMEPAGE="https://www.indilib.org/"
-SRC_URI="https://github.com/${PN}/${PN/lib/}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${P/lib/}"
-
-LICENSE="BSD GPL-2+ LGPL-2+ LGPL-2.1+"
-SLOT="0/1"
-KEYWORDS="amd64 ~ppc ppc64 ~riscv ~x86"
-IUSE="ogg rtlsdr test websocket"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-cpp/cpp-httplib:=
- dev-cpp/nlohmann_json
- dev-libs/libev
- media-libs/libjpeg-turbo:=
- net-misc/curl
- sci-libs/cfitsio:=
- sci-libs/fftw:3.0=
- sci-libs/gsl:=
- sci-libs/libnova:=
- sys-libs/zlib
- virtual/libusb:1
- ogg? (
- media-libs/libogg
- media-libs/libtheora
- )
- rtlsdr? ( net-wireless/rtl-sdr )
- websocket? ( dev-libs/boost:= )
-"
-DEPEND="${RDEPEND}
- kernel_linux? ( sys-kernel/linux-headers )
- test? ( >=dev-cpp/gtest-1.8.0 )
- websocket? ( dev-cpp/websocketpp )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DINDI_SYSTEM_HTTPLIB=ON
- -DINDI_SYSTEM_JSONLIB=ON
- -DINDI_BUILD_QT5_CLIENT=OFF
- -DINDI_BUILD_SHARED=ON
- -DINDI_BUILD_STATIC=OFF
- -DINDI_BUILD_XISF=OFF # not packaged
- -DUDEVRULES_INSTALL_DIR="${EPREFIX}$(get_udevdir)"/rules.d
- $(cmake_use_find_package ogg OggTheora)
- $(cmake_use_find_package rtlsdr RTLSDR)
- -DINDI_BUILD_UNITTESTS=$(usex test)
- -DINDI_BUILD_INTEGTESTS=$(usex test)
- -DINDI_BUILD_WEBSOCKET=$(usex websocket)
- )
-
- cmake_src_configure
-}
-
-src_test() {
- # Unit tests
- BUILD_DIR="${BUILD_DIR}"/test cmake_src_test
-
- # Integration tests
- # They fail in parallel because they try to bind to the same port more
- # than once.
- BUILD_DIR="${BUILD_DIR}"/integs cmake_src_test -j1
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}