summaryrefslogtreecommitdiff
path: root/sci-mathematics/4ti2/4ti2-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/4ti2/4ti2-1.6.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/4ti2/4ti2-1.6.2.ebuild')
-rw-r--r--sci-mathematics/4ti2/4ti2-1.6.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-mathematics/4ti2/4ti2-1.6.2.ebuild b/sci-mathematics/4ti2/4ti2-1.6.2.ebuild
new file mode 100644
index 000000000000..d107c3deb4a7
--- /dev/null
+++ b/sci-mathematics/4ti2/4ti2-1.6.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+# The swig subdir is not used, so we can skip running autotools in it. #518000
+AT_NO_RECURSIVE=1
+
+inherit autotools-utils
+
+DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
+HOMEPAGE="http://www.4ti2.de/"
+SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-macos"
+IUSE="static-libs"
+
+DEPEND="
+ sci-mathematics/glpk:0[gmp]
+ dev-libs/gmp[cxx]"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-gold.patch
+ )
+
+src_prepare() {
+ sed \
+ -e "s:^CXX.*$:CXX=$(tc-getCXX):g" \
+ -i m4/glpk-check.m4 || die
+ autotools-utils_src_prepare
+}