summaryrefslogtreecommitdiff
path: root/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sci-mathematics/cvc4/cvc4-1.7-r1.ebuild')
-rw-r--r--sci-mathematics/cvc4/cvc4-1.7-r1.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild b/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
index e50bae6113f6..36e9f4689a67 100644
--- a/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
+++ b/sci-mathematics/cvc4/cvc4-1.7-r1.ebuild
@@ -3,12 +3,12 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+CMAKE_MAKEFILE_GENERATOR=emake
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit cmake python-any-r1
-inherit python-any-r1 cmake-utils
-
-DESCRIPTION="automatic theorem prover for satisfiability modulo theories (SMT) problems"
-HOMEPAGE="http://cvc4.cs.stanford.edu/web/"
+DESCRIPTION="Automatic theorem prover for satisfiability modulo theories (SMT) problems"
+HOMEPAGE="https://cvc4.github.io/"
SRC_URI="https://github.com/CVC4/CVC4/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
@@ -25,12 +25,11 @@ RDEPEND="dev-libs/antlr-c
DEPEND="${RDEPEND}"
BDEPEND="${PYTHON_DEPS}"
-S="${WORKDIR}"/CVC4-${PV}
+S="${WORKDIR}"/${P^^}
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_configure() {
- CMAKE_MAKEFILE_GENERATOR=emake
local mycmakeargs=(
-DANTLR_BINARY=/usr/bin/antlr3
-DENABLE_GPL=ON
@@ -41,7 +40,7 @@ src_configure() {
-DENABLE_PROOFS="$(usex proofs ON OFF)"
-DENABLE_REPLAY="$(usex replay ON OFF)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
@@ -54,10 +53,10 @@ src_test() {
smt2_compliance \
two_smt_engines \
statistics
- cmake-utils_src_test
+ cmake_src_test
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
mv "${D}"/usr/{lib,$(get_libdir)}
}