summaryrefslogtreecommitdiff
path: root/sci-mathematics/easycrypt/easycrypt-2022.04-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sci-mathematics/easycrypt/easycrypt-2022.04-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sci-mathematics/easycrypt/easycrypt-2022.04-r1.ebuild')
-rw-r--r--sci-mathematics/easycrypt/easycrypt-2022.04-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/easycrypt-2022.04-r1.ebuild b/sci-mathematics/easycrypt/easycrypt-2022.04-r1.ebuild
new file mode 100644
index 000000000000..0e74e30a9b91
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-2022.04-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-r${PV}
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=sci-mathematics/why3-1.4:= <sci-mathematics/why3-1.5:=
+ dev-ml/batteries:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}