summaryrefslogtreecommitdiff
path: root/sci-mathematics/easycrypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
commit27b3683509c5229cce540418778a8b64afbc0009 (patch)
treeb7164898142b8b093b91c8254c4387b6eec679ee /sci-mathematics/easycrypt
parentf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (diff)
gentoo auto-resync : 17:02:2025 - 00:13:57
Diffstat (limited to 'sci-mathematics/easycrypt')
-rw-r--r--sci-mathematics/easycrypt/Manifest2
-rw-r--r--sci-mathematics/easycrypt/easycrypt-2025.02.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/Manifest b/sci-mathematics/easycrypt/Manifest
index 1b90ed5de2be..dae52c1a9845 100644
--- a/sci-mathematics/easycrypt/Manifest
+++ b/sci-mathematics/easycrypt/Manifest
@@ -1,3 +1,5 @@
DIST easycrypt-2024.09.tar.gz 1310681 BLAKE2B cfe81762d4f4567473fc1f98c889145ed8c42f0a48b9e8089de8eca6c15f088d36c4eb7f4b4c4889b6444323b38a2ab17d0703cf97470ddf3084094a37436d69 SHA512 ce1554046c87fbeb27763ffd7a40fb0d8abc8bdedce6884e864968c23b31aee2c66108e52233d4dd1cb408a48b2ac3cba3ef46aee0963a5c21f3c2d1a843c308
+DIST easycrypt-2025.02.tar.gz 1362823 BLAKE2B d0a9739178b459e9f1288286f9a40bd45735d8a4d1acdcc322a079b2fc7712b1a9ffb655cfc67ae9384234981496218cd9dc8c7385d2954b3544a6339a8f98c7 SHA512 61d35a3e1bb2e91be94a52f3cc4c75e209a95908a6fc558472dab863b6d9d82f0a39bbe35ba98f6ce92eb398465013fdddd73bc99b789a55bcca6975c0d72196
EBUILD easycrypt-2024.09.ebuild 990 BLAKE2B a7545b457ce9d8127c05e543dbc92931ffcef034eb590252eb7a0e24552b2067d4fa4daf498e02c2281e6aceec50f5eff647444873f376c476a04ecaa550657f SHA512 7ba58288c3f6229ec5a3c904a123017c516364696a9ffca2b88b1c00d4e8460999e7b53f6502ee523ae7c14cfc6aae1c99de61a921dfc5bcdc93b02480798cf2
+EBUILD easycrypt-2025.02.ebuild 993 BLAKE2B d77a3c1acda3c25ba0ae8bd77d81cc79a417ec0343f9cc784e333b29be71ef55a418d78cb23b656e52a2986d5882cbe01eb6496e2f3dfbbd7412ff2569fb2961 SHA512 0fef6f02d3bdcdffb753cad81540c8f3495128f0346e81e8ee8abac89efda1023710837a408f723fd013ddcfe5f1e78f085f19e91128557b733f2e1ded92a1bf
MISC metadata.xml 799 BLAKE2B 967a758171a2fe87b648a29bf2663beaae7834119e55a7619c98518c96cfe459e59fe5dc72a9faea071c0b488dc8144f1c0e43677ac63646f1ba12cf831f4a88 SHA512 411ff1acad400c3e70e546fd59b20db13b0f1db121aca9f1af23da708cd82340114bc966f64cfb5a35e84967c1131c660ab260f867639932c67edf47c859c4ca
diff --git a/sci-mathematics/easycrypt/easycrypt-2025.02.ebuild b/sci-mathematics/easycrypt/easycrypt-2025.02.ebuild
new file mode 100644
index 000000000000..94f61fdf4523
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-2025.02.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/r${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-r${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=sci-mathematics/why3-1.8.0:=
+ dev-ml/batteries:=
+ dev-ml/camlp-streams:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/num:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}