summaryrefslogtreecommitdiff
path: root/sci-mathematics/eclib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-09 23:42:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-09 23:42:15 +0100
commit12de738b83927a4b71c3ad067edbb6279d15b368 (patch)
tree87b2ef3927262a0aba7a923512909bdbadd71b8b /sci-mathematics/eclib
parent7b7a5ff63901698b7b993201e07bcaf8d0e5db2f (diff)
gentoo auto-resync : 09:05:2023 - 23:42:14
Diffstat (limited to 'sci-mathematics/eclib')
-rw-r--r--sci-mathematics/eclib/Manifest2
-rw-r--r--sci-mathematics/eclib/eclib-20230424.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index 297b00a3d92b..d55795328726 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1,3 +1,5 @@
DIST eclib-20221012.tar.bz2 922112 BLAKE2B 2a6e5dccdef7c3c3b8bb1a121706bbfbcaafa9fb50882e4e88f8fa826c3b1bcbec11dc55462cbd51da3ab263991ae357b151ff3bdbf453abfc30e82d2abdeac8 SHA512 9d04aefe9e35fbc1b18dd92b5ba872cf71f5ce1c94c9a0f1ff326c763bf144112d7d950ac80e2bd8d3780a303edeeac903754b4eb5fb241e87be7ef3f2738c19
+DIST eclib-20230424.tar.bz2 923074 BLAKE2B 00c314e54ff2ce37f3aa83b757c0f880aef563093ab33db5241dfeb1e78cfd21be4f6a5097965697d5b87aa1987da17bd47007a599717ebf39456717efa6ad2c SHA512 4c248c48fa563e53b9354f3822c4e95308320a809f2dcc3e116cba8a6f903b333e27b527da9a10dc8252052201c4fcf50d9747a75cf8438a98b9d3828eb3d9d9
EBUILD eclib-20221012.ebuild 1027 BLAKE2B 8d6b0aebf0558475eb1190d37c545977b67f22c5c781d8b2c291eca25b65f63f4c14e0d23632028c70257285e210932d8540cd837c4ab56f9ff5a93376a69f42 SHA512 d91fb3677e456480e6b02f8ec643007bbbbc3a339ba03d4ee6a952f1187e743ea13379a671cb26dc5e7d3e3fa244657cc89d366193f829589dbe35bbd785e901
+EBUILD eclib-20230424.ebuild 1114 BLAKE2B ee9bface000314df476aeb6f3b272b680cff0712b3998f1891cd400c2d7e7bfa9076ed892957617ea605f02eeae9504776c20b001e0b4640e625c3236beba4c1 SHA512 4ffa8c82f1a255ccaa7f81d793f55ba03c87e58d9625f4ff4c12a9799d75d97aaff6d896c3fbabb4d8d02dae320ffa1c395d441e339b2492c99c409cc79909d0
MISC metadata.xml 1089 BLAKE2B d10f9af5634478f0f13595abd10d9eefc437c27955cd3f504165beb4219e55c3997f16271148c1c2fbb5c9ae71e08665000836658bb954b83db06aeffa2b4098 SHA512 7111f3231464624d356611372934d0604fdd7a05c3531342a372979292a068dfa2edf49c4de5840cbf07b6f4819c22b8d87d54d7cacefb28ce0f53576d4620fd
diff --git a/sci-mathematics/eclib/eclib-20230424.ebuild b/sci-mathematics/eclib/eclib-20230424.ebuild
new file mode 100644
index 000000000000..b6530c437e9e
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20230424.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0/12"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # LT_CURRENT was bumped to 12 in this release but LT_AGE was left at
+ # two despite an interface being removed. Here we fix it so that the
+ # soname is correctly updated (and matches the expected subslot
+ # again).
+ sed -e 's/LT_AGE=2/LT_AGE=0/' -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}