summaryrefslogtreecommitdiff
path: root/sci-mathematics/eclib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-mathematics/eclib
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-mathematics/eclib')
-rw-r--r--sci-mathematics/eclib/Manifest3
-rw-r--r--sci-mathematics/eclib/eclib-20190909.ebuild37
-rw-r--r--sci-mathematics/eclib/metadata.xml39
3 files changed, 79 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
new file mode 100644
index 000000000000..3c538ebc2bee
--- /dev/null
+++ b/sci-mathematics/eclib/Manifest
@@ -0,0 +1,3 @@
+DIST eclib-20190909.tar.bz2 914900 BLAKE2B df57972792f96e65b25db5a2ab1063d5a8f1ad05edbed77d9ca2632ddfb4af2cb8586e572155beec09cc0c03472300d1e6fcbdda3527c36e9106006239f50600 SHA512 df829b10c353f528f2040b55d6198e3a48eba179b9a80e71794e4c6d46ee9bb13b3eccec15c7d286ec5d8252e6ba91157c2a08ac4e2da86969a4158450a41960
+EBUILD eclib-20190909.ebuild 1032 BLAKE2B ac9d22b2bf93cc93236a325b5b9f282057a35e6c939f7d33991c7e08f26bcfd45d8f2a7518b47e99ae83160c9e836a8de2563ddba1d9a7cdef15672f17ab70c5 SHA512 3c43c89824caec646156deb47c23155d5b191be3d65718f5dafa43310176539d2852911e87ba0503e4b10b4573a04a9a5386c1db94b566118464a91291453bf8
+MISC metadata.xml 1058 BLAKE2B f78114f517aa1b21ee6bc36104f1e929b319d77c2a9373c41cfcea4a90d89ff9e0a0d512f4056b6d1c611a3dfe2f64b65117f8e3ba09dd4c3e535eab0cb76f3b SHA512 692e570681c68cd0a2285b616a792e91e341993fceac875f3e35911f04d1933b2e696c9d54d9f90c3a2f459c8365291e03c0a52c1cbf0491a3c303f9e1ba6d41
diff --git a/sci-mathematics/eclib/eclib-20190909.ebuild b/sci-mathematics/eclib/eclib-20190909.ebuild
new file mode 100644
index 000000000000..e30f083b9992
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20190909.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://www.warwick.ac.uk/~masgaj/mwrank/index.html"
+
+# We use the SageMath tarball instead of the one from github because
+# the github releases don't contain the "make dist" stuff and we would
+# need autotools.eclass to generate it.
+SRC_URI="http://files.sagemath.org/spkg/upstream/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="boost flint minimal static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-mathematics/eclib/metadata.xml b/sci-mathematics/eclib/metadata.xml
new file mode 100644
index 000000000000..9561ac3f61e9
--- /dev/null
+++ b/sci-mathematics/eclib/metadata.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <use>
+ <flag name="boost">
+ Add parallel capabilities using <pkg>dev-libs/boost</pkg>.
+ </flag>
+
+ <flag name="flint">
+ Enable the use of <pkg>sci-mathematics/flint</pkg> for certain
+ operations.
+ </flag>
+
+ <flag name="minimal">
+ Build only the "mwrank" program.
+ </flag>
+ </use>
+
+ <upstream>
+ <remote-id type="github">JohnCremona/eclib</remote-id>
+ </upstream>
+</pkgmetadata>