summaryrefslogtreecommitdiff
path: root/sci-mathematics/eclib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
commit454de691f3543d47dc89cd0b137eaa9ea4640cd3 (patch)
tree90ec469ff7d2e1b1fac0b0f98f32d49dacb30278 /sci-mathematics/eclib
parente393c0503a79342594a61547dc43f80f8bcc086e (diff)
gentoo auto-resync : 21:12:2022 - 13:54:08
Diffstat (limited to 'sci-mathematics/eclib')
-rw-r--r--sci-mathematics/eclib/Manifest2
-rw-r--r--sci-mathematics/eclib/eclib-20221012.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index ba46830e2e2b..8da0cb4ae750 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1,3 +1,5 @@
DIST eclib-20220621.tar.bz2 921610 BLAKE2B f53f0648f09e427ae9b208a17c93f9808c2ab859cc41db6b5acb3b1382e9aaee93b17cd9d94c14e7f4941f140749d91b2ad94ad684f8a2c0f6033ac042cc89e7 SHA512 45cc47256f6ccbf2a00711d14533cffe8a3fc0dfea3d94d9823ac43af8a56cfe95485f0559c9141203910e85b1d3fa3284ee12ca5e53d083b74cbb2907afca42
+DIST eclib-20221012.tar.bz2 922112 BLAKE2B 2a6e5dccdef7c3c3b8bb1a121706bbfbcaafa9fb50882e4e88f8fa826c3b1bcbec11dc55462cbd51da3ab263991ae357b151ff3bdbf453abfc30e82d2abdeac8 SHA512 9d04aefe9e35fbc1b18dd92b5ba872cf71f5ce1c94c9a0f1ff326c763bf144112d7d950ac80e2bd8d3780a303edeeac903754b4eb5fb241e87be7ef3f2738c19
EBUILD eclib-20220621.ebuild 869 BLAKE2B 46ca028cc712a8eaaf1a47fed105473d27abc2afeab903e4d91ef42cf79cce5783dab01387a0ad0ed291a5f65bb3fa28d01877fd4fe3a564d24d71acd62eb65c SHA512 67437c82d90b0f75a4e4f4a6f3fba489b7b1a7fa363b615d0ae71307b8fead2c92db005dfd37e708a983177ac6e5360442dd30990e864ae4c92a6d61e828e135
+EBUILD eclib-20221012.ebuild 1029 BLAKE2B d4ff0a197ee0a2d8450c6ac4e03e65d54682ed57dea61ef2970fa4dc4cc50f98eb9fe583cc1746afadc9629ae8179f6081b448ef7243f1491ffa47c8a1a6b2fb SHA512 35e7aeffd230b3ae950f3931abafca7534ff847cccfbc064ae7c324c0174e9a98ac4a45be3ce59681558b9bd11fc9a04f0221e0dcb52423c6e2f91852eb6998e
MISC metadata.xml 1089 BLAKE2B d10f9af5634478f0f13595abd10d9eefc437c27955cd3f504165beb4219e55c3997f16271148c1c2fbb5c9ae71e08665000836658bb954b83db06aeffa2b4098 SHA512 7111f3231464624d356611372934d0604fdd7a05c3531342a372979292a068dfa2edf49c4de5840cbf07b6f4819c22b8d87d54d7cacefb28ce0f53576d4620fd
diff --git a/sci-mathematics/eclib/eclib-20221012.ebuild b/sci-mathematics/eclib/eclib-20221012.ebuild
new file mode 100644
index 000000000000..0266953df5d9
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20221012.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+# Major version of /usr/lib64/libec.so
+# It *should* be at 11 in v20221012, as this commit shows,
+#
+# https://github.com/JohnCremona/eclib/commit/b63b8bb
+#
+# but it's actually still at 10, probably due to a forgotten autoreconf
+# or something.
+SLOT="0/11"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}