summaryrefslogtreecommitdiff
path: root/sci-mathematics/factmsieve
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sci-mathematics/factmsieve
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sci-mathematics/factmsieve')
-rw-r--r--sci-mathematics/factmsieve/Manifest4
-rw-r--r--sci-mathematics/factmsieve/factmsieve-76-r1.ebuild31
-rw-r--r--sci-mathematics/factmsieve/files/factmsieve-76.patch52
-rw-r--r--sci-mathematics/factmsieve/metadata.xml8
4 files changed, 0 insertions, 95 deletions
diff --git a/sci-mathematics/factmsieve/Manifest b/sci-mathematics/factmsieve/Manifest
deleted file mode 100644
index 6665a440967b..000000000000
--- a/sci-mathematics/factmsieve/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX factmsieve-76.patch 1386 BLAKE2B 7d39ff2bd7cfeff73c484f1a4fe918e2087c73ef004265df2600e4b669bdb6a927be3d72894cf4c593c9f2caef1b7788deb2ac2a0fec1d8a6c059156a6d8329d SHA512 f2dcda3838b27d39e235875a9be7dfccf69618f73daf73d28f599a33fe428bec289f52329128179772f6fbcdaa8692df9763af75b701459f03698c768fed584f
-DIST factmsieve.76.zip 19563 BLAKE2B 466378c331f47fd302768b0902a1753e512bbebda0582916fb720045dea044873ea36849de11acc6016b6013aaa20634c84d8e987af3c6fa96358b54e47dc681 SHA512 b07b0676a635ff746b1edfaf064d27388df8f9c5c2fe1bd1e80d4c839c6e518e3a0b39a06b76f3d59c9fa3f4cc99df0831ba6309a2a7d2eb779b952a29996431
-EBUILD factmsieve-76-r1.ebuild 687 BLAKE2B 7f418cbc7c4bc52853196d1ca4a9bcad5d7e4b48d3fe82c2e0764ca69a37a9aa350e6ad4b967eead5e3367fd786c9fe769ea864c0a034746f4cd6df5eb60e989 SHA512 d79cf5f87602e5ca197bff1866c97a30d1538a64423483ab6331be57dba9c090cbcba07b8424623a10374e68586dcb7b1e6f4eefd23d987cc334f8e4bb47f3e4
-MISC metadata.xml 247 BLAKE2B 5a20af3c9732ef7dba68131a08988652f5c93a6d186a82c4deb1bb9c06dc3ae73152a0d241cc346637f7b11caf4676da43301ba596c67b66669535e71db0b03e SHA512 29cf52c16b0cce69899d9c2da8acd9144b7d760442aa323b854dceadb42459e009545193b1df7911ac2241b59f4819b4a6bb1d206d6f57953f770031433bb6b7
diff --git a/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild b/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild
deleted file mode 100644
index b8e607498d38..000000000000
--- a/sci-mathematics/factmsieve/factmsieve-76-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="Convenient factorization helper script using msieve and ggnfs"
-HOMEPAGE="http://gladman.plushost.co.uk/oldsite/computing/factoring.php"
-SRC_URI="http://gladman.plushost.co.uk/oldsite/computing/${PN}.${PV}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- sci-mathematics/msieve
- sci-mathematics/ggnfs"
-DEPEND=""
-
-S="${WORKDIR}"
-PATCHES=( "${FILESDIR}/${P}.patch" )
-
-src_install() {
- python_fix_shebang ${PN}.py
- dobin ${PN}.py
-}
diff --git a/sci-mathematics/factmsieve/files/factmsieve-76.patch b/sci-mathematics/factmsieve/files/factmsieve-76.patch
deleted file mode 100644
index eaf50efaecca..000000000000
--- a/sci-mathematics/factmsieve/files/factmsieve-76.patch
+++ /dev/null
@@ -1,52 +0,0 @@
---- a/factmsieve.py
-+++ b/factmsieve.py
-@@ -1,3 +1,4 @@
-+#!/usr/bin/env python
- # factmsieve.py - A Python driver for GGNFS and MSIEVE
- #
- # Copyright (c) 2010, Brian Gladman
-@@ -56,9 +57,12 @@
- import time, subprocess, gzip, glob, math, tempfile, datetime
- import atexit, threading, collections, multiprocessing, platform
-
-+# need to save pwd
-+CUR_DIR=os.path.realpath(os.curdir)
-+
- # Set binary directory paths
--GGNFS_PATH = '../../bin/x64/Release/'
--MSIEVE_PATH = '../../../msieve/build.vc10/x64/Release/'
-+GGNFS_PATH = '/usr/bin/'
-+MSIEVE_PATH = '/usr/bin/'
-
- # Set the number of CPU cores and threads
- NUM_CORES = 4
-@@ -69,7 +73,7 @@
- # number of linear algebra threads to launch
- LA_THREADS = NUM_CORES * THREADS_PER_CORE
-
--USE_CUDA = True
-+USE_CUDA = False
- GPU_NUM = 0
- MSIEVE_POLY_TIME_LIMIT = 0
-
-@@ -103,8 +107,8 @@
-
- # default parameter files
-
--DEFAULT_PAR_FILE = GGNFS_PATH + 'def-par.txt'
--DEFAULT_POLSEL_PAR_FILE = GGNFS_PATH + 'def-nm-params.txt'
-+DEFAULT_PAR_FILE = '/usr/share/doc/ggnfs/def-par.txt'
-+DEFAULT_POLSEL_PAR_FILE = '/usr/share/doc/ggnfs/def-nm-params.txt'
-
- # temporary files
-
-@@ -258,7 +262,8 @@
- # write string to log(s):
-
- def write_string_to_log(s):
-- with open(LOGNAME, 'a') as out_f:
-+ # XXX hax
-+ with open(CUR_DIR+'/'+LOGNAME, 'a') as out_f:
- print(date_time_string() + s, file = out_f)
-
- def output(s, console = True, log = True):
diff --git a/sci-mathematics/factmsieve/metadata.xml b/sci-mathematics/factmsieve/metadata.xml
deleted file mode 100644
index 40aa45df2b01..000000000000
--- a/sci-mathematics/factmsieve/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>patrick@gentoo.org</email>
- <name>Patrick Lauer</name>
- </maintainer>
-</pkgmetadata>