summaryrefslogtreecommitdiff
path: root/sci-mathematics/geogebra-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /sci-mathematics/geogebra-bin
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'sci-mathematics/geogebra-bin')
-rw-r--r--sci-mathematics/geogebra-bin/Manifest5
-rw-r--r--sci-mathematics/geogebra-bin/files/geogebra.sh32
-rw-r--r--sci-mathematics/geogebra-bin/geogebra-bin-5.0.604.0-r2.ebuild55
-rw-r--r--sci-mathematics/geogebra-bin/metadata.xml7
4 files changed, 99 insertions, 0 deletions
diff --git a/sci-mathematics/geogebra-bin/Manifest b/sci-mathematics/geogebra-bin/Manifest
new file mode 100644
index 000000000000..0602f38f3098
--- /dev/null
+++ b/sci-mathematics/geogebra-bin/Manifest
@@ -0,0 +1,5 @@
+AUX geogebra.sh 954 BLAKE2B 6345f6f0103f326a3d0acc56d9c794c0f269613916b221e690bb4065be9597a9b0c77b1caa370d144548b6f24bf96995f2c2b6ca70d2da16d296e0639feecc2b SHA512 f44c7250af9c991fb78b96d97d0324084f97e54c2b64c680fc82a71ddba1cb5c89c76276eaa0b3bd966ace4d90f4336b3cc3c3c5603294b2314d6d82916c70e0
+DIST GeoGebra-Linux-Portable-5-0-604-0.tar.bz2 138245005 BLAKE2B 589b12a60161ca07e6da82953aeda69a2ed7302634df9078cb997000e2b77486aa1f4dfcbc1daddfddf0b425574ad927c97e0a08d70d708a209eaf0af86d9756 SHA512 ccf190f436504727dc9c6fa10adbd2d0a72a87b641e5b7ce2c7bc8ffe8c1baa00d97b3d2b619f32f1c50b28d5c72b0e0b15619e9c8be74ad8c8fb5afbe66c9a3
+DIST Geogebra.svg 522 BLAKE2B 8c11d037bd8af7af571abc2bba0a8610f0ed5c1cea46fdc47a40d0176e5ea3b7ad4700601a3094b1aa15012f769883c7f5cb60a70f4ed400df57e3b0610271e9 SHA512 a54fedd530d1c803e14d6f44ab7341d9f1ae17fb6b6496bd21788ad1b88b0977d574db6de199e9168543a03dff73ab19e3c50793ec91750ff5fff4a4b7af408d
+EBUILD geogebra-bin-5.0.604.0-r2.ebuild 1182 BLAKE2B 8a693a3bdde6c8b5cc1b22f3d4f25e84d824704d1c5dcdb18c1d37472b126b9ef3fdddc1a81de31daf24992363a11a34862f7c7a9fa390fc0bc8f3d9e1bb651e SHA512 f2fd807d3c41787f4ff2d9eea33154240b4b240031e862c9eeb8766420106c0a090166b4714014b344873aee9cf30c9385af22b3183539ca74308c5acf3173e5
+MISC metadata.xml 216 BLAKE2B da3631f8f6582ec2aad6497bbadf58b72bd143f39387aa3a5ee5842db7dc470f1693503286c6c1cde6e4f1ac72c271afabd139d1cb6f25de7d06a5469dd66c03 SHA512 241c7b10d088e8d6b9ace6781434e64c4a5d2eb80e5dfceea04e09a9637475e927ebd804588e5624622b24ef60a29331ad07f995360b0c1c2d5ffa25033a9f4d
diff --git a/sci-mathematics/geogebra-bin/files/geogebra.sh b/sci-mathematics/geogebra-bin/files/geogebra.sh
new file mode 100644
index 000000000000..b0f941e8a463
--- /dev/null
+++ b/sci-mathematics/geogebra-bin/files/geogebra.sh
@@ -0,0 +1,32 @@
+#!@GENTOO_PORTAGE_EPREFIX@/bin/bash
+
+set -euo pipefail
+IFS=$'\n\t'
+
+main() {
+ local j8 j11 jcmd
+ j8="$(java-config --select-vm openjdk-8 -J 2> /dev/null || true)"
+ j11="$(java-config --select-vm openjdk-11 -J 2> /dev/null || true)"
+
+ if [[ -f "$(dirname "${j8:-/}")/../jre/lib/javafx.properties" ]]; then
+ jcmd="${j8}"
+ elif [[ -f "$(dirname "${j11:-/}")/../lib/javafx.properties" ]]; then
+ jcmd="${j11}"
+ elif [[ -f @GENTOO_PORTAGE_EPREFIX@/usr/lib64/openjdk-11/lib/javafx.properties ]]; then
+ jcmd="@GENTOO_PORTAGE_EPREFIX@/usr/lib64/openjdk-11/bin/java"
+ elif [[ -f @GENTOO_PORTAGE_EPREFIX@/usr/lib/openjdk-11/lib/javafx.properties ]]; then
+ jcmd="@GENTOO_PORTAGE_EPREFIX@/usr/lib/openjdk-11/bin/java"
+ else
+ echo "dev-java/openjdk[javafx] not found!" 1>&2
+ exit 1
+ fi
+
+ if [[ ! -x "${jcmd}" ]]; then
+ echo "${jcmd} not executable!" 1>&2
+ exit 1
+ fi
+
+ env JAVACMD="${jcmd}" "@GENTOO_PORTAGE_EPREFIX@/opt/geogebra/geogebra" "${@}"
+}
+
+main "$@"
diff --git a/sci-mathematics/geogebra-bin/geogebra-bin-5.0.604.0-r2.ebuild b/sci-mathematics/geogebra-bin/geogebra-bin-5.0.604.0-r2.ebuild
new file mode 100644
index 000000000000..f2e494821062
--- /dev/null
+++ b/sci-mathematics/geogebra-bin/geogebra-bin-5.0.604.0-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop prefix xdg
+
+MY_PV="${PV//./-}"
+
+DESCRIPTION="Mathematics software for geometry"
+HOMEPAGE="https://www.geogebra.org"
+SRC_URI="https://download.geogebra.org/installers/5.0/GeoGebra-Linux-Portable-${MY_PV}.tar.bz2
+ https://dev.gentoo.org/~gyakovlev/distfiles/Geogebra.svg"
+
+LICENSE="Geogebra CC-BY-NC-SA-3.0 GPL-3 Apache-2.0 BSD-2 BSD BSD-4 colt EPL-1.0 icu LGPL-2.1 LGPL-2.1+ MIT W3C || ( GPL-2 CDDL )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+RDEPEND="
+ dev-java/java-config
+ || (
+ dev-java/openjdk:8[javafx]
+ dev-java/openjdk:11[javafx]
+ )
+ !sci-mathematics/geogebra
+"
+
+# no tests
+RESTRICT="test"
+
+src_unpack() {
+ default
+ mv -v GeoGebra-Linux-Portable-* "${P}" || die
+ rm -rf "${P}/jre"* || die
+ rm -f "${P}/geogebra-portable" || die
+}
+
+src_prepare() {
+ eapply_user
+}
+
+src_install() {
+ insinto /opt
+ doins -r geogebra
+ newbin "$(prefixify_ro "${FILESDIR}"/geogebra.sh)" geogebra
+
+ fperms 0755 /opt/geogebra/geogebra
+ doicon "${DISTDIR}/Geogebra.svg"
+ make_desktop_entry geogebra Geogebra Geogebra Science
+}
+
+src_test() {
+ ewarn "package has no tests"
+}
diff --git a/sci-mathematics/geogebra-bin/metadata.xml b/sci-mathematics/geogebra-bin/metadata.xml
new file mode 100644
index 000000000000..0d49beafc75d
--- /dev/null
+++ b/sci-mathematics/geogebra-bin/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>