summaryrefslogtreecommitdiff
path: root/sci-mathematics/mathlib-tools/mathlib-tools-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 00:49:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 00:49:44 +0000
commit4828c25c25aacf399de429d381288982fd7e0d0e (patch)
treea265b5f79cf1b578c4e54483be1466f657f4baba /sci-mathematics/mathlib-tools/mathlib-tools-1.3.0.ebuild
parentf8d671851faf1ca201cec0490ead4642c8987bae (diff)
gentoo auto-resync : 14:11:2022 - 00:49:44
Diffstat (limited to 'sci-mathematics/mathlib-tools/mathlib-tools-1.3.0.ebuild')
-rw-r--r--sci-mathematics/mathlib-tools/mathlib-tools-1.3.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-mathematics/mathlib-tools/mathlib-tools-1.3.0.ebuild b/sci-mathematics/mathlib-tools/mathlib-tools-1.3.0.ebuild
new file mode 100644
index 000000000000..b9439cb1bcca
--- /dev/null
+++ b/sci-mathematics/mathlib-tools/mathlib-tools-1.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Development tools for Lean's mathlib"
+HOMEPAGE="https://github.com/leanprover-community/mathlib-tools"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/${PN}.git"
+else
+ H=1ce2e7143b2456867f4a671a078a4e9af3c73c11
+ SRC_URI="https://github.com/leanprover-community/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${H}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="
+ >=dev-python/GitPython-2.1.11[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.0[${PYTHON_USEDEP}]
+ dev-python/PyGithub[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${BDEPEND}
+ sci-mathematics/lean:0/3
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Remove problematic tests (mainly issues with network)
+ rm ./tests/test_functional.py || die
+
+ distutils-r1_python_prepare_all
+}