summaryrefslogtreecommitdiff
path: root/sci-mathematics/otter/otter-3.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/otter/otter-3.3-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/otter/otter-3.3-r3.ebuild')
-rw-r--r--sci-mathematics/otter/otter-3.3-r3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/otter/otter-3.3-r3.ebuild b/sci-mathematics/otter/otter-3.3-r3.ebuild
new file mode 100644
index 000000000000..eec8a1d25164
--- /dev/null
+++ b/sci-mathematics/otter/otter-3.3-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="An Automated Deduction System"
+HOMEPAGE="http://www.cs.unm.edu/~mccune/otter/"
+SRC_URI="http://www.cs.unm.edu/~mccune/otter/${P}.tar.gz"
+
+LICENSE="otter"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-gold.patch
+)
+
+src_compile() {
+ tc-export CC
+
+ emake -C source
+ emake -C mace2
+}
+
+src_install() {
+ dobin bin/* source/formed/formed
+
+ dodoc README* Legal Changelog Contents documents/*.pdf
+
+ insinto /usr/share/${PN}
+ doins -r examples examples-mace2
+}