summaryrefslogtreecommitdiff
path: root/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild')
-rw-r--r--sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild32
1 files changed, 22 insertions, 10 deletions
diff --git a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
index 2ea39b2a42f1..cf74c8bf763f 100644
--- a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
+++ b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
@@ -1,24 +1,36 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools-utils
+inherit out-of-source
DESCRIPTION="Multiple independent streams of pseudo-random numbers"
HOMEPAGE="http://statmath.wu.ac.at/software/RngStreams/"
-SRC_URI="${HOMEPAGE}${P}.tar.gz"
+SRC_URI="http://statmath.wu.ac.at/software/RngStreams/${P}.tar.gz"
LICENSE="GPL-3"
-SLOT=0
+SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
+
+my_src_configure() {
+ econf --enable-shared --disable-static
+}
+
+my_src_install_all() {
+ if use doc; then
+ HTML_DOCS=( doc/rngstreams.html/. )
+ dodoc doc/${PN}.pdf
+ fi
+ einstalldocs
-src_install() {
- autotools-utils_src_install
- use doc && dohtml -r doc/rngstreams.html/* && dodoc doc/${PN}.pdf
if use examples; then
- rm examples/Makefile*
+ rm examples/Makefile* || die
dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}