summaryrefslogtreecommitdiff
path: root/sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild')
-rw-r--r--sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild b/sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild
new file mode 100644
index 000000000000..495a57f37578
--- /dev/null
+++ b/sci-mathematics/smtinterpol/smtinterpol-2.5_p20211018.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=32d7fa8751f668f9e9a18e4e96df3337b53d2150
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Interpolating SMT-solver that can compute Craig interpolants for various theories"
+HOMEPAGE="http://ultimate.informatik.uni-freiburg.de/smtinterpol/"
+SRC_URI="https://github.com/ultimate-pa/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${H}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8"
+RDEPEND=">=virtual/jre-1.8"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-Version.template-version.patch
+ "${FILESDIR}"/${PN}-build.xml-basename.patch
+)
+
+src_prepare() {
+ default
+ java-pkg-2_src_prepare
+}
+
+src_compile() {
+ eant all
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+
+ einstalldocs
+}