summaryrefslogtreecommitdiff
path: root/sci-mathematics/topcom/topcom-0.17.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-mathematics/topcom/topcom-0.17.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-mathematics/topcom/topcom-0.17.7.ebuild')
-rw-r--r--sci-mathematics/topcom/topcom-0.17.7.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-mathematics/topcom/topcom-0.17.7.ebuild b/sci-mathematics/topcom/topcom-0.17.7.ebuild
new file mode 100644
index 000000000000..97a0cf2de6d5
--- /dev/null
+++ b/sci-mathematics/topcom/topcom-0.17.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Computing Triangulations Of Point Configurations and Oriented Matroids"
+HOMEPAGE="http://www.rambau.wm.uni-bayreuth.de/TOPCOM/"
+SRC_URI="
+ http://www.rambau.wm.uni-bayreuth.de/Software/TOPCOM-${PV}.tar.gz
+ doc? ( http://www.rambau.wm.uni-bayreuth.de/TOPCOM/TOPCOM-manual.html )"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc examples static-libs"
+
+DEPEND="
+ dev-libs/gmp:0
+ >=sci-libs/cddlib-094f"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buildsystem.patch
+)
+
+src_prepare () {
+ # ... and link in tree versions:
+ append-libs -lgmp -lgmpxx -lcddgmp
+
+ find external -delete || die
+
+ default
+}
+
+src_install () {
+ default
+
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*a
+
+ use examples && dodoc -r "${S}"/examples
+
+ docinto /usr/share/doc/${PF}/html
+ use doc && dodoc "${DISTDIR}"/TOPCOM-manual.html
+
+ mv "${ED}"/usr/bin/cube "${ED}"/usr/bin/topcom_cube || die
+}
+
+pkg_postinst() {
+ elog "Due to a file collision with media-libs/lib3ds the helper"
+ elog "'cube' has been installed as topcom_cube (see bug #547030)."
+}