summaryrefslogtreecommitdiff
path: root/sci-mathematics/unuran/unuran-1.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sci-mathematics/unuran/unuran-1.8.1.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sci-mathematics/unuran/unuran-1.8.1.ebuild')
-rw-r--r--sci-mathematics/unuran/unuran-1.8.1.ebuild45
1 files changed, 24 insertions, 21 deletions
diff --git a/sci-mathematics/unuran/unuran-1.8.1.ebuild b/sci-mathematics/unuran/unuran-1.8.1.ebuild
index f3fea32d662e..27d0f064189a 100644
--- a/sci-mathematics/unuran/unuran-1.8.1.ebuild
+++ b/sci-mathematics/unuran/unuran-1.8.1.ebuild
@@ -1,44 +1,47 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools-utils
+inherit out-of-source
DESCRIPTION="Universal Non-Uniform Random number generator"
HOMEPAGE="http://statmath.wu.ac.at/unuran/"
-SRC_URI="${HOMEPAGE}${P}.tar.gz"
+SRC_URI="http://statmath.wu.ac.at/unuran/${P}.tar.gz"
LICENSE="GPL-2"
-SLOT=0
+SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples gsl prng +rngstreams static-libs"
+IUSE="doc examples gsl prng +rngstreams"
DEPEND="
- gsl? ( sci-libs/gsl )
+ gsl? ( sci-libs/gsl:= )
prng? ( sci-mathematics/prng )
- rngstreams? ( sci-mathematics/rngstreams )"
+ rngstreams? ( sci-mathematics/rngstreams:= )"
RDEPEND="${DEPEND}"
-src_configure() {
+my_src_configure() {
local udefault=builtin
use rngstreams && udefault=rngstream
- local myeconfargs=(
- --enable-shared
- --with-urng-default=${udefault}
- $(use_with gsl urng-gsl)
- $(use_with prng urng-prng)
+ econf \
+ --enable-shared \
+ --disable-static \
+ --with-urng-default="${udefault}" \
+ $(use_with gsl urng-gsl) \
+ $(use_with prng urng-prng) \
$(use_with rngstreams urng-rngstream)
- )
- autotools-utils_src_configure
}
-src_install() {
- autotools-utils_src_install
+my_src_install_all() {
use doc && dodoc doc/${PN}.pdf
+ einstalldocs
+
if use examples; then
- rm examples/Makefile*
- insinto /usr/share/doc/${PF}
- doins -r examples
+ rm examples/Makefile* || die
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
fi
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}