summaryrefslogtreecommitdiff
path: root/sci-mathematics/why3-for-spark/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sci-mathematics/why3-for-spark/files
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sci-mathematics/why3-for-spark/files')
-rw-r--r--sci-mathematics/why3-for-spark/files/why3-for-spark-2021-flags.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-mathematics/why3-for-spark/files/why3-for-spark-2021-flags.patch b/sci-mathematics/why3-for-spark/files/why3-for-spark-2021-flags.patch
new file mode 100644
index 000000000000..7f6dfd0f446f
--- /dev/null
+++ b/sci-mathematics/why3-for-spark/files/why3-for-spark-2021-flags.patch
@@ -0,0 +1,28 @@
+--- a/Makefile.in 2020-06-12 21:03:33.375534124 +0200
++++ b/Makefile.in 2020-06-12 21:03:48.623283408 +0200
+@@ -127,7 +127,7 @@
+
+ WARNINGS = A-4-9-41-44-45-50-52@5@8@48
+
+-FLAGS = -w $(WARNINGS) -safe-string -keep-locs -bin-annot -dtypes -g -thread $(INCLUDES)
++FLAGS = -w $(WARNINGS) -safe-string -keep-locs -bin-annot -dtypes -g -thread $(INCLUDES) -cclib "$(LDFLAGS)" -ccopt "$(CFLAGS)"
+ OFLAGS = $(FLAGS)
+ BFLAGS = $(FLAGS)
+
+@@ -778,13 +778,13 @@
+ all: $(TOOLS)
+
+ lib/why3server$(EXE): $(SERVER_O)
+- $(CC) -Wall -o $@ $^
++ $(CC) -Wall $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ lib/why3cpulimit$(EXE): $(CPULIM_O)
+- $(CC) -Wall -o $@ $^
++ $(CC) -Wall $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ %.o: %.c
+- $(CC) -Wall -O -g -o $@ -c $<
++ $(CC) -Wall $(CFLAGS) -O -g -o $@ -c $<
+
+ uninstall-bin::
+ rm -f $(LIBDIR)/why3/why3server$(EXE) $(LIBDIR)/why3/why3cpulimit$(EXE)