summaryrefslogtreecommitdiff
path: root/sci-mathematics/z3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-20 00:15:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-20 00:15:26 +0000
commit1534d50aaf24272ec425fa439389ef7e1f7bf174 (patch)
treec48ca34f49e5c335c0d06b96d9f09d4a74e144d5 /sci-mathematics/z3
parent2e512e4e32285f8c4eb19586d014cb9d31454ec9 (diff)
gentoo auto-resync : 20:02:2025 - 00:15:26
Diffstat (limited to 'sci-mathematics/z3')
-rw-r--r--sci-mathematics/z3/Manifest2
-rw-r--r--sci-mathematics/z3/z3-4.14.0.ebuild107
2 files changed, 109 insertions, 0 deletions
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index 21d40d1ab1a1..2c212476e25c 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,3 +1,5 @@
DIST z3-4.13.4.tar.gz 5766645 BLAKE2B 99e22754a7b7333868b713d78677de5d8c8ed7fdf15f0a60c224cca49bd89022e80dee86aa23f96cb7ec052ef1286ec6e2d025a6e336001d4c0d09cfce50ac55 SHA512 fd554122f3bb65e5d6622e2e331546d24892dfd3e5310bc4e041bd1c61fecfe53dbb487e4b125d87367338cacc9e06f28c71f380aac5fe8a74f4b45aaa27b6ce
+DIST z3-4.14.0.tar.gz 5841848 BLAKE2B fc56ab4538a8fa07fd7ea34fdd403a13941f93fee500e90686cfc827b5094d83662ad02fda0c9ff146cb425603a3d65aadc1c006d26dd40c8cbd91462381670a SHA512 5a3de3207b5c05f77f8369d7fdbb9e13a7db850f8c3edaa8f2adfcf58b186d34409e4a56d44646f853027850941135be5042e67a53ddf3302dc3b645c1ab3db4
EBUILD z3-4.13.4.ebuild 2606 BLAKE2B 4d1558de478d4cde52c6202ce2dabb22645a71cee0782daf78bf36ca879b8bd539f9a95a9cbbfa9b7a0b0b08d780239bba50b5eb83c876071d5a993fb30c599b SHA512 210add2e050e469860ced42ddd316061646fcc8e9cba78cfc1ef0b6c9ad4ca9cc82ecee73a291c0fa290ed879b5b09c81b3b61afaf90dd2431700d8a7944a337
+EBUILD z3-4.14.0.ebuild 2612 BLAKE2B 2199cfdeaa07a1dc9a22a3a07bdb77645b65632b70a520b966d74ba56beb8499b50f95b6608b48b3cea2f548186217c46fc3d9394980904b875fb01837fd4878 SHA512 88bdeb3290537b666e5453de807e466a6020f7f5dc76fb804b9b635006d1e9300980ef2405377b6b4a90152ee5720bdf68d12d092ae2272932ed2f1fe2df840b
MISC metadata.xml 1718 BLAKE2B a94783909c12aa7dd2d5fd1f9d2fc75e20ca91b6abffd6dc020f602e57ef698f7184acaf14def4b6e21bb659e595abd44956ba37a679134d11b523103b0461df SHA512 ed375986a8010a7ae1eadab3107342126194a5513cbb22ce2064ffeff42c7184ea94f4f69017204c73bd61236847475cd1f0d8b3ba369236b26630dc8b2f46a2
diff --git a/sci-mathematics/z3/z3-4.14.0.ebuild b/sci-mathematics/z3/z3-4.14.0.ebuild
new file mode 100644
index 000000000000..759a8f720476
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.14.0.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit cmake-multilib java-pkg-opt-2 python-single-r1
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0=[cxx(+),${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ java? ( >=virtual/jdk-1.8 )
+"
+BDEPEND="
+ doc? ( app-text/doxygen[dot] )
+"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_prepare() {
+ cmake_src_prepare
+ java-pkg-opt-2_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ -DZ3_USE_LIB_GMP=$(usex gmp)
+ -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
+ -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
+ -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+ -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+ -DZ3_INCLUDE_GIT_DESCRIBE=OFF
+ -DZ3_INCLUDE_GIT_HASH=OFF
+ )
+
+ multilib_is_native_abi && use java && mycmakeargs+=( -DJAVA_HOME="$(java-config -g JAVA_HOME )" )
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+multilib_src_install_all() {
+ dodoc README.md
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}