summaryrefslogtreecommitdiff
path: root/sci-mathematics/z3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sci-mathematics/z3
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sci-mathematics/z3')
-rw-r--r--sci-mathematics/z3/Manifest4
-rw-r--r--sci-mathematics/z3/metadata.xml3
-rw-r--r--sci-mathematics/z3/z3-4.8.8.ebuild95
3 files changed, 98 insertions, 4 deletions
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index e0199dadd995..9e05c62bbb36 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,3 +1,5 @@
DIST z3-4.8.6.tar.gz 4328752 BLAKE2B 4932670f3c1ab9bdba18a6ad80f4fd8812eb70d71705ebdf1f93c3b052ffb632dc10e4f7f4043f098af214288d6d4a4a26ef7f8cc0d1183c9f27b14ef1787c46 SHA512 d338413274a3d11a9e9287202989df9da4c31e095c14428a418d4019e9f86c0e2b681c519d2d0bcbb4cd99a722a2539006f5c86ade568b1ee208545b142369f1
+DIST z3-4.8.8.tar.gz 4520119 BLAKE2B 8d3d9fac61ac7d5a9d8c44323db9f67a7b24ee510b12e67867b249062cbcfe9a3bd0fa3b24c03c9eccd2aaf90451083ff5e9a9253a87c3e8e943fc5cf08a1893 SHA512 a6823cadb7cdad11b8f0db1530676c0ec4853886dfb3c4dbc5b798c5dbd445afb0c61675f81cb7f99c1b1734d9cd0ec96a07c68a948da3c25801fc6767fea47f
EBUILD z3-4.8.6.ebuild 2335 BLAKE2B e980e31d4d6ab4443b7b385c66aa1a71ab062d4783e1947d1a2d9688986729a19769813e22cb7395d9a8a1a45e1fb898da1a8e6c923c8486aa8dccd601f9874b SHA512 214122932dcbb1cef0e3d3617e37e3057936b28afc7d70fff2fe08bfcaad963516d48f20fe65efaf80729f5ab070b562aa574c163f908c82b620846e5cda7982
-MISC metadata.xml 862 BLAKE2B 1d219fcfb0772a48ec398a51b8916748db336730b91b66e336e8df0b8522b9a47df718d6303aff5f305b699e9297aaad9b352c69d529a93f66cf2a1b76c8f094 SHA512 2a5cc11ae87199a23c72ffb7366c65cbb33683bb6ad142d1df84a65b56bd69f50907bca69f066a1c860947254c241089521c026bac9ff92bd405038c266907ef
+EBUILD z3-4.8.8.ebuild 2415 BLAKE2B fa4d5fe952685eb5d8d2aa1f679b008e6887c0eaa25ec7101635db290b33ae5c5936216b5cd1ba11cf49006ac1de242a566e7b47923e608dbace24c6c5b85d08 SHA512 b4e757bfdf1a252f0b33f28fb1dd470025966dd16cf77e5925d0e52a30011672475097789d46557fcddce00cf5d308c9f417f6da858c2a66965933547c2d4d75
+MISC metadata.xml 732 BLAKE2B dec39a80325f9dba9e79d65f448d828c3ee19327a1a12505e487a39fd58fb49f47446e439d713a9fa2603bc971f22f4eb8c1a12e93e18281aeba5e183642add8 SHA512 7d081840634a8dc578acc60c4b85ef1a35f025c2ac251d2f7633a807af7395061ef4fb96716e96a96a876ae318b52333dfc0200fa1e72e35889433676a56e58b
diff --git a/sci-mathematics/z3/metadata.xml b/sci-mathematics/z3/metadata.xml
index 15735c68e920..65ab90b88bdf 100644
--- a/sci-mathematics/z3/metadata.xml
+++ b/sci-mathematics/z3/metadata.xml
@@ -15,9 +15,6 @@
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
- <longdescription lang="en">
-Z3 is a high-performance theorem prover being developed at Microsoft Research.
- </longdescription>
<use>
<flag name="isabelle">Add integration support for the Isabelle/HOL
theorem prover.</flag>
diff --git a/sci-mathematics/z3/z3-4.8.8.ebuild b/sci-mathematics/z3/z3-4.8.8.ebuild
new file mode 100644
index 000000000000..949c33e2e2b1
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.8.8.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake-multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0=[cxx,${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.8 )"
+BDEPEND="
+ doc? ( app-doc/doxygen )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+ -DZ3_USE_LIB_GMP=$(usex gmp)
+ -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
+ -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
+ -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+ -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+ -DZ3_INCLUDE_GIT_DESCRIBE=OFF
+ -DZ3_INCLUDE_GIT_HASH=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ cmake-utils_src_make test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+multilib_src_install_all() {
+ dodoc README.md RELEASE_NOTES
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}