summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-25 20:34:27 +0000
commit0f15659d48c193027158492acb726297501202c5 (patch)
tree5502ba879a78b759da28441d418dbbfe08bd8f03 /sci-mathematics
parent93a93e9a3b53c1a73142a305ea1f8136846942ee (diff)
gentoo xmass resync : 25.12.2021
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin14650 -> 15155 bytes
-rw-r--r--sci-mathematics/primecount/Manifest3
-rw-r--r--sci-mathematics/primecount/metadata.xml24
-rw-r--r--sci-mathematics/primecount/primecount-7.2.ebuild48
-rw-r--r--sci-mathematics/primesieve/Manifest3
-rw-r--r--sci-mathematics/primesieve/metadata.xml24
-rw-r--r--sci-mathematics/primesieve/primesieve-7.7.ebuild50
-rw-r--r--sci-mathematics/singular/Manifest3
-rw-r--r--sci-mathematics/singular/files/singular-4.2.1-htmldoc.patch43
-rw-r--r--sci-mathematics/singular/singular-4.2.1_p3.ebuild122
-rw-r--r--sci-mathematics/verit/Manifest3
-rw-r--r--sci-mathematics/verit/metadata.xml16
-rw-r--r--sci-mathematics/verit/verit-2021.06.2.ebuild26
-rw-r--r--sci-mathematics/z3/Manifest2
-rw-r--r--sci-mathematics/z3/z3-4.8.14.ebuild103
15 files changed, 470 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index ad64b07f4753..dee72830f374 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/primecount/Manifest b/sci-mathematics/primecount/Manifest
new file mode 100644
index 000000000000..bdc617c4b895
--- /dev/null
+++ b/sci-mathematics/primecount/Manifest
@@ -0,0 +1,3 @@
+DIST primecount-7.2.tar.gz 340799 BLAKE2B 5ce3661e322be363e2fe79de1dd134b5c3009269cbb10d36dc69bee4c23c9f41d2117b3ed7aa4c5f852e494832573c84a8d9c37cbe92cf80a5024bdec9b22c69 SHA512 df14929012434eddfab94410ba9165642094327f8abd139a6a1ba87e508bba56df91cb0dc9411e873e90a9aa4aa3ba4007396c930d593f5954be8c715fa26e84
+EBUILD primecount-7.2.ebuild 1095 BLAKE2B 94949133a99b3977d6c4fb8c1b788bddc32facf6de3c5986622461788773688bab38336a0464dd16b8623b533aa2e9907564b9e28fb6a6279ba40c134cd00fbf SHA512 099f3065274d951b11606b02408d9cf87ea68994bf451edf23f79150bd13d83ecdf9449efbe16f149ed4265c6265e255e1a14b608641f4f5114eb70a15a0ddaf
+MISC metadata.xml 673 BLAKE2B dcb9633d5529d3c78afaf761812f38a370496a861e5391190f9c2059bde94ca6628b5d751eeab4c0832bebeec421825019671d0a9a815e269691922b23f3ce2b SHA512 fdbebd019bfd1d06e505900b2061b6a8597f62b2b979f337c07c7bd9084181004183595e05e9381800c02981ec584fef3454a5c98ceeeb76009887f5acb9dfb7
diff --git a/sci-mathematics/primecount/metadata.xml b/sci-mathematics/primecount/metadata.xml
new file mode 100644
index 000000000000..524d8bf2ac66
--- /dev/null
+++ b/sci-mathematics/primecount/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <use>
+ <flag name="executable">Build the primecount CLI executable</flag>
+ </use>
+
+ <upstream>
+ <remote-id type="github">kimwalisch/primecount</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/primecount/primecount-7.2.ebuild b/sci-mathematics/primecount/primecount-7.2.ebuild
new file mode 100644
index 000000000000..1e394a48459e
--- /dev/null
+++ b/sci-mathematics/primecount/primecount-7.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Highly optimized CLI and library to count primes"
+HOMEPAGE="https://github.com/kimwalisch/primecount"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/7" # subslot is first component of libprimecount.so version
+KEYWORDS="~amd64"
+IUSE="+executable openmp test"
+RESTRICT="!test? ( test )"
+
+DEPEND="sci-mathematics/primesieve:="
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/Credits.md
+ doc/Easy-Special-Leaves.md
+ doc/Hard-Special-Leaves.md
+ doc/Records.md
+ doc/References.md
+ doc/alpha-factor-dr.pdf
+ doc/alpha-factor-gourdon.pdf
+ doc/alpha-factor-lmo.pdf
+ doc/libprimecount.md
+)
+
+pkg_pretend() {
+ use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_LIBPRIMESIEVE="OFF"
+ -DBUILD_PRIMECOUNT="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ -DWITH_OPENMP="$(usex openmp)"
+ )
+
+ cmake_src_configure
+}
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
new file mode 100644
index 000000000000..dd47d10bcb26
--- /dev/null
+++ b/sci-mathematics/primesieve/Manifest
@@ -0,0 +1,3 @@
+DIST primesieve-7.7.tar.gz 101558 BLAKE2B cfaa91ddcf661e265d403f8a93461fe297ac48db843b096d0dd7828c4e3d11cdba60cb102197248359c79950fe2ac66c8e9295ab17b0d6bd0eed5a6260c7d115 SHA512 bbcc141a12afdf54386d2408e067b1c6af2dd9b5c9f44d71290269ddefc7c46ba6794064cde6728c8356724553cb6bc2e765bf18c24a18b6d5d1f472d2c6e6dd
+EBUILD primesieve-7.7.ebuild 1048 BLAKE2B bf12c35f6e722cb0f7dec8d3a141135668cbd460f59d9048dbd142b046ba85a0bb0d3bebd6f7063131bd299904da74285aa17839c4a9965e91efd56fab1abeb7 SHA512 71964a60f46c34240acbf715c5a023118d0a5fb79d5c47423ec60724d6d229c3c68d5b44306a24eb31f31f9a42d05b3a60c4e77856be49d27d62ac579b16eacc
+MISC metadata.xml 671 BLAKE2B 66f6291e855c6ae971e436b1499e66295c5dd8ed8ae2f82f2383c7379abba2e1a42697bef34acb264b7ee962df6fd71f5d3231ae59deb7c48dd73cd5842a6ccd SHA512 0bc2a3ef693ee89e59046541754f7fb08be9c96fe94b5679254e43d9f89391c0a65271eb82c5c9163a6b80843f7477d56ab4911bafe57ec8c61179f9dde59277
diff --git a/sci-mathematics/primesieve/metadata.xml b/sci-mathematics/primesieve/metadata.xml
new file mode 100644
index 000000000000..e2285b80a8b4
--- /dev/null
+++ b/sci-mathematics/primesieve/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <use>
+ <flag name="executable">Build the primesieve CLI executable</flag>
+ </use>
+
+ <upstream>
+ <remote-id type="github">kimwalisch/primesieve</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/primesieve/primesieve-7.7.ebuild b/sci-mathematics/primesieve/primesieve-7.7.ebuild
new file mode 100644
index 000000000000..5d26f8b6a858
--- /dev/null
+++ b/sci-mathematics/primesieve/primesieve-7.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="CLI and library for quickly generating prime numbers."
+HOMEPAGE="https://github.com/kimwalisch/primesieve"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/9" # subslot is first component of libprimesieve.so version
+KEYWORDS="~amd64"
+IUSE="doc +executable test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen app-text/texlive media-gfx/graphviz )"
+DEPEND=""
+RDEPEND=""
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/ALGORITHMS.md
+ doc/CPP_Examples.md
+ doc/C_Examples.md
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOC="$(usex doc)"
+ -DBUILD_PRIMESIEVE="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ if use doc; then
+ DOCS+=(
+ "${BUILD_DIR}/doc/html"
+ "${BUILD_DIR}/doc/latex/refman.pdf"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_build doc
+}
diff --git a/sci-mathematics/singular/Manifest b/sci-mathematics/singular/Manifest
index 5571db7e3268..00d930c99119 100644
--- a/sci-mathematics/singular/Manifest
+++ b/sci-mathematics/singular/Manifest
@@ -4,11 +4,14 @@ AUX singular-4.1.3-doc_install.patch 2834 BLAKE2B d8e35169534ed9087fc1faf6029a11
AUX singular-4.2.0-doc_install-v2.patch 2918 BLAKE2B 9b844a51165425e696db1270dcbdf6343356c313e797cee04bf8c0bad3c0c659302a88866877b729d50ba2e5717b4a1ec209f8ff57c1f71509e551ccc780f4bf SHA512 fc3aaf5b330057b1283a877d1ee5c97e6088a2eadfeaa2d85667ca3f8c661f400d52f7e29eb27da94c6be7b9809f8aea88dc2e33affc4b3a29d334b3e5798e78
AUX singular-4.2.0-gfan_linking.patch 1849 BLAKE2B 11a4ed33cab5265a3b5650270511ff38cd36422fea07ad0ae5f229761e31229d8ed61fa278d47b1326abc0919c85522d80f8085d3f2019463ae50fa48589c837 SHA512 bc1635cc592c5b624c87bfffbafb8d1c1cc094e2e629027c89255552ec15918bbdc3275605f8612cc418d4efc58efa46465d286cd9118cdf06a079ba40ff52ae
AUX singular-4.2.0-no-static.patch 2644 BLAKE2B 466705130179efe13cd4bdccb09e0bc2a5a0efaf36536009054235f6a44af932c359cee366eef860235739c480fea84e9ca48947597d2c3aaf2e26bdb3fada88 SHA512 53dd7045d717f62817b0fd03963a8cf2ba4e88387b89e854a1cc6a2817bf975fd7e16852e948b64182d049b8c184459d4e071bbb5f8c6ca5998c4c1b964deef5
+AUX singular-4.2.1-htmldoc.patch 2086 BLAKE2B 28ab2e8ef9ad2ff1343d3efd33917503c00fb74428f35b1ab0fb1475368d3760d3c915668d4fb008ccc618e2aa1c13a35f66d3a62f8c3abe93b5275f1648c8e7 SHA512 5c28c31bc51a937ddff4e52da3ed93f20516b64ac6abfc05031d09e708e557268e757c55e625abfd77c19600f64a7f284903de619c113a57194367e23148ff82
DIST singular-4.2.0p1.tar.gz 14155171 BLAKE2B 444553f87d7ca8d6a62e4519c9857a6892757e92285df7c3b686913a9b51c9ae8d802c41382b0b2b6e37dc2dc496d4a10f262c98407470219cdce131e8baf127 SHA512 2ecd8940c9e8d70a93dbdb4df6da313c00151e5cb959f8eed5856e8df99089b5a03e514fbcdc70903c77df8b59fa7ef9f3b134f1de510b795fa6ea0341089bd8
DIST singular-4.2.0p3.tar.gz 16641923 BLAKE2B 4dd7e1a42c71bbba625e171aee656580b443656f50458909ffae1af81b1413d5330aa032656032ea365225eb088491fe2a48997895e37bc89eea5f17b8fbebb8 SHA512 b9833389b648ec4ba2bd09253f00254b9ae3dc61313fc81c9003b283fc413caab4274e55750de1c342ef24a8fc0ce817643cd31eabbb2999de7f5017dfa1411f
DIST singular-4.2.1.tar.gz 16643430 BLAKE2B 2cfc33bd59a5e8756c7ce022ad2b38477a0d7a6747b3c4fd4b1b168cfd179ace52121506cda2c4d5f318abca72231c74f649ede349b17b5f138083428d9da766 SHA512 48bebbe9c886ee56bb2f7bdd9e356bd33e357a2d707c976b8496200f422a2ba25d7c9bba22a261574428abf73a8b6b111d35236fca647e32619659059e861916
+DIST singular-4.2.1p3.tar.gz 15042102 BLAKE2B 9958c1c432f8a3516387cfe7b258d2e22e8e9fdf3874de53a803b34e353088a3ce246a90b78db43f186717985b503d2355f524ee80784e63b186d53217fdeead SHA512 1e6533fcf966499e9ad145b640e7e5878eb9738bd65535aaa517c5e98dedb09bc99bf832359e9b6dca2fff615237f855bd861820e592a885341aa82e7a9a9168
EBUILD singular-4.2.0_p1.ebuild 2259 BLAKE2B 2237245fe2550f398a20a14ae599bcc668288aa6312925cee725e2571dc53f8f62f88bdff0cdf8cd303c72baaf2861a2c560ce54978da720e93cbe459769b7d1 SHA512 2a6b8e478f32ff9e3df96e0188cd137b16d9be1a8c18c9f5367a81b96dc8b0cc01d34771246001eee9e8ec9832f8832539e921879ec56fe8a51ebb42c0d29389
EBUILD singular-4.2.0_p3-r1.ebuild 2428 BLAKE2B af72aae39de23df410fe1d6dfe475c3179f6355fffe1775d4d408bec6fe80aa37022e6a9838a45014488666b56cfaa627f1fc1d007d360fbbe6987f4b3ead197 SHA512 0921b4991019b449054fb7c7c60a9bd39ec6434a19321b79f63470f2e15889945f24bc15f48e12ba16a24ff23c368a73b0b062d0150104d39aa715511766bc55
EBUILD singular-4.2.1-r1.ebuild 2679 BLAKE2B 8e24286895a237762fc61ed6cfa7ec723ba9d06f25eb6ef8d228747f7658c487c6c29dc9c6fe93c4864d3e9ceaf61d3edbc023c326f83556095f6e62082220ba SHA512 dcc37fe96e0c3a50661c81eeb9ff7fc31aa5dba023712c5c922cdf3529410b854039a9644ffa7bfe4b9d7951b797a60ce7faa9477bfb0e8743f8f8edaab2c448
EBUILD singular-4.2.1.ebuild 2571 BLAKE2B 7ccf61735ce3bfd5472b646dceb77239430d44bff9816ea2c1a5cd1cd4807c0138ec2396a193c98b7c3b456a36ee72c6351ff95f949f3afa318b5955a14a014b SHA512 1aad8be5aee15235c8f4a865ec8e3e19c3cac61ae6c8db39e7a7f614119fa2dfc1869a7ce9cc6fb896a5ffb455c65e90b2fc91cf98d5b0a3e193941deadc807c
+EBUILD singular-4.2.1_p3.ebuild 2672 BLAKE2B fb85c13b5f625b1a674aa912ba447931befcb3707a453aacdff8dc0ad38cb619d9bfb6d0d374a3d89e7049f1370788807591dd9d4f98fece569f19066dfdbf9b SHA512 f24886bdb006b4a362c1e8915666599f6d8c27218ce8dd7ce6717f9134fa286db02586d26001ec7779375107edfa81c560a271f1a50e0c8780bacfc3a885aded
MISC metadata.xml 580 BLAKE2B 25a2f7adf99e9469811f49d1493b274298d2219874aca83e0569a8ca079514659338543a2dd002d5038b2c9b3cdae44772021e2bc1b0340c6237974744ade4a5 SHA512 385646f40f3a741faae6db06eacff9837608cd5860bbeadbbdfd7e0ff847f0a214a5b8373ea549f6463e0e29931b018af36c86394aa894dba10d1e691ada3902
diff --git a/sci-mathematics/singular/files/singular-4.2.1-htmldoc.patch b/sci-mathematics/singular/files/singular-4.2.1-htmldoc.patch
new file mode 100644
index 000000000000..7eedee90dcf2
--- /dev/null
+++ b/sci-mathematics/singular/files/singular-4.2.1-htmldoc.patch
@@ -0,0 +1,43 @@
+diff --git a/configure.ac b/configure.ac
+index 6b75a34..5e932b8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -228,6 +228,11 @@ AX_NORMALIZE_PATH([config_datadir],['/'])
+ AC_DEFINE_UNQUOTED([DATA_DIR],"$config_datadir",[datadir])
+ AC_SUBST(DATA_DIR, "$config_datadir")
+
++AX_RECURSIVE_EVAL([[$]docdir], [config_docdir])
++AX_NORMALIZE_PATH([config_docdir],['/'])
++AC_DEFINE_UNQUOTED([DOC_DIR],"$config_docdir",[docdir])
++AC_SUBST(DOC_DIR, "$config_docdir")
++
+ SING_SHOW_FLAGS([Compiler/linker flags: ])
+
+
+diff --git a/resources/configure.ac b/resources/configure.ac
+index bde2baa..9f9c966 100644
+--- a/resources/configure.ac
++++ b/resources/configure.ac
+@@ -72,5 +72,9 @@ AX_RECURSIVE_EVAL([[$]datadir], [config_datadir])
+ AX_NORMALIZE_PATH([config_datadir],['/'])
+ AC_DEFINE_UNQUOTED([DATA_DIR],"$config_datadir",[datadir])
+
++AX_RECURSIVE_EVAL([[$]htmldir], [config_htmldir])
++AX_NORMALIZE_PATH([config_htmldir],['/'])
++AC_DEFINE_UNQUOTED([HTML_DIR],"$config_datadir",[htmldir])
++
+ AC_CONFIG_FILES([singular_resources.pc Makefile])
+ AC_OUTPUT
+diff --git a/resources/feResource.cc b/resources/feResource.cc
+index 0eaa6fa..3309386 100644
+--- a/resources/feResource.cc
++++ b/resources/feResource.cc
+@@ -78,7 +78,7 @@ VAR feResourceConfig_s feResourceConfigs[] =
+ {"DefaultDir",'d', feResDir, "SINGULAR_DEFAULT_DIR", SINGULAR_DEFAULT_DIR, (char *)""},
+ {"InfoFile", 'i', feResFile, "SINGULAR_INFO_FILE", "%D/info/singular.info", (char *)""},
+ {"IdxFile", 'x', feResFile, "SINGULAR_IDX_FILE", "%D/singular/singular.idx", (char *)""},
+- {"HtmlDir", 'h', feResDir, "SINGULAR_HTML_DIR", "%D/singular/html", (char *)""},
++ {"HtmlDir", 'h', feResDir, "SINGULAR_HTML_DIR", HTML_DIR, (char *)""},
+ {"ManualUrl", 'u', feResUrl, "SINGULAR_URL", "https://www.singular.uni-kl.de/Manual/", (char *)""},
+ {"ExDir", 'm', feResDir, "SINGULAR_EXAMPLES_DIR","%r/examples", (char *)""},
+ {"Path", 'p', feResPath, NULL, "%b;%P;$PATH", (char *)""},
diff --git a/sci-mathematics/singular/singular-4.2.1_p3.ebuild b/sci-mathematics/singular/singular-4.2.1_p3.ebuild
new file mode 100644
index 000000000000..451f17e9f05a
--- /dev/null
+++ b/sci-mathematics/singular/singular-4.2.1_p3.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools elisp-common flag-o-matic
+
+MY_PN=Singular
+MY_PV=$(ver_rs 3 '')
+# Consistency is different...
+MY_DIR2=$(ver_cut 1-3 ${PV})
+MY_DIR=$(ver_rs 1- '-' ${MY_DIR2})
+
+DESCRIPTION="Computer algebra system for polynomial computations"
+HOMEPAGE="https://www.singular.uni-kl.de/ https://github.com/Singular/Singular"
+SRC_URI="ftp://jim.mathematik.uni-kl.de/pub/Math/${MY_PN}/SOURCES/${MY_DIR}/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_DIR2}"
+
+LICENSE="BSD GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE="emacs examples julia polymake +readline static-libs"
+
+RDEPEND="
+ dev-lang/perl
+ dev-libs/gmp:0
+ dev-libs/ntl:=
+ sci-libs/cddlib
+ sci-mathematics/flint
+ emacs? ( >=app-editors/emacs-23.1:* )
+ julia? ( dev-lang/julia )
+ polymake? ( sci-mathematics/polymake )
+ readline? ( sys-libs/readline )
+"
+DEPEND="${RDEPEND}"
+
+SITEFILE=60${PN}-gentoo.el
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.2.1-htmldoc.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Needed to avoid segfaults in the test suite until
+ #
+ # https://github.com/Singular/Singular/issues/1105
+ #
+ # makes its way into a release.
+ append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
+
+ local myconf=(
+ --disable-debug
+ --disable-doc
+ --disable-optimizationflags
+ --disable-pyobject-module
+ --disable-python
+ --disable-python-module
+ --disable-python_module
+ --enable-factory
+ --enable-gfanlib
+ --enable-libfac
+ --with-flint
+ --with-gmp
+ --with-libparse
+ --with-ntl
+ --without-python
+ --without-pythonmodule
+ $(use_enable emacs)
+ $(use_enable julia)
+ $(use_enable polymake polymake-module)
+ $(use_enable static-libs static)
+ $(use_with readline)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ pushd "${S}"/emacs
+ elisp-compile *.el || die "elisp-compile failed"
+ popd
+ fi
+}
+
+src_install() {
+ # Do not compress singular's info file (singular.hlp)
+ # some consumer of that file do not know how to deal with compression
+ docompress -x /usr/share/info
+
+ default
+
+ dosym Singular /usr/bin/"${PN}"
+
+ # purge .la file
+ find "${ED}" -name '*.la' -delete || die
+}
+
+src_test() {
+ # SINGULAR_PROCS_DIR need to be set to "" otherwise plugins from
+ # an already installed version of singular may be used and cause segfault
+ # See https://github.com/Singular/Sources/issues/980
+ SINGULAR_PROCS_DIR="" emake check
+}
+
+pkg_postinst() {
+ einfo "Additional functionality can be enabled by installing"
+ einfo "sci-mathematics/4ti2"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/verit/Manifest b/sci-mathematics/verit/Manifest
new file mode 100644
index 000000000000..33bd4ca29d74
--- /dev/null
+++ b/sci-mathematics/verit/Manifest
@@ -0,0 +1,3 @@
+DIST verit-2021.06.2-rmx.tar.gz 683775 BLAKE2B e7488ef11f37c4312dc3bb7809c8f4a134c70e0cb893a9127235e5bd660e3cf88648d5af598f650d25aed02eb864c171479a570b4e47b96ab2bb5f6aba3e6926 SHA512 4dfdbcf12fefaba13f5540a08a520e15666ca3bb923483b86eac708cf23bd5d8441d9a687487ae38f9bbdbc023beedf3e503800e99622cb71fb086329c047a4d
+EBUILD verit-2021.06.2.ebuild 508 BLAKE2B 6ac727f550f8fa0c81b70e509e2381e26eee8745b3c16f7626b0f02408bac78b0b2cd88b11c99f815f9439e0454d714254c0b3fa56ec0a063369e74048ba422a SHA512 60e00146bf88f2d93b9a5ec476568700154df6a70b67b85fe3c37bee495546cddc6942b3d5a1659c4252e1a22073d5c776452548cf1bc6d2812834d92faae80f
+MISC metadata.xml 628 BLAKE2B a23cb8e317e25706a6aef22a09639ab69d5255d624dee52234070050ce571bf41d6ad14c06808905c59632fc3fab429c4b6cabb7e06dfec08a7ebf7ff538b5bb SHA512 7d612a0cf762d81799fe3954bedd02c6d7392d20fff12bf1f515723889fec0aa59d4494c6f939c4166ad72f6ec6202b62fa9c8ff91695bc28d9d26f447c6b229
diff --git a/sci-mathematics/verit/metadata.xml b/sci-mathematics/verit/metadata.xml
new file mode 100644
index 000000000000..cd0a6cfe1019
--- /dev/null
+++ b/sci-mathematics/verit/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ veriT is a SMT (Satisfiability Modulo Theories) solver. It is open-source,
+ proof-producing, and complete for quantifier-free formulas with
+ uninterpreted functions and linear arithmetic on real numbers and integers.
+ It also offers good support for quantifiers.
+ The input format is the SMT-LIB 2.0 language and DIMACS.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/verit/verit-2021.06.2.ebuild b/sci-mathematics/verit/verit-2021.06.2.ebuild
new file mode 100644
index 000000000000..bd4092215917
--- /dev/null
+++ b/sci-mathematics/verit/verit-2021.06.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="An open, trustable and efficient SMT-prover"
+HOMEPAGE="https://verit.loria.fr/"
+SRC_URI="https://verit.loria.fr/download/${PV}/${P}-rmx.tar.gz"
+S="${WORKDIR}/${P}-rmx"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/gmp:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+
+ mv example examples || die
+ insinto /usr/share/${PN}
+ doins -r examples
+}
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
index c3422162c44f..a8bfa9189478 100644
--- a/sci-mathematics/z3/Manifest
+++ b/sci-mathematics/z3/Manifest
@@ -1,5 +1,7 @@
DIST z3-4.8.11b.tar.gz 4801435 BLAKE2B 903a04246fe4dedc96fda653fa9e3a57a80b951d20b992306bd07bc778cf0a94cf36fe4ed3f178bb26196a1ca294834c784a117fe906d52b82f874a43869d110 SHA512 dfcfc85209dd00aa5f07de0a7e7186a33442b72b94b05c01f53350b9281551be2a2c21ad5e7814bc2c52a3329be8df578e6be8c387cbfdc3a9d3bef0611d6613
DIST z3-4.8.13.tar.gz 5103999 BLAKE2B 5500bbc71e7a863092a36bdd2bc04f5a4435e9d8fdc62c7956aa2546ffa9e39344c9528bf802f6e4c211c799e873f2673dbf8b113599dcbb694ac040ada2e9a0 SHA512 c5e8f34525ed3b6b2935d7f01ce2f90f5dd99b4cdd035664b36c967fb1c7f3b05abed45c7288e2261723e73d68728ee91a0f67d92012d86b04598d7b54369c30
+DIST z3-4.8.14.tar.gz 5113598 BLAKE2B c6a82cec33e879123c33506897ac02be682d08a6432da0b11c6918f2664fd7249d8874ccb6f543907f789cc3b40b126465548abeabf4ac16d2ee791ce179742a SHA512 10170516ca472258d2f9df28cd036e43023a76a25f1e1670290c62f3890d935bf82770970054a5fd3a0f02559409e7ed4b18fb08347c040ff2f9e0918e152aab
EBUILD z3-4.8.11b.ebuild 2610 BLAKE2B 62e0920d9e4ba69c65fff37bdc74c70f7177853f3b8ff61b2f4a50dd09d72d0f42ffcf71da152e2c5b80d1ff4e26b96d683f10a439c8a8270cc8f6dc50fb3faf SHA512 457a93cfee6bb224e5d1987a7ecaeba18f3f478ac26a222ed4c93e249225c46834d07800e9049931833e01d8ce1e5fadca09ab24df261fbc4b1165e1290845f9
EBUILD z3-4.8.13.ebuild 2599 BLAKE2B 7d4b057cf1b8a9853db7d5f482a7457cd55fe1e4c3bdaa727db86fa69d0d144ccb2de9e25e51f34c7edb7c3487e6b0f4a51a76890dc309820e8096e39d7d9f01 SHA512 3c40f3b590e1d46defc757c6133136693e5ee5129949dfd1f7dbf49bc7e0634c591c2ba6e0758b0a0e9b979425c9501864020e4e12cc685ce963d74d5b2b6889
+EBUILD z3-4.8.14.ebuild 2599 BLAKE2B 7d4b057cf1b8a9853db7d5f482a7457cd55fe1e4c3bdaa727db86fa69d0d144ccb2de9e25e51f34c7edb7c3487e6b0f4a51a76890dc309820e8096e39d7d9f01 SHA512 3c40f3b590e1d46defc757c6133136693e5ee5129949dfd1f7dbf49bc7e0634c591c2ba6e0758b0a0e9b979425c9501864020e4e12cc685ce963d74d5b2b6889
MISC metadata.xml 617 BLAKE2B f940ac3d7c159dadf4398164b749eaded84c12af5553a154d97fd9bfb939c72e3122e08e11c1c9764514f59a87695534daff6628bd15be4de834c7cfdb65d7f9 SHA512 758df481a60606de12c5a450162ee89fd2f68f842675b3bf280f024fcd61232228476ac889e60c09e42ebae01ad855b32ad77793ba7fa5714861ccc5ca52bfc7
diff --git a/sci-mathematics/z3/z3-4.8.14.ebuild b/sci-mathematics/z3/z3-4.8.14.ebuild
new file mode 100644
index 000000000000..488e59de75e0
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.8.14.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake-multilib java-pkg-opt-2 python-single-r1
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="https://github.com/Z3Prover/z3/"
+SRC_URI="https://github.com/Z3Prover/z3/archive/${P}.tar.gz"
+S=${WORKDIR}/z3-${P}
+
+SLOT="0/4.8"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc examples gmp isabelle java python"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp:0=[cxx(+),${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.8 )"
+BDEPEND="
+ doc? ( app-doc/doxygen )"
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+src_prepare() {
+ cmake_src_prepare
+ java-pkg-opt-2_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${P}"
+ -DZ3_USE_LIB_GMP=$(usex gmp)
+ -DZ3_ENABLE_EXAMPLE_TARGETS=OFF
+ -DZ3_BUILD_DOCUMENTATION=$(multilib_native_usex doc)
+ -DZ3_BUILD_PYTHON_BINDINGS=$(multilib_native_usex python)
+ -DZ3_BUILD_JAVA_BINDINGS=$(multilib_native_usex java)
+ -DZ3_INCLUDE_GIT_DESCRIBE=OFF
+ -DZ3_INCLUDE_GIT_HASH=OFF
+ )
+
+ multilib_is_native_abi && use java && mycmakeargs+=( -DJAVA_HOME="$(java-config -g JAVA_HOME )" )
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build test-z3
+ set -- "${BUILD_DIR}"/test-z3 /a
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+multilib_src_install_all() {
+ dodoc README.md RELEASE_NOTES
+ use examples && dodoc -r examples
+ use python && python_optimize
+
+ if use isabelle; then
+ insinto /usr/share/Isabelle/contrib/${P}/etc
+ newins - settings <<-EOF
+ Z3_COMPONENT="\$COMPONENT"
+ Z3_HOME="${EPREFIX}/usr/bin"
+ Z3_SOLVER="${EPREFIX}/usr/bin/z3"
+ Z3_REMOTE_SOLVER="z3"
+ Z3_VERSION="${PV}"
+ Z3_INSTALLED="yes"
+ Z3_NON_COMMERCIAL="yes"
+ EOF
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [[ -f ${ROOT}/etc/isabelle/components ]]; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ cat <<-EOF >> "${ROOT}/etc/isabelle/components" || die
+ contrib/${P}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ if [[ -f "${ROOT}/etc/isabelle/components" ]]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new Isabelle component being installed during an upgrade.
+ sed -e "/contrib\/${P}/d" \
+ -i "${ROOT}/etc/isabelle/components" || die
+ fi
+ fi
+ fi
+}