summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-07 04:26:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-07 04:26:50 +0100
commit7ad61ca2bfc8f8da08d2fb3085e4333dcccb0a64 (patch)
treef7c41a49b46acf8ae70e84a70c452a7d121c5458 /sci-mathematics
parentd6106fb0c1ab8f79024ab6a9ac2062ddc85d4e07 (diff)
gentoo auto-resync : 07:10:2024 - 04:26:50
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin19341 -> 19339 bytes
-rw-r--r--sci-mathematics/easycrypt/Manifest2
-rw-r--r--sci-mathematics/easycrypt/easycrypt-2024.09.ebuild50
3 files changed, 52 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index ac63a95cef05..f16d2f06d43a 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/easycrypt/Manifest b/sci-mathematics/easycrypt/Manifest
index 279ad2a412a8..bdd5f37cd312 100644
--- a/sci-mathematics/easycrypt/Manifest
+++ b/sci-mathematics/easycrypt/Manifest
@@ -1,3 +1,5 @@
DIST easycrypt-2024.01.tar.gz 1349695 BLAKE2B e9c43d43f2c07d75dcb5ee8edf46d1fcfc2a47497fd76c87ef13d52087144acbf3b80ae809c70164eebe046cfb5d585678811163a47cf30c3c55828c3278a4fc SHA512 331612b05f6c47b302f1ceb1d741f47476354bf2d4960c2f55e6bddf3187fea3d40aa687c278fc727bf8994fee95e7af444f109be9a0c9eb9ab455d5fcc7b97d
+DIST easycrypt-2024.09.tar.gz 1310681 BLAKE2B cfe81762d4f4567473fc1f98c889145ed8c42f0a48b9e8089de8eca6c15f088d36c4eb7f4b4c4889b6444323b38a2ab17d0703cf97470ddf3084094a37436d69 SHA512 ce1554046c87fbeb27763ffd7a40fb0d8abc8bdedce6884e864968c23b31aee2c66108e52233d4dd1cb408a48b2ac3cba3ef46aee0963a5c21f3c2d1a843c308
EBUILD easycrypt-2024.01-r1.ebuild 990 BLAKE2B a7545b457ce9d8127c05e543dbc92931ffcef034eb590252eb7a0e24552b2067d4fa4daf498e02c2281e6aceec50f5eff647444873f376c476a04ecaa550657f SHA512 7ba58288c3f6229ec5a3c904a123017c516364696a9ffca2b88b1c00d4e8460999e7b53f6502ee523ae7c14cfc6aae1c99de61a921dfc5bcdc93b02480798cf2
+EBUILD easycrypt-2024.09.ebuild 990 BLAKE2B a7545b457ce9d8127c05e543dbc92931ffcef034eb590252eb7a0e24552b2067d4fa4daf498e02c2281e6aceec50f5eff647444873f376c476a04ecaa550657f SHA512 7ba58288c3f6229ec5a3c904a123017c516364696a9ffca2b88b1c00d4e8460999e7b53f6502ee523ae7c14cfc6aae1c99de61a921dfc5bcdc93b02480798cf2
MISC metadata.xml 799 BLAKE2B 967a758171a2fe87b648a29bf2663beaae7834119e55a7619c98518c96cfe459e59fe5dc72a9faea071c0b488dc8144f1c0e43677ac63646f1ba12cf831f4a88 SHA512 411ff1acad400c3e70e546fd59b20db13b0f1db121aca9f1af23da708cd82340114bc966f64cfb5a35e84967c1131c660ab260f867639932c67edf47c859c4ca
diff --git a/sci-mathematics/easycrypt/easycrypt-2024.09.ebuild b/sci-mathematics/easycrypt/easycrypt-2024.09.ebuild
new file mode 100644
index 000000000000..80d57075fb07
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-2024.09.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/r${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-r${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ <dev-ml/num-1.5:=
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ dev-ml/batteries:=
+ dev-ml/camlp-streams:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+ sci-mathematics/why3:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}