summaryrefslogtreecommitdiff
path: root/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild')
-rw-r--r--sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild b/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
index 6120fae9e88b..a5abe4c0c16b 100644
--- a/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
+++ b/sci-misc/cdfplayer/cdfplayer-12.2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit multilib versionator
+inherit desktop multilib versionator
DESCRIPTION="Wolfram Player for the interactive Computable Document Format (CDF)"
SRC_URI="WolframPlayer_12.2.0_LINUX.sh"
@@ -70,12 +70,12 @@ src_install() {
dosym ../Wolfram/${MPN}/${MPV}/Executables/WolframPlayer opt/bin/WolframPlayer
# fix some embedded paths and install desktop files
- insinto /usr/share/applications
+ local filename
for filename in $(find "${D}" -name "wolfram-cdf12.desktop") ; do
echo Fixing "${filename}"
sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}"
echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}"
- doins "${filename}"
+ domenu "${filename}"
done
# install a wrapper