summaryrefslogtreecommitdiff
path: root/sci-misc/oww/oww-0.86.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-misc/oww/oww-0.86.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-misc/oww/oww-0.86.5.ebuild')
-rw-r--r--sci-misc/oww/oww-0.86.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-misc/oww/oww-0.86.5.ebuild b/sci-misc/oww/oww-0.86.5.ebuild
new file mode 100644
index 000000000000..83eafaaa6ac2
--- /dev/null
+++ b/sci-misc/oww/oww-0.86.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="A one-wire weather station for Dallas Semiconductor"
+HOMEPAGE="http://oww.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk nls usb"
+
+RDEPEND="
+ net-misc/curl
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.86.4-build.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ )
+
+src_configure() {
+ local myeconfargs=(
+ --enable-interactive
+ $(use_enable nls)
+ $(use_enable gtk gui)
+ $(use_with usb)
+ )
+ autotools-utils_src_configure
+}