summaryrefslogtreecommitdiff
path: root/sci-misc/tango
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /sci-misc/tango
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'sci-misc/tango')
-rw-r--r--sci-misc/tango/Manifest3
-rw-r--r--sci-misc/tango/metadata.xml23
-rw-r--r--sci-misc/tango/tango-9.2.5a.ebuild44
3 files changed, 70 insertions, 0 deletions
diff --git a/sci-misc/tango/Manifest b/sci-misc/tango/Manifest
new file mode 100644
index 000000000000..052761858f28
--- /dev/null
+++ b/sci-misc/tango/Manifest
@@ -0,0 +1,3 @@
+DIST tango-9.2.5a.tar.gz 65888551 BLAKE2B 73ac78c4cce5f98bff108ae01d669d7654f8d11d1fcc5621b4268511c713f5ed6087c268a6d4c620e4aa41692ecd96f9676a48038c036cb0896c2acd007a3e3a SHA512 f372ea8b261d345fac5dbd198b1d5f28ff346796ba91191e752cea5b9fb9155b43bfada89032c29a51fa9b4f5e3a4f16d1b1ca9e73530dc7f60eb10103531d3e
+EBUILD tango-9.2.5a.ebuild 976 BLAKE2B 0d6351bdf41bfe222c9ac4523cf292e76b3f96bf969c82514ec0ce900d95ed84ece8b087008c958f34faea00a1f477d72305bab06624fc7450fb2625d753751c SHA512 c88c4c8446827fbceca7a740a6cb505e25510a0c3f78495921ff876d5728f9c47e624c76151b85982b8f1f094b58a00a0bd625946937d00a2e0b085d629e73e8
+MISC metadata.xml 1086 BLAKE2B b0f79dc60fb750a2096f21eb9f9897e3a5e56ea91a0d5eddc52e49785f8e75cdfb1b6a3d2e55db08755680671a81c85cfec74b411a16d6ca1293f35b8dcfa630 SHA512 b42c372a91066486afedd67f6f72bb994a3179710905149deee78cf62d2b27aac68a012ea5ebdb397b478f9057a1befa1299fc8f20925ec1413cc9e4e67e2d6b
diff --git a/sci-misc/tango/metadata.xml b/sci-misc/tango/metadata.xml
new file mode 100644
index 000000000000..5e6d8ba6b6ac
--- /dev/null
+++ b/sci-misc/tango/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>alexxy@gentoo.org</email>
+ <name>Alexey Shvetsov</name>
+ </maintainer>
+ <longdescription lang="en">
+ Tango is an Open Source solution for SCADA and DCS. Open Source means you get all the source code under an Open Source free licence (LGPL and GPL). Supervisory Control and Data Acquisition (SCADA) systems are typically industrial type systems using standard hardware. Distributed Control Systems (DCS) are more flexible control systems used in more complex environments.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tango-cs</remote-id>
+ </upstream>
+ <use>
+ <flag name="dbserver">Enable build of tango dbserver</flag>
+ <flag name="mariadb">Use <pkg>dev-db/mariadb</pkg></flag>
+ <flag name="zeromq">Allow to use ZeroMQ broker via <pkg>net-libs/zeromq</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-misc/tango/tango-9.2.5a.ebuild b/sci-misc/tango/tango-9.2.5a.ebuild
new file mode 100644
index 000000000000..2b88352a4505
--- /dev/null
+++ b/sci-misc/tango/tango-9.2.5a.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tango is an Open Source solution for SCADA and DCS"
+HOMEPAGE="http://www.tango-controls.org/"
+SRC_URI="mirror://sourceforge/tango-cs/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dbserver java +mariadb +zeromq"
+
+DEPEND="
+ net-misc/omniORB
+ mariadb? ( dev-db/mariadb-connector-c )
+ !mariadb? ( dev-db/mysql-connector-c )
+ dbserver? (
+ mariadb? ( dev-db/mariadb[server] )
+ !mariadb? ( dev-db/mysql[server] )
+ virtual/mysql[server] )
+ java? ( virtual/jdk:* )
+ zeromq? ( net-libs/zeromq )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_configure() {
+ local MYCONF
+ if use mariadb; then
+ MYCONF+=(
+ $(use_enable mariadb)
+ --with-mariadbclient-include="${EPREFIX}/usr/include/mysql"
+ )
+ fi
+
+ econf \
+ --with-omni="${EPREFIX}/usr" \
+ $(use_enable zeromq zmq) \
+ $(use_enable java) \
+ $(use_enable dbserver) \
+ ${MYCONF[@]}
+}