summaryrefslogtreecommitdiff
path: root/sci-physics/fastjet-contrib/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-26 14:52:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-26 14:52:16 +0100
commitc3d998909264b1ff687b9c65cae3046443e66f7e (patch)
treeed7aa279f601f6c46fb8b7425bd2a051b72be8d6 /sci-physics/fastjet-contrib/files
parentcf91c70bb5a537972156006c46756b9ac75bdb7b (diff)
gentoo auto-resync : 26:08:2022 - 14:52:16
Diffstat (limited to 'sci-physics/fastjet-contrib/files')
-rw-r--r--sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-ar.patch247
-rw-r--r--sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch4
2 files changed, 249 insertions, 2 deletions
diff --git a/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-ar.patch b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-ar.patch
new file mode 100644
index 000000000000..b7578bd76738
--- /dev/null
+++ b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-ar.patch
@@ -0,0 +1,247 @@
+--- a/Centauro/Makefile
++++ b/Centauro/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/ClusteringVetoPlugin/Makefile
++++ b/ClusteringVetoPlugin/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/ConstituentSubtractor/Makefile
++++ b/ConstituentSubtractor/Makefile
+@@ -41,8 +41,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/EnergyCorrelator/Makefile
++++ b/EnergyCorrelator/Makefile
+@@ -40,8 +40,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/FlavorCone/Makefile
++++ b/FlavorCone/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/GenericSubtractor/Makefile
++++ b/GenericSubtractor/Makefile
+@@ -38,8 +38,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/JetCleanser/Makefile
++++ b/JetCleanser/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/JetFFMoments/Makefile
++++ b/JetFFMoments/Makefile
+@@ -34,8 +34,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ examples: example
+
+--- a/JetsWithoutJets/Makefile
++++ b/JetsWithoutJets/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/LundPlane/Makefile
++++ b/LundPlane/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/Nsubjettiness/Makefile
++++ b/Nsubjettiness/Makefile
+@@ -40,8 +40,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES) $(EXAMPLES2)
+--- a/QCDAwarePlugin/Makefile
++++ b/QCDAwarePlugin/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/RecursiveTools/Makefile
++++ b/RecursiveTools/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/ScJet/Makefile
++++ b/ScJet/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/scripts/internal/Template/Makefile
++++ b/scripts/internal/Template/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/SoftKiller/Makefile
++++ b/SoftKiller/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/SubjetCounting/Makefile
++++ b/SubjetCounting/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/ValenciaPlugin/Makefile
++++ b/ValenciaPlugin/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
+--- a/VariableR/Makefile
++++ b/VariableR/Makefile
+@@ -39,8 +39,8 @@
+ all: lib$(NAME).a
+
+ lib$(NAME).a: $(OBJS)
+- ar cru lib$(NAME).a $(OBJS)
+- ranlib lib$(NAME).a
++ $(AR) cru lib$(NAME).a $(OBJS)
++ $(RANLIB) lib$(NAME).a
+
+ # building the examples
+ examples: $(EXAMPLES)
diff --git a/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch
index 5f69900cdc30..fe3794d5e0f5 100644
--- a/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch
+++ b/sci-physics/fastjet-contrib/files/fastjet-contrib-1.049-soname.patch
@@ -1,5 +1,5 @@
---- fjcontrib-1.046.orig/Makefile.in 2022-03-10 13:44:33.963887464 +0100
-+++ fjcontrib-1.046/Makefile.in 2022-03-10 13:45:02.573890763 +0100
+--- a/Makefile.in
++++ b/Makefile.in
@@ -54,7 +54,7 @@
fragile_SHARED_SRC_LIST=@FRAGILE_SHARED_SRC_LIST@