summaryrefslogtreecommitdiff
path: root/sci-physics/fastjet/fastjet-3.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-23 02:48:52 +0100
commitfd70f5e3ed54d5e013c11a3f3e632e80838171d0 (patch)
treec6bf0dac8239e644ccc09b184e4eb9cca9701dcf /sci-physics/fastjet/fastjet-3.4.0-r1.ebuild
parent5deadca7219297a3c1f90eca00544a00e33efdbc (diff)
gentoo auto-resync : 23:07:2022 - 02:48:51
Diffstat (limited to 'sci-physics/fastjet/fastjet-3.4.0-r1.ebuild')
-rw-r--r--sci-physics/fastjet/fastjet-3.4.0-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/sci-physics/fastjet/fastjet-3.4.0-r1.ebuild b/sci-physics/fastjet/fastjet-3.4.0-r1.ebuild
new file mode 100644
index 000000000000..530a7302df44
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-3.4.0-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=plugins
+PYTHON_COMPAT=( python3_{8..11} )
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ media-libs/freetype
+ virtual/latex-base
+"
+
+inherit autotools docs flag-o-matic fortran-2 python-single-r1
+
+DESCRIPTION="A software package for jet finding in pp and e+e- collisions"
+HOMEPAGE="https://fastjet.fr/"
+SRC_URI="https://fastjet.fr/repo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cgal examples python +plugins"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# cgal is header-only in version 5.4 and up. We need to use the
+# special --enable-cgal-header-only argument to use these versions.
+DEPEND="
+ cgal? ( >=sci-mathematics/cgal-5.4:=[shared(+)] )
+ plugins? ( sci-physics/siscone:= )
+ python? ( ${PYTHON_DEPS} )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/fortran"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-system-siscone.patch
+ "${FILESDIR}"/${P}-gfortran.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use cgal && \
+ has_version 'sci-mathematics/cgal[gmp]' && append-libs -lgmp
+
+ econf \
+ $(use_enable cgal cgal-header-only) \
+ $(use_enable plugins allplugins) \
+ $(use_enable plugins allcxxplugins) \
+ --enable-shared \
+ --enable-static=no \
+ --disable-static \
+ --disable-auto-ptr \
+ $(use_enable python pyext)
+}
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ if use examples; then
+ emake -C example maintainer-clean
+ find example -iname 'makefile*' -delete || die
+
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ find "${ED}" -name '*.la' -delete || die
+}