summaryrefslogtreecommitdiff
path: root/sci-physics/geant4_vmc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /sci-physics/geant4_vmc/files
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'sci-physics/geant4_vmc/files')
-rw-r--r--sci-physics/geant4_vmc/files/geant4_vmc-6.0-cmake-g4root-tests.patch31
-rw-r--r--sci-physics/geant4_vmc/files/geant4_vmc-6.0-geant-4.11.0.1-fix.patch33
2 files changed, 64 insertions, 0 deletions
diff --git a/sci-physics/geant4_vmc/files/geant4_vmc-6.0-cmake-g4root-tests.patch b/sci-physics/geant4_vmc/files/geant4_vmc-6.0-cmake-g4root-tests.patch
new file mode 100644
index 000000000000..5f561dc64c88
--- /dev/null
+++ b/sci-physics/geant4_vmc/files/geant4_vmc-6.0-cmake-g4root-tests.patch
@@ -0,0 +1,31 @@
+From 5d25b7fd6d53b620b25bed3a72d739d1644b5731 Mon Sep 17 00:00:00 2001
+From: Oliver Freyermuth <o.freyermuth@googlemail.com>
+Date: Fri, 11 Feb 2022 17:22:13 +0100
+Subject: [PATCH] CMake: Fix G4Root_BUILD_TEST option in main CMakeLists.
+
+The option was not correctly inherited for use by the g4root
+subdirectory. Fixed by:
+- Setting it before add_subdirectory().
+- Storing the value in CACHE (otherwise, not seen in subdirectory).
+
+Pull Request: https://github.com/vmc-project/geant4_vmc/pull/28
+Bug: https://bugs.gentoo.org/833126
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -60,8 +60,8 @@ include(VMCInstallLibDir)
+ #--- Add the packages sources --------------------------------------------------
+ #
+ if(Geant4VMC_BUILD_G4Root)
++ set(G4Root_BUILD_TEST ${Geant4VMC_BUILD_G4Root_TEST} CACHE BOOL "Build G4Root test")
+ add_subdirectory(g4root)
+- set(G4Root_BUILD_TEST ${Geant4VMC_BUILD_G4Root_TEST})
+ endif(Geant4VMC_BUILD_G4Root)
+
+ if(Geant4VMC_BUILD_Geant4VMC)
+--
+2.34.1
+
diff --git a/sci-physics/geant4_vmc/files/geant4_vmc-6.0-geant-4.11.0.1-fix.patch b/sci-physics/geant4_vmc/files/geant4_vmc-6.0-geant-4.11.0.1-fix.patch
new file mode 100644
index 000000000000..64e55fccc186
--- /dev/null
+++ b/sci-physics/geant4_vmc/files/geant4_vmc-6.0-geant-4.11.0.1-fix.patch
@@ -0,0 +1,33 @@
+From fad0699c25b864e1ce2466c3c683007af5c350ad Mon Sep 17 00:00:00 2001
+From: Ivana Hrivnacova <Ivana.Hrivnacova@cern.ch>
+Date: Wed, 9 Mar 2022 18:03:18 +0100
+Subject: [PATCH] Fix compilation with Geant4 11.0.p1: (#30)
+
+Added missing test for G4VERSION_NUMBER in TG4RunManager.cxx
+---
+ source/run/src/TG4RunManager.cxx | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/source/run/src/TG4RunManager.cxx b/source/run/src/TG4RunManager.cxx
+index 64a45f0e0..5190172b0 100644
+--- a/source/run/src/TG4RunManager.cxx
++++ b/source/run/src/TG4RunManager.cxx
+@@ -47,6 +47,7 @@
+ #include <G4UIExecutive.hh>
+ #include <G4UImanager.hh>
+ #include <G4UIsession.hh>
++#include <G4Version.hh>
+ #include <Randomize.hh>
+
+ #ifdef USE_G4ROOT
+@@ -405,8 +406,10 @@ void TG4RunManager::Initialize()
+ // create G4RunManager
+ // ConfigureRunManager();
+
++#if G4VERSION_NUMBER == 1100
+ // Temporary work-around for bug in Cerenkov in Geant4 11.0
+ TG4PhysicsManager::Instance()->StoreCerenkovMaxBetaChangeValue();
++#endif
+
+ // initialize Geant4
+ fRunManager->Initialize();