summaryrefslogtreecommitdiff
path: root/sci-physics/herwig++
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /sci-physics/herwig++
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'sci-physics/herwig++')
-rw-r--r--sci-physics/herwig++/Manifest3
-rw-r--r--sci-physics/herwig++/files/herwig++-2.7.1-fix-boost-1.67.patch42
-rw-r--r--sci-physics/herwig++/herwig++-2.7.1-r1.ebuild6
3 files changed, 48 insertions, 3 deletions
diff --git a/sci-physics/herwig++/Manifest b/sci-physics/herwig++/Manifest
index 31e4728d5d8c..1fa1a1060124 100644
--- a/sci-physics/herwig++/Manifest
+++ b/sci-physics/herwig++/Manifest
@@ -1,4 +1,5 @@
AUX herwig++-2.6.3-looptools.patch 3187 BLAKE2B 1f310339b5bd84a67aa7111ed5d548e225cfcc5620175dd3c39fd0b1a51f783fa58cc5f1d3ca7e3d7b274d4360827b95d1042d7046030300b58ca9879dffcf08 SHA512 22a39b340a12fc7060bbd26700be836b1a9833a9b43f93ddfef6659ee0517fc6804e455dd39cd26b8d3ff41c125acca34ea0e72bfa45958885c347e38078aaab
+AUX herwig++-2.7.1-fix-boost-1.67.patch 986 BLAKE2B b66583720154dd1c3a00357c3aea4a26fb6ce33b02fd4670851487fa31786c59d7a5a638d965e917e0a8b8d2b5f6c0fa947c99e054706a28f21a9f57825771df SHA512 d297990d7fc2cd8335bc3c89fba71976cd186ece40d5e5d0aa5776ca9d7c688146cb7421d6012fe0f97a1160a78eef7c4b3d49e4fe82e4d91d9c130eab04bddb
DIST Herwig++-2.7.1.tar.bz2 3388956 BLAKE2B 20aa085d9b3e7bf3246a6431240141f027ac666d85679cb093b4d76c89d04cac3913cb8cdb6eac050bcd0da6f7ba78c97dea46ca7fd6ad578c5d8a42ed6c633e SHA512 643f389f13f22b30d0adb4ca601a11c2686f6db4746af51136601954af2ec20eb0af7b45981e764d8b71cb7206bfe310beea1fee069972868955b1f024b8d5e3
-EBUILD herwig++-2.7.1-r1.ebuild 1607 BLAKE2B 9d2c1b5baa8c5e04704c7664d1562a303611464e916d8c5d4c0bed1f81c53ab9a2ec14aa9b53625070f590528afab83c59c3f83c228ac9518c5262e1fc82db52 SHA512 ba002990f6071e6d98ca4120d1db8e2ecee380dc2b181ce3a3eff14e06d6337ce2ed1e6451dc736c9e506896dbc22d7fc09945bfa149004190b5b647dfd9a0cd
+EBUILD herwig++-2.7.1-r1.ebuild 1659 BLAKE2B 1186bb8e9654998c9b1f8b69705600de741e324e949e4fd398d469e8733d5345a0c2746778ca5bfc5a46028c296a09344968ae588981179bfadc039da3d4f978 SHA512 b62f1eb0a56df7ba06d84b837c8b289741dff00fa87f90048446dd791ed53dc31174ccf4da8b993239876ff79f9febf8bcb732df77e82c7385b3e32fb23d6f50
MISC metadata.xml 844 BLAKE2B 62358b0fc54682b9758f5b26bce163a97be4e27aaa9fef6f92c899f6a3e82a74d4a110c0427a36677f732dcc1ed132de8741fe485379a8fbf743e087ea596a7d SHA512 72d27384af741c0508a9fa5df44c76c0bc34f0affbcbdd76e5b46b84ecb08db80bf6c8735d45df180728a13d68cef8cc97aa22e6b12b9bb946cec5036c30afc4
diff --git a/sci-physics/herwig++/files/herwig++-2.7.1-fix-boost-1.67.patch b/sci-physics/herwig++/files/herwig++-2.7.1-fix-boost-1.67.patch
new file mode 100644
index 000000000000..bd4579b575a0
--- /dev/null
+++ b/sci-physics/herwig++/files/herwig++-2.7.1-fix-boost-1.67.patch
@@ -0,0 +1,42 @@
+https://bugs.gentoo.org/672250
+
+--- a/DipoleShower/Base/DipoleChain.cc
++++ b/DipoleShower/Base/DipoleChain.cc
+@@ -15,6 +15,7 @@
+ #include "Herwig++/DipoleShower/Utility/DipolePartonSplitter.h"
+
+ #include <boost/utility.hpp>
++#include <boost/next_prior.hpp>
+
+ using namespace Herwig;
+
+--- a/DipoleShower/Base/DipoleEventRecord.cc
++++ b/DipoleShower/Base/DipoleEventRecord.cc
+@@ -19,6 +19,7 @@
+ #include "ThePEG/PDF/PartonExtractor.h"
+
+ #include <boost/utility.hpp>
++#include <boost/next_prior.hpp>
+
+ #include <algorithm>
+
+--- a/Exsample2/BinnedStatistics.h
++++ b/Exsample2/BinnedStatistics.h
+@@ -16,6 +16,7 @@
+ #include "ThePEG/Repository/UseRandom.h"
+
+ #include <boost/utility.hpp>
++#include <boost/next_prior.hpp>
+
+ namespace Herwig {
+
+--- a/Exsample2/exsample/config.h
++++ b/Exsample2/exsample/config.h
+@@ -25,6 +25,7 @@
+ #include <limits>
+
+ #include <boost/utility.hpp>
++#include <boost/next_prior.hpp>
+ #include <boost/scoped_array.hpp>
+ #include <boost/scoped_ptr.hpp>
+
diff --git a/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild b/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
index cb49eebe72f9..33fcc97e82f2 100644
--- a/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
+++ b/sci-physics/herwig++/herwig++-2.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -33,7 +33,9 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYP}"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.6.3-looptools.patch
+ epatch \
+ "${FILESDIR}"/${PN}-2.6.3-looptools.patch \
+ "${FILESDIR}"/${PN}-2.7.1-fix-boost-1.67.patch
# fixes bug 570458, which is due to an outdated bundled boost.m4
rm m4/boost.m4 || die
find -name 'Makefile.am' -exec \