summaryrefslogtreecommitdiff
path: root/sci-physics/looptools/looptools-2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-physics/looptools/looptools-2.12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-physics/looptools/looptools-2.12.ebuild')
-rw-r--r--sci-physics/looptools/looptools-2.12.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-physics/looptools/looptools-2.12.ebuild b/sci-physics/looptools/looptools-2.12.ebuild
new file mode 100644
index 000000000000..3727a66da958
--- /dev/null
+++ b/sci-physics/looptools/looptools-2.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils fortran-2 multilib
+
+MYP=LoopTools-${PV}
+
+DESCRIPTION="Tools for evaluation of scalar and tensor one-loop integrals"
+HOMEPAGE="http://www.feynarts.de/looptools"
+SRC_URI="http://www.feynarts.de/looptools/${MYP}.tar.gz"
+
+LICENSE="LGPL-3"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.10-makefile.patch
+ export VER="${PV}"
+ # necessary fix for prefix
+ sed -i "s/lib\$(LIBDIRSUFFIX)/$(get_libdir)/" makefile.in || die
+}
+
+src_install() {
+ default
+ # another one of these package building archive with pic
+ # no: ooptools is not a typo
+ if use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/libooptools.a || die
+ fi
+ use doc && dodoc manual/*.pdf
+}