summaryrefslogtreecommitdiff
path: root/sci-physics/pythia/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /sci-physics/pythia/files
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'sci-physics/pythia/files')
-rw-r--r--sci-physics/pythia/files/pythia-6.4.28-fno-common.patch54
-rw-r--r--sci-physics/pythia/files/pythia8209-run-tests.patch20
2 files changed, 54 insertions, 20 deletions
diff --git a/sci-physics/pythia/files/pythia-6.4.28-fno-common.patch b/sci-physics/pythia/files/pythia-6.4.28-fno-common.patch
new file mode 100644
index 000000000000..3ee9bc7c0f7a
--- /dev/null
+++ b/sci-physics/pythia/files/pythia-6.4.28-fno-common.patch
@@ -0,0 +1,54 @@
+https://bugs.gentoo.org/766306
+--- a/pythia6_common_address.c
++++ b/pythia6_common_address.c
+@@ -48,28 +48,28 @@
+ # define pybins PYBINS
+ #endif
+
+-int pyjets[2+5*4000+2*2*5*4000];
+-int pydat1[200+2*200+200+2*200];
+-int pydat2[4*500+2*4*500+2*2000+2*4*4];
+-int pydat3[3*500+2*8000+2*8000+5*8000]; /* KNDCAY=8000 */
+-char pydat4[2*500*16];
+-int pydatr[6+2*100];
+-int pysubs[2+500+81*2+2*200];
+-int pypars[200+2*200+200+2*200];
+-int pyint1[400+2*400];
+-int pyint2[500+2*500+2*20*500+2*4*40];
+-int pyint3[2*81*2+3*1000+2*1000];
+-int pyint4[500+2*5*500];
+-int pyint5[1+3*501+2*3*501];
+-char pyint6[501*28];
+-int pyint7[2*6*7*7];
+-int pyint8[2*5*13];
+-int pyint9[2*4*13];
+-int pyuppr[1+7*20+1+2*10+2*5*20+2*11]; /* PYUPPR DOES NOT EXIST IN PYTHIA6 AT ALL!!! */
+-int pymssm[100+2*100];
+-int pyssmt[2*4*4+2*2*2+2*2*2+2*4+2*2+2*4*16+2*4*4+2*2*2+2*2*2];
+-int pyints[2*20];
+-int pybins[4+1000+2*20000];
++extern int pyjets[2+5*4000+2*2*5*4000];
++extern int pydat1[200+2*200+200+2*200];
++extern int pydat2[4*500+2*4*500+2*2000+2*4*4];
++extern int pydat3[3*500+2*8000+2*8000+5*8000]; /* KNDCAY=8000 */
++extern char pydat4[2*500*16];
++extern int pydatr[6+2*100];
++extern int pysubs[2+500+81*2+2*200];
++extern int pypars[200+2*200+200+2*200];
++extern int pyint1[400+2*400];
++extern int pyint2[500+2*500+2*20*500+2*4*40];
++extern int pyint3[2*81*2+3*1000+2*1000];
++extern int pyint4[500+2*5*500];
++extern int pyint5[1+3*501+2*3*501];
++extern char pyint6[501*28];
++extern int pyint7[2*6*7*7];
++extern int pyint8[2*5*13];
++extern int pyint9[2*4*13];
++extern int pyuppr[1+7*20+1+2*10+2*5*20+2*11]; /* PYUPPR DOES NOT EXIST IN PYTHIA6 AT ALL!!! */
++extern int pymssm[100+2*100];
++extern int pyssmt[2*4*4+2*2*2+2*2*2+2*4+2*2+2*4*16+2*4*4+2*2*2+2*2*2];
++extern int pyints[2*20];
++extern int pybins[4+1000+2*20000];
+
+ void *pythia6_common_address(const char* name) {
+ if (!strcmp(name,"PYJETS")) return pyjets;
diff --git a/sci-physics/pythia/files/pythia8209-run-tests.patch b/sci-physics/pythia/files/pythia8209-run-tests.patch
deleted file mode 100644
index d1edc8393726..000000000000
--- a/sci-physics/pythia/files/pythia8209-run-tests.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- pythia8209/examples/Makefile.orig 2015-06-04 22:21:53.000000000 +0300
-+++ pythia8209/examples/Makefile 2015-06-05 05:35:25.324262331 +0300
-@@ -139,3 +139,17 @@
- rm -f test[0-9][0-9][0-9]; rm -f out[0-9][0-9][0-9];\
- rm -f weakbosons.lhe; rm -f Pythia8.promc; rm -f hist.root;\
- rm -f *~; rm -f \#*; rm -f core*; rm -f *Dct.*
-+ rm -f main*out *.dat
-+
-+# Run tests, inject test-specific arguments when needed
-+main%.out: main%
-+ ./$< \
-+ $(if $(findstring $*,16 42 43 $(shell seq 81 89)), main$*.cmnd) \
-+ $(if $(findstring $*, $(shell seq 81 83)), w+_production_lhc_0.lhe) \
-+ $(if $(findstring $*, 84), hepmcout84.dat 2 w+_production_lhc) \
-+ $(if $(findstring $*, $(shell seq 85 88)), w_production) \
-+ $(if $(findstring $*, 42 43 $(shell seq 81 89)), histout$*.dat) \
-+ > $@
-+
-+main89.out: main89
-+ $(foreach cmd, $(wildcard main89*.cmnd), ./$< $(cmd) histout-$(cmd).dat >> $@ || exit;)