summaryrefslogtreecommitdiff
path: root/sci-physics/root/root-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /sci-physics/root/root-9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'sci-physics/root/root-9999.ebuild')
-rw-r--r--sci-physics/root/root-9999.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index 9231a3e5261a..b9e470282f89 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -9,7 +9,7 @@ CMAKE_MAKEFILE_GENERATOR=emake
FORTRAN_NEEDED="fortran"
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit cmake-utils eapi7-ver elisp-common eutils fortran-2 \
+inherit cmake-utils cuda eapi7-ver elisp-common eutils fortran-2 \
prefix python-single-r1 toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
@@ -26,19 +26,20 @@ fi
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
-IUSE="+X avahi aqua +asimage +davix emacs +examples fits fftw fortran
+IUSE="+X avahi aqua +asimage cuda +davix emacs +examples fits fftw fortran
+gdml graphviz +gsl http jemalloc kerberos ldap libcxx memstat
+minuit mysql odbc +opengl oracle postgres prefix pythia6 pythia8
- +python qt4 qt5 R +roofit root7 shadow sqlite +ssl table +tbb test
+ +python qt5 R +roofit root7 shadow sqlite +ssl table +tbb test
+threads +tiff +tmva +unuran vc xinetd +xml xrootd"
LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
REQUIRED_USE="
- !X? ( !asimage !opengl !qt4 !qt5 !tiff )
+ !X? ( !asimage !opengl !qt5 !tiff )
+ davix? ( ssl xml )
python? ( ${PYTHON_REQUIRED_USE} )
+ qt5? ( root7 )
tmva? ( gsl )
- davix? ( ssl xml )
"
CDEPEND="
@@ -65,10 +66,6 @@ CDEPEND="
virtual/glu
x11-libs/gl2ps:0=
)
- qt4? (
- dev-qt/qtcore:4=
- dev-qt/qtgui:4=
- )
qt5? (
dev-qt/qtcore:5=
dev-qt/qtgui:5=
@@ -80,6 +77,7 @@ CDEPEND="
>=x11-wm/afterstep-2.2.11[gif,jpeg,png,tiff?]
) )
avahi? ( net-dns/avahi[mdnsresponder-compat] )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-9.0 )
davix? ( net-libs/davix )
emacs? ( virtual/emacs )
fftw? ( sci-libs/fftw:3.0= )
@@ -201,6 +199,7 @@ src_configure() {
-Dchirp=OFF
-Dcling=ON # cling=OFF is broken
-Dcocoa=$(usex aqua)
+ -Dcuda=$(usex cuda)
-Dcxx14=$(usex root7)
-Dcxxmodules=OFF # requires clang, unstable
-Ddavix=$(usex davix)
@@ -242,8 +241,8 @@ src_configure() {
-Dpythia8=$(usex pythia8)
-Dpython=$(usex python)
-Dqt5web=$(usex qt5)
- -Dqtgsi=$(usex qt4)
- -Dqt=$(usex qt4)
+ -Dqtgsi=OFF
+ -Dqt=OFF
-Drfio=OFF
-Droofit=$(usex roofit)
-Droot7=$(usex root7)
@@ -263,9 +262,9 @@ src_configure() {
-Dtcmalloc=OFF
-Dtesting=$(usex test)
-Dthread=$(usex threads)
- -Dtmva-cpu=$(usex tmva)
- -Dtmva-gpu=OFF
-Dtmva=$(usex tmva)
+ -Dtmva-cpu=$(usex tmva)
+ -Dtmva-gpu=$(usex cuda)
-Dunuran=$(usex unuran)
-Dvc=$(usex vc)
-Dvdt=OFF