summaryrefslogtreecommitdiff
path: root/sci-visualization/dash/dash-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-26 20:08:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-26 20:08:29 +0000
commit6dfd9c39ab68bbc917ffc374b2fa515f676f891f (patch)
treec9963a9e1e09b0e237a5c00736caa588c5a0a38f /sci-visualization/dash/dash-2.0.0.ebuild
parentadb727afeb568404873e8cbc91ba93d3d49eff13 (diff)
gentoo auto-resync : 26:12:2022 - 20:08:29
Diffstat (limited to 'sci-visualization/dash/dash-2.0.0.ebuild')
-rw-r--r--sci-visualization/dash/dash-2.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-visualization/dash/dash-2.0.0.ebuild b/sci-visualization/dash/dash-2.0.0.ebuild
new file mode 100644
index 000000000000..f8f2e13614d1
--- /dev/null
+++ b/sci-visualization/dash/dash-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python framework for building ML & data science web apps"
+HOMEPAGE="https://github.com/plotly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Test need some packages not yet in the tree
+# flask_talisman
+# percy
+# ...
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/flask-compress[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup4 )"
+BDEPEND=""
+
+distutils_enable_tests pytest