summaryrefslogtreecommitdiff
path: root/sci-visualization/dash/dash-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-27 14:10:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-27 14:10:06 +0000
commit4429be000a778f363162554d59d903a725283d7d (patch)
tree16a6de16cbef2e9dcb36233f2e0c825f3ff60493 /sci-visualization/dash/dash-2.3.1.ebuild
parent2d9c9c77c273a982d69ad4caefcc1a3783844056 (diff)
gentoo auto-resync : 27:12:2022 - 14:10:05
Diffstat (limited to 'sci-visualization/dash/dash-2.3.1.ebuild')
-rw-r--r--sci-visualization/dash/dash-2.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-visualization/dash/dash-2.3.1.ebuild b/sci-visualization/dash/dash-2.3.1.ebuild
new file mode 100644
index 000000000000..f8f2e13614d1
--- /dev/null
+++ b/sci-visualization/dash/dash-2.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python framework for building ML & data science web apps"
+HOMEPAGE="https://github.com/plotly/dash"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Test need some packages not yet in the tree
+# flask_talisman
+# percy
+# ...
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/plotly[${PYTHON_USEDEP}]
+ dev-python/flask-compress[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup4 )"
+BDEPEND=""
+
+distutils_enable_tests pytest