summaryrefslogtreecommitdiff
path: root/sci-visualization/fig2sxd/fig2sxd-0.22.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-visualization/fig2sxd/fig2sxd-0.22.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-visualization/fig2sxd/fig2sxd-0.22.1.ebuild')
-rw-r--r--sci-visualization/fig2sxd/fig2sxd-0.22.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-visualization/fig2sxd/fig2sxd-0.22.1.ebuild b/sci-visualization/fig2sxd/fig2sxd-0.22.1.ebuild
new file mode 100644
index 000000000000..d01566cdf963
--- /dev/null
+++ b/sci-visualization/fig2sxd/fig2sxd-0.22.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to convert files in xfig format to OpenOffice.org Draw format"
+LICENSE="GPL-2"
+
+HOMEPAGE="https://sourceforge.net/projects/fig2sxd"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+DOCS=( changelog )
+PATCHES=( "${FILESDIR}"/${PN}-0.20-phony-check.patch )
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS}" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ einstalldocs
+}