summaryrefslogtreecommitdiff
path: root/sci-visualization/gnuplot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-29 12:00:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-29 12:00:47 +0100
commitadcf4f8116a4a850dae301fb4dbcd7b71cb35975 (patch)
tree41af0dd08b04c7d619cdfed205b03ff2cc201b26 /sci-visualization/gnuplot
parent7166f3a0a0b7886d340010458d0b130013cb9989 (diff)
gentoo auto-resync : 29:08:2024 - 12:00:47
Diffstat (limited to 'sci-visualization/gnuplot')
-rw-r--r--sci-visualization/gnuplot/Manifest1
-rw-r--r--sci-visualization/gnuplot/gnuplot-6.0.1-r1.ebuild225
2 files changed, 226 insertions, 0 deletions
diff --git a/sci-visualization/gnuplot/Manifest b/sci-visualization/gnuplot/Manifest
index 80da9c0a4034..2ec56fbdde1c 100644
--- a/sci-visualization/gnuplot/Manifest
+++ b/sci-visualization/gnuplot/Manifest
@@ -7,6 +7,7 @@ DIST gnuplot-5.4.8.tar.gz 5684061 BLAKE2B bd897b55e267f50e2f5ce8a49a3a033277577c
DIST gnuplot-6.0.1.tar.gz 7528936 BLAKE2B d385d4dc8a4af83f121bd062e014d8845078f5aeb84244f4cce7c17b7cf71c5fc66bd7b8623504ab53567b4123fc739506f7d2f8e4f8ad184258a7568f0223a2 SHA512 47e72ac444f35e22a5de111da3333c80846226d87411a3168e45a8433a258e351ad9b6f0ba21d76f2456042b755123a697b685fd2552b4bd9edc5b97fafcbc62
EBUILD gnuplot-5.4.10.ebuild 5045 BLAKE2B 34f31c96cc89f8aa0d87a88490fbf947dd6dd60cd1e783761863b2efc7435d4a7259fc5a67a0f41396cc198040304360e1f81c985d4a76b6edc1b82cc7544302 SHA512 c02c3845169bb46a9a9759b17e4c3b1bec7467147bb45c5444f41895c22457608661b12aa6d136f0b9562ed295a8b375576935134fb2ca49cf1f84c4db59bcba
EBUILD gnuplot-5.4.8.ebuild 5045 BLAKE2B 34f31c96cc89f8aa0d87a88490fbf947dd6dd60cd1e783761863b2efc7435d4a7259fc5a67a0f41396cc198040304360e1f81c985d4a76b6edc1b82cc7544302 SHA512 c02c3845169bb46a9a9759b17e4c3b1bec7467147bb45c5444f41895c22457608661b12aa6d136f0b9562ed295a8b375576935134fb2ca49cf1f84c4db59bcba
+EBUILD gnuplot-6.0.1-r1.ebuild 5560 BLAKE2B c59d15dcff6946958c9a106bbbb3e113d9ea6ceaf4ae0bc4ed9b2b8a8ce42c9f5ce00bcb3313b87b9f8d25404b9f26a3f59020b9ab8612c692e5a1b6a1111088 SHA512 e4a252b688fc024066b96eabda247fe970329cbe6a37d6f5d51ef7da66c403fd6e0327d58efa05d160f2a33f33c5b840e262f910cfe44a308024c924a53a665b
EBUILD gnuplot-6.0.1.ebuild 5353 BLAKE2B 470564ed59fcf4e7a90ffee9737bcc62b9522bec76d7aef7d41e1d7b11b74cebe6d42530a53799d3529d8183938a0a8858d6ef64a406f7832eb6211e85d489cf SHA512 9055d83f90e060fded97cc45f0a83ca741d5ec068354714d634c18909ed576c87cbd5c3956ef65d27250cefb7901a8f711191cab60145378210b7110baf41cba
EBUILD gnuplot-6.1.9999.ebuild 4962 BLAKE2B bfebc677042f2d56e3c553c19cdf0afc0c06988feb6d0a780cfb14d6b04e480e1fb2cb949650e18a5b6ba1fb8a770d46ea85702caf9507935b79e025303d1f2d SHA512 c1a8e70f0b7e82723045df2bd70c3858b4d0619923d20623a1d632e4f35be044f6b61b76c31996ad37c3a07eda026b742525474b14217e65ba22b5917ab7feea
MISC metadata.xml 1487 BLAKE2B f903fd16007f638163484d2c635c1eea3040cee929230f9c6578f190a65707ade22d7e08a7a9d2f354bafa7ed92c85b7db0182fe1b8584ce0e201665b8cadd55 SHA512 fe61bdbea5637e7eba0c1e726404068c861b151843c88da1972df2b132ff40d9e402a7b39f02750a05a233c17c572fd78ff26cadcb2f5fd9f0a9e201caa9da63
diff --git a/sci-visualization/gnuplot/gnuplot-6.0.1-r1.ebuild b/sci-visualization/gnuplot/gnuplot-6.0.1-r1.ebuild
new file mode 100644
index 000000000000..6d1f04e29d39
--- /dev/null
+++ b/sci-visualization/gnuplot/gnuplot-6.0.1-r1.ebuild
@@ -0,0 +1,225 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1,2,3,4} )
+WX_GTK_VER="3.2-gtk3"
+
+inherit autotools lua-single readme.gentoo-r1 toolchain-funcs wxwidgets
+
+DESCRIPTION="Command-line driven interactive plotting program"
+HOMEPAGE="http://www.gnuplot.info/"
+
+if [[ -z ${PV%%*9999} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.code.sf.net/p/gnuplot/gnuplot-main"
+ EGIT_BRANCH="master"
+ MY_P="${PN}"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${MY_P}"
+else
+ MY_P="${P/_/.}"
+ SRC_URI="https://downloads.sourceforge.net/gnuplot/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="gnuplot"
+SLOT="0"
+IUSE="amos aqua bitmap cairo doc examples +gd gpic latex libcaca libcerf lua metafont metapost qt5 qt6 readline regis tgif wxwidgets X"
+
+REQUIRED_USE="
+ doc? ( gd )
+ lua? ( ${LUA_REQUIRED_USE} )"
+
+RDEPEND="
+ amos? ( dev-libs/openspecfun )
+ cairo? (
+ x11-libs/cairo
+ x11-libs/pango )
+ gd? ( >=media-libs/gd-2.0.35-r3:2=[png] )
+ latex? (
+ virtual/latex-base
+ lua? (
+ dev-tex/pgf
+ >=dev-texlive/texlive-latexrecommended-2008-r2 ) )
+ libcaca? ( media-libs/libcaca )
+ lua? ( ${LUA_DEPS} )
+ qt5? ( !qt6? (
+ dev-qt/qtcore:5=
+ dev-qt/qtgui:5=
+ dev-qt/qtnetwork:5=
+ dev-qt/qtprintsupport:5=
+ dev-qt/qtsvg:5=
+ dev-qt/qtwidgets:5= ) )
+ qt6? (
+ dev-qt/qtbase:6=[gui,network,widgets]
+ dev-qt/qtsvg:6=
+ dev-qt/qt5compat:6= )
+ readline? ( sys-libs/readline:0= )
+ libcerf? ( sci-libs/libcerf )
+ wxwidgets? (
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/gtk+:3 )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXaw )"
+
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-langgreek
+ dev-texlive/texlive-mathscience
+ app-text/ghostscript-gpl )
+ qt5? ( !qt6? ( dev-qt/linguist-tools:5 ) )"
+
+IDEPEND="latex? ( virtual/latex-base )"
+
+GP_VERSION="${PV%.*}"
+TEXMF="${EPREFIX}/usr/share/texmf-site"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.1-no-picins.patch
+ "${FILESDIR}"/${PN}-6.0.0-configure.patch
+ "${FILESDIR}"/${PN}-6.0.1-watchpoints.patch
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV##*.} = 9999 ]]; then
+ local dir
+ for dir in config demo m4 term tutorial; do
+ emake -C "$dir" -f Makefile.am.in Makefile.am
+ done
+ fi
+
+ # Add special version identification as required by provision 2
+ # of the gnuplot license
+ sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
+
+ eautoreconf
+
+ # Make sure we don't mix build & host flags.
+ sed -i \
+ -e 's:@CPPFLAGS@:$(BUILD_CPPFLAGS):' \
+ -e 's:@CFLAGS@:$(BUILD_CFLAGS):' \
+ -e 's:@LDFLAGS@:$(BUILD_LDFLAGS):' \
+ -e 's:@CC@:$(CC_FOR_BUILD):' \
+ docs/Makefile.in || die
+}
+
+src_configure() {
+ if ! use latex; then
+ sed -i -e '/SUBDIRS/s/LaTeX//' share/Makefile.in || die
+ fi
+
+ use wxwidgets && setup-wxwidgets
+
+ tc-export CC CXX #453174
+ tc-export_build_env BUILD_CC
+ export CC_FOR_BUILD=${BUILD_CC}
+
+ use qt5 && use qt6 && ewarn "USE flag \"qt6\" overrides \"qt5\""
+
+ econf \
+ --with-texdir="${TEXMF}/tex/latex/${PN}" \
+ --with-readline=$(usex readline gnu builtin) \
+ $(use_with amos) \
+ $(use_with bitmap bitmap-terminals) \
+ $(use_with cairo) \
+ $(use_with gd) \
+ $(use_with gpic) \
+ "$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
+ $(use_with libcerf) \
+ $(use_with lua) \
+ $(use_with metafont) \
+ $(use_with metapost) \
+ $(use_with regis) \
+ $(use_with tgif) \
+ $(use_with X x) \
+ --enable-stats \
+ $(usev qt6 --with-qt=qt6 || use_with qt5 qt qt5) \
+ $(use_enable wxwidgets) \
+ DIST_CONTACT="https://bugs.gentoo.org/" \
+ EMACS=no
+}
+
+src_compile() {
+ # Prevent access violations, see bug 201871
+ export VARTEXFONTS="${T}/fonts"
+
+ emake all
+
+ # pdflatex fails in titlepag.tex: "Argument of  has an extra }."
+ # Install the pre-built gnuplot.pdf instead.
+ #if use doc; then
+ # if use cairo; then
+ # emake -C docs pdf
+ # else
+ # ewarn "Cannot build figures unless cairo is enabled."
+ # ewarn "Building documentation without figures."
+ # emake -C docs pdf_nofig
+ # mv docs/nofigures.pdf docs/gnuplot.pdf || die
+ # fi
+ #fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc BUGS NEWS PGPKEYS README* RELEASE_NOTES
+ newdoc term/PostScript/README README-ps
+ newdoc term/js/README README-js
+ use lua && newdoc term/lua/README README-lua
+
+ local DOC_CONTENTS='Gnuplot no longer links against pdflib. You can
+ use the "pdfcairo" terminal for PDF output.'
+ use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
+ use gd && DOC_CONTENTS+="\n\nFor font support in png/jpeg/gif output,
+ you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
+ environment variables. See the FAQ file in /usr/share/doc/${PF}/
+ for more information."
+ readme.gentoo_create_doc
+
+ if use examples; then
+ # Demo files
+ insinto /usr/share/${PN}/${GP_VERSION}
+ doins -r demo
+ rm "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/binary{1,2,3} || die
+ rm "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/plugin/*.{o,so} || die
+ fi
+
+ if use doc; then
+ # Manual, FAQ
+ dodoc docs/gnuplot.pdf #FAQ.pdf
+ # Documentation for making PostScript files
+ docinto psdoc
+ dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
+ fi
+}
+
+src_test() {
+ emake check GNUTERM="dumb"
+}
+
+pkg_postinst() {
+ use latex && texmf-update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ use latex && texmf-update
+}