summaryrefslogtreecommitdiff
path: root/sci-visualization/gwyddion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-14 00:13:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-14 00:13:14 +0000
commit4fda045f90a4e301329bddb766e2e12a0b4401de (patch)
tree1d486767bfd9de15d6c11d341408385eb7f7debe /sci-visualization/gwyddion
parent965058196f44550f3bc491dd85064071e085b776 (diff)
gentoo auto-resync : 14:02:2025 - 00:13:14
Diffstat (limited to 'sci-visualization/gwyddion')
-rw-r--r--sci-visualization/gwyddion/Manifest2
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.67.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/sci-visualization/gwyddion/Manifest b/sci-visualization/gwyddion/Manifest
index ed8fa8a83076..e2112e1678af 100644
--- a/sci-visualization/gwyddion/Manifest
+++ b/sci-visualization/gwyddion/Manifest
@@ -1,4 +1,6 @@
AUX gwyddion-2.62-automagic.patch 1527 BLAKE2B 85b5267bd011125c979cdec5885e8f61fc39bfdcac864405a5d37f26543e62f4b5762129e1537ae871dfbb109226364e66fc3576340e704b671df025986846bc SHA512 cd335f0a264679159bb4f98cdac8b37357f886b49d6d98662f2550ba0b5e5d911530c31b0238574ee1b42d6dbe8fc9ff77e3d8ce985baaabc5e58a145f057ffb
DIST gwyddion-2.62.tar.xz 5010676 BLAKE2B 18012dfe050753413834e8a3734ec82989f375d81ac0242a6bbaf630da1a7741e9701d3c7a8c0dc03cfde8f93de9848ae106731f057c902f44ba1caf0cd79520 SHA512 93aff13f865fab045e17bd6c7633d714c4a97980ff10093f38c35e6dd39a0ed9680185f7a81a198522b623260cf6086d40e2b6a63a1cb59bc176eadf87fb85e1
+DIST gwyddion-2.67.tar.xz 5456028 BLAKE2B ef02681a1aa777a736340d6f4f0712da9d41e4e9644c3b6ad81f14ba4f9608390876a33aaf6eb2125cf6843f8775026fb74cc99aab7290fdfc4609855fc243ca SHA512 973ebd4a718b23b0de3340f22dbffa1a8e29da586d19838e34fa2195a29443274adba63a3f5fb68ed288ed9a6d0236acbb57fe88cff4a41ecc13845898be20fd
EBUILD gwyddion-2.62-r3.ebuild 2022 BLAKE2B a1b12590240528f97cf786e9f05b7492bc69bab251f5956e4bca3eb65c2514843fd4099b557b292344936fab06a50da7f16f3670cef87a587b36d94c8c2ce3bf SHA512 49acd0781ba0a26d50f52e9ddbc7dc32456b4ecec19b647bbfbbf16ed89d4722f02b214ce0e2760a1fe7fbd64e123aeb20883d6324573e8b3be76c51ce3b5f82
+EBUILD gwyddion-2.67.ebuild 2023 BLAKE2B faeded723abb0046ef83852bfdaf481e9e473ce5718328e9281631f0b0b0624b1bc097938539f45666ae3e64ad7cf647e0ce4ea9aa8cc4bb9b0b1145bd6e740b SHA512 c08a299fa244915a6cdc03f2abcb832c1fc7d467de848935742a987ae0cccb1e151416f67dad38bd32908a2ab60ebb6f912bb662f3f84b91d1dde79e257996b2
MISC metadata.xml 1154 BLAKE2B f5b963012cfc1842557eb4a678d9f1d3dbbefd08ea53e37306b747dd41336fe04418f97487e909a5c58eac4c97dc694a8be90be7b16079449be5269e869549a5 SHA512 612def01f5ce5f6681525c129abe4f58507aac92dc61d1d5ccdb1f95cd7625c5b79beda9eabc9ebf3e76808eeacbebd92ddb4e74476eace966d4ef4c32a68f67
diff --git a/sci-visualization/gwyddion/gwyddion-2.67.ebuild b/sci-visualization/gwyddion/gwyddion-2.67.ebuild
new file mode 100644
index 000000000000..c96a611bb31d
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.67.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 doc fits jansson hdf5 nls openexr openmp perl ruby sourceview unique xml X zlib"
+
+RDEPEND="
+ >=dev-libs/glib-2.32
+ dev-libs/libzip
+ media-libs/libpng:0=
+ >=sci-libs/fftw-3.1:3.0=[openmp?]
+ virtual/libiconv
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libXmu
+ x11-libs/pango
+ bzip2? ( app-arch/bzip2 )
+ fits? ( sci-libs/cfitsio[bzip2?] )
+ jansson? ( dev-libs/jansson )
+ hdf5? ( sci-libs/hdf5:=[hl,zlib?] )
+ openexr? ( media-libs/openexr:= )
+ perl? ( dev-lang/perl:= )
+ ruby? ( dev-ruby/narray )
+ unique? ( dev-libs/libunique:3 )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ xml? ( dev-libs/libxml2:2 )
+ zlib? ( sys-libs/zlib )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.62-automagic.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+# There are python bindings (--enable-pygwy) but they are py2 only
+# 3D opengl rendering requires deprecated GTK-2 x11-libs/gtkglext
+src_configure() {
+ # hack for bug 741840
+ use doc && export GTK_DOC_PATH=/usr/share/gtk-doc
+
+ econf \
+ --disable-rpath \
+ --without-kde4-thumbnailer \
+ $(use_enable doc gtk-doc) \
+ $(use_enable openmp) \
+ $(use_enable nls) \
+ --disable-pygwy \
+ --without-python \
+ $(use_with bzip2) \
+ $(use_with fits cfitsio) \
+ $(use_with hdf5) \
+ $(use_with jansson) \
+ $(use_with perl) \
+ $(use_with ruby) \
+ $(use_with openexr exr) \
+ --without-gl \
+ $(use_with sourceview gtksourceview) \
+ $(use_with unique) \
+ $(use_with xml libxml2) \
+ $(use_with X x) \
+ $(use_with zlib) \
+ --with-zip=libzip
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}