summaryrefslogtreecommitdiff
path: root/sci-visualization/jupyter-dash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sci-visualization/jupyter-dash
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sci-visualization/jupyter-dash')
-rw-r--r--sci-visualization/jupyter-dash/Manifest3
-rw-r--r--sci-visualization/jupyter-dash/jupyter-dash-0.4.0.ebuild30
-rw-r--r--sci-visualization/jupyter-dash/metadata.xml16
3 files changed, 49 insertions, 0 deletions
diff --git a/sci-visualization/jupyter-dash/Manifest b/sci-visualization/jupyter-dash/Manifest
new file mode 100644
index 000000000000..696beb06e2cb
--- /dev/null
+++ b/sci-visualization/jupyter-dash/Manifest
@@ -0,0 +1,3 @@
+DIST jupyter-dash-0.4.0.tar.gz 42855 BLAKE2B 6ee097892e8175d72883005a4b8097e1069d3550d845dc8728991c78d437d74f571e3e1e4fddf7c8df716c0921a5910c9fbc654f0a56c0f177f14c7b2c1bd336 SHA512 16774dfe54122096cdf672408af8fb7f0246ba7db1429eeee21a9b10645990d859208e13b743119c90e5b0ae042eeb32e91e56205139d9cf792f5995e467ccf9
+EBUILD jupyter-dash-0.4.0.ebuild 721 BLAKE2B 6f851409edc6f4d6032799785048cc612e259e787538fb8fcdd1e01e00c3e9268256dc4ccc8b7a9c15fb970f2747b70ecab9ccdbf4a7be2fae8801e364258e31 SHA512 3575d813ded8691d8d9f56769557df7a04d8767bae5541d02bd629b3464bf7a507d0585ef3c5b3254b9e4a1fa43115d49506411bf3a70df37d588ebdd38b4441
+MISC metadata.xml 589 BLAKE2B 3c22acd7937d555699ef6d26466bf0db05ee62bece4184dc52c3a724bca75298b5e25c3a53ea9a1f79d39597b1eb15e2fd1367931ef2d3d5e511102a7fb92389 SHA512 38437c044d2c9bdfd16ad95a8940c2565875f8a56f67a7a9e726285b0bcc431cc53e1c0786bc3d88a169fe9f2a15a0b9aa3a920a1b21319b0ffdf51b5fe18b00
diff --git a/sci-visualization/jupyter-dash/jupyter-dash-0.4.0.ebuild b/sci-visualization/jupyter-dash/jupyter-dash-0.4.0.ebuild
new file mode 100644
index 000000000000..87d8aedc3a92
--- /dev/null
+++ b/sci-visualization/jupyter-dash/jupyter-dash-0.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Plotly Dash apps from within Jupyter environments"
+HOMEPAGE="https://plotly.com/dash/"
+SRC_URI="https://github.com/plotly/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/ansi2html[${PYTHON_USEDEP}]
+ sci-visualization/dash[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/retrying[${PYTHON_USEDEP}]"
+BDEPEND=""
+
+src_install () {
+ distutils-r1_src_install
+ mv "${D}"/usr/etc "${D}"/ || die
+}
diff --git a/sci-visualization/jupyter-dash/metadata.xml b/sci-visualization/jupyter-dash/metadata.xml
new file mode 100644
index 000000000000..50ec7aff92b7
--- /dev/null
+++ b/sci-visualization/jupyter-dash/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ This library makes it easy to develop Plotly Dash apps interactively
+ from within Jupyter environments (e.g. classic Notebook, JupyterLab,
+ Visual Studio Code notebooks, nteract, PyCharm notebooks, etc.).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">plotly/jupyter-dash</remote-id>
+ </upstream>
+</pkgmetadata>