summaryrefslogtreecommitdiff
path: root/sci-visualization/paraview
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /sci-visualization/paraview
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'sci-visualization/paraview')
-rw-r--r--sci-visualization/paraview/Manifest2
-rw-r--r--sci-visualization/paraview/paraview-5.9.0.ebuild233
2 files changed, 235 insertions, 0 deletions
diff --git a/sci-visualization/paraview/Manifest b/sci-visualization/paraview/Manifest
index 481124d38c4a..fd5a7639ebc6 100644
--- a/sci-visualization/paraview/Manifest
+++ b/sci-visualization/paraview/Manifest
@@ -4,5 +4,7 @@ AUX paraview-5.5.0-allow_custom_build_type.patch 1036 BLAKE2B ff00093034196935e9
AUX paraview-5.8.0-w-vtk-8.2.0-qt-5.15.patch 1185 BLAKE2B 9573a94af926615a3e6e8e043ea5bbbbf7a7946e33bce30c9fe6475de074142043463c345cf6caed09a60a63c241cac19ca2a54383b41752441b72e0bf5d9f17 SHA512 3552ae966be577840187590c651abc98e41047cbac6b679a17779b83b37c8d1ddd1a36a6ddd6dffb01b66138d2fc8a1bd335afb3ee488d2faa60c7ec1e4323e0
AUX paraview-5.8.1-find-xmlpatterns.patch 1343 BLAKE2B 6786f27d4a3d5539f0265d1b3426b16063e795fca57d51ac3d232e5258d4d3db1b765379607ba143a422fe8f49b12354edc51fd4f4700a709e2e4aa362e75b8c SHA512 08aa76bdb1251638d52a2871116f507cc492cf03895a1950e05a56048571edb932efebe0f7704d56cd61afadee8f1f9e7003bc02825df83550944f84265b1658
DIST ParaView-v5.8.1.tar.xz 49822084 BLAKE2B 1b99392a85c19fdc02f8f9f0f055fb7efd8a0b17eedfd84005d1af9b170c34ec4eedb25700f91c3a2241ee80e271fe1e744e3a729b7726deb8f9c7a9fd2e4191 SHA512 94861c01da2f98c47e7453d072a4de34a7f52f5df280a8745b44d58d8d6a1dba42a15d0bac31895bbe25f23d993d4d356e5af1f8415137e289afd60570070248
+DIST ParaView-v5.9.0.tar.xz 62784788 BLAKE2B f07bfce50304b2bfba0de4ba3127d686cf4c32633f8c707fbb2d93c19685f7e8a119ba211e27c29b986ca5b22afab4f57c273077a1c0a7ab0abefa55c8874e28 SHA512 44d93b49449262aa3f068aa990419415c3197916a002555d914efc407ed7ccd57b15b829f0fe711afee780e5e63fb1bd072175fc382f3afd36daecc541c382d5
EBUILD paraview-5.8.1.ebuild 6363 BLAKE2B d1682ea682bfe732b3442cc2495dfb660fc8d5603c50b5c864b7629dd918bb77d9a8dcdd1dd14a7e8bc3047d345f6fe1b71365b735a6e7093c93493dd67c9aeb SHA512 4bef374b2f19f375d21f2d548c941cd14502311e395e9dd80d050068ea25cd3d1d2d41abf4e74bcbbe34ccc55d01b81197ab9b7dc325d185a54ac0e019501fb4
+EBUILD paraview-5.9.0.ebuild 5806 BLAKE2B 1b95eee4c57a64b68a872eea69b49423e854571909466e1f3e3e70b4ff5b8bcc723e08012f91abc31593583667fe1caccdbe52601265a051522ab33a26a3e555 SHA512 3e88a1dc77c0e5f9f7590db6a3a17e2510aa368b4a243e78851d9a44f3a696daab531912d2c70ef0ce25c5384a43929c29c20d3a3b0dae711da66f490163e72a
MISC metadata.xml 873 BLAKE2B 3f48aa66e19a19e8de7959d58248e7d4d7b6ca0f9dd98b869088f15bfc483dec486c89bdd448368eb0b385735ca8cfb3462a86e93fecb13383366ced4ead4ebd SHA512 871830a5157bc1f8803cf4dbd4797a58bd87d6338a3eaa21662a2e789412bf746c30f817a485a26b4b14fa578aa15b391efe76c920db7b1c2a2f74f9bf3eceb2
diff --git a/sci-visualization/paraview/paraview-5.9.0.ebuild b/sci-visualization/paraview/paraview-5.9.0.ebuild
new file mode 100644
index 000000000000..826f9ea31de5
--- /dev/null
+++ b/sci-visualization/paraview/paraview-5.9.0.ebuild
@@ -0,0 +1,233 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+inherit cmake desktop python-single-r1 qmake-utils toolchain-funcs xdg-utils
+
+MAIN_PV=$(ver_cut 0-1)
+MAJOR_PV=$(ver_cut 1-2)
+MY_P="ParaView-v${PV}"
+
+DESCRIPTION="Powerful scientific data visualization application"
+HOMEPAGE="https://www.paraview.org"
+SRC_URI="https://www.paraview.org/files/v${MAJOR_PV}/${MY_P}.tar.xz"
+
+LICENSE="paraview GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost cg doc examples ffmpeg mpi mysql nvcontrol openmp offscreen plugins python +qt5 +sqlite test tk +webengine"
+
+RESTRICT="mirror test"
+
+# "vtksqlite, needed by vtkIOSQL" and "vtkIOSQL, needed by vtkIOMySQL"
+REQUIRED_USE="
+ python? ( mpi ${PYTHON_REQUIRED_USE} )
+ mysql? ( sqlite )
+ webengine? ( qt5 )
+ qt5? ( sqlite )
+ ?? ( offscreen qt5 )"
+
+# TODO: Verify that these two are not needed any more for the catalyst
+# module:
+# - dev-python/PyQt5
+# - dev-qt/qtgui:5[-gles2-only]
+RDEPEND="
+ app-arch/lz4
+ dev-libs/expat
+ dev-libs/jsoncpp:=
+ dev-libs/libxml2:2
+ dev-libs/protobuf:=
+ dev-libs/pugixml
+ media-libs/freetype
+ media-libs/glew:0
+ media-libs/libpng:0
+ media-libs/libtheora
+ media-libs/tiff:0=
+ sci-libs/cgnslib
+ sci-libs/hdf5:=[mpi=]
+ >=sci-libs/netcdf-4.2[hdf5]
+ >=sci-libs/netcdf-cxx-4.2:3
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ ffmpeg? ( media-video/ffmpeg )
+ mpi? ( virtual/mpi[cxx,romio] )
+ mysql? ( dev-db/mysql-connector-c )
+ offscreen? ( >=media-libs/mesa-18.3.6[osmesa] )
+ !offscreen? ( virtual/opengl )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/constantly[${PYTHON_MULTI_USEDEP}]
+ dev-python/incremental[${PYTHON_MULTI_USEDEP}]
+ dev-python/matplotlib[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygments[${PYTHON_MULTI_USEDEP}]
+ dev-python/sip[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]
+ dev-python/twisted[${PYTHON_MULTI_USEDEP}]
+ dev-python/zope-interface[${PYTHON_MULTI_USEDEP}]
+ mpi? ( dev-python/mpi4py )
+ qt5? ( dev-python/PyQt5[opengl,${PYTHON_MULTI_USEDEP}] )
+ ')
+ )
+ qt5? (
+ dev-qt/designer:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qthelp:5
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qttest:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxmlpatterns:5
+ )
+ sqlite? ( dev-db/sqlite:3 )
+ tk? ( dev-lang/tk:0= )
+ webengine? ( dev-qt/qtwebengine:5[widgets] )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ boost? (
+ $(python_gen_cond_dep '
+ dev-libs/boost[mpi?,${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.1-xdmf-cstring.patch
+ "${FILESDIR}"/${PN}-5.5.0-allow_custom_build_type.patch
+)
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != "binary" ]] && use openmp && tc-check-openmp
+ use python && python-single-r1_pkg_setup
+ PVLIBDIR=$(get_libdir)/${PN}-${MAJOR_PV}
+}
+
+src_prepare() {
+ # Bug #661812
+ mkdir -p Plugins/StreamLinesRepresentation/doc || die
+
+ cmake_src_prepare
+
+ # lib64 fixes
+ sed -i \
+ -e "s:/lib/python:/$(get_libdir)/python:g" \
+ VTK/ThirdParty/xdmf3/vtkxdmf3/CMakeLists.txt || die
+ sed -i \
+ -e "s:lib/paraview-:$(get_libdir)/paraview-:g" \
+ Remoting/Application/vtkInitializationHelper.cxx || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="${PVLIBDIR}"
+ -UBUILD_SHARED_LIBS
+ -DPARAVIEW_BUILD_SHARED_LIBS=ON
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+
+ # boost
+ -DVTK_MODULE_ENABLE_VTK_IOInfovis="$(usex boost YES NO)"
+
+ # doc
+ -DPARAVIEW_BUILD_DEVELOPER_DOCUMENTATION="$(usex doc)"
+
+ # examples
+ -DBUILD_EXAMPLES="$(usex examples)"
+
+ # ffmpeg
+ -DPARAVIEW_ENABLE_FFMPEG="$(usex ffmpeg)"
+ -DVTK_USE_FFMPEG_ENCODER="$(usex ffmpeg)"
+
+ # mpi
+ -DPARAVIEW_USE_MPI="$(usex mpi)"
+ -DXDMF_BUILD_MPI="$(usex mpi)"
+ -DVTK_GROUP_ENABLE_MPI="$(usex mpi YES NO)"
+
+ # mysql
+ -DVTK_MODULE_ENABLE_VTK_IOMySQL="$(usex mysql YES NO)"
+
+ # offscreen
+ -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
+ -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
+
+ # plugins
+ -DPARAVIEW_PLUGINS_DEFAULT="$(usex plugins)"
+
+ # python
+ -DModule_pqPython="$(usex python)"
+ -DPARAVIEW_USE_PYTHON="$(usex python)"
+
+ # qt5
+ -DPARAVIEW_USE_QT="$(usex qt5)"
+ -DModule_pqPython="$(usex qt5 "$(usex python)" "off")"
+ -DVTK_USE_NVCONTROL="$(usex nvcontrol)"
+ -DVTK_GROUP_ENABLE_Qt="$(usex qt5 YES NO)"
+
+ # sqlite
+ -DVTK_MODULE_ENABLE_VTK_sqlite="$(usex sqlite YES NO)"
+
+ # test
+ -DBUILD_TESTING="$(usex test)"
+
+ # tk
+ -DVTK_USE_TK="$(usex tk)"
+ -DVTK_GROUP_ENABLE_Tk="$(usex tk YES NO)"
+
+ # webengine
+ -DPARAVIEW_USE_QTWEBENGINE="$(usex webengine)"
+ -DVTK_GROUP_ENABLE_Web="$(usex webengine YES NO)"
+ )
+
+ if use openmp; then
+ mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE=OpenMP )
+ fi
+
+ if use qt5; then
+ mycmakeargs+=(
+ -DOPENGL_gl_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGL.so
+ -DOPENGL_glu_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGLU.so
+ -DQT_MOC_EXECUTABLE="$(qt5_get_bindir)/moc"
+ -Dqt_xmlpatterns_executable="$(qt5_get_bindir)/xmlpatterns"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # remove wrapper binaries and put the actual executable in place
+ for i in {paraview-config,pvserver,pvdataserver,pvrenderserver,pvbatch,pvpython,paraview}; do
+ if [ -f "${ED}"/usr/lib/"$i" ]; then
+ mv "${ED}"/usr/lib/"$i" "${ED}"/usr/bin/"$i" || die
+ fi
+ done
+
+ # set up the environment
+ echo "LDPATH=${EPREFIX}/usr/${PVLIBDIR}" > "${T}"/40${PN} || die
+ doenvd "${T}"/40${PN}
+
+ newicon "${S}"/Clients/ParaView/pvIcon-96x96.png paraview.png
+ make_desktop_entry paraview "Paraview" paraview
+
+ use python && python_optimize "${D}"/usr/$(get_libdir)/${PN}-${MAJOR_PV}
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}