summaryrefslogtreecommitdiff
path: root/sci-visualization/spectromatic/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-19 00:01:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-19 00:01:59 +0100
commit9d4810f84de876ec9d0ae03d0d44224500b41188 (patch)
tree1ca0866afdc949e405d20635d3d7f2115abb9ace /sci-visualization/spectromatic/files
parent075fd1f8cabc5879c6eb42127fb84c3058677fde (diff)
gentoo auto-resync : 19:05:2024 - 00:01:59
Diffstat (limited to 'sci-visualization/spectromatic/files')
-rw-r--r--sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch49
-rw-r--r--sci-visualization/spectromatic/files/spectromatic-1.0-stringliteral.patch78
-rw-r--r--sci-visualization/spectromatic/files/spectromatic-1.0-waveheaderstruct-amd64.patch103
3 files changed, 0 insertions, 230 deletions
diff --git a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
deleted file mode 100644
index ea1fa0a70eec..000000000000
--- a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-Respect LDFLAGS, CFLAGS, CC #334715
-Fix install paths
-
---- a/Makefile
-+++ b/Makefile
-@@ -1,33 +1,29 @@
- # Makefile for spectromatic
-
--CFLAGS = -O2 -Wall
--LIBS = -lgsl -lgslcblas -lpng -lm
-+LIBS = -lpng `${PKG_CONFIG} --libs gsl`
- DESTDIR =
--TOPLEVEL_HOME = /usr
-+TOPLEVEL_HOME ?= /usr
-
--CC = gcc -I.
--
- SRC = spectromatic.c wave.c
-
- OBJ = $(SRC:.c=.o)
-
- TARGET = spectromatic
-
--install: all
-- mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/bin
-- mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/man/man1
-- install -o root -g root -m 0755 spectromatic $(DESTDIR)$(TOPLEVEL_HOME)/bin
-- install -o root -g root -m 0644 man/spectromatic.1 $(DESTDIR)$(TOPLEVEL_HOME)/man/man1
--
- all: $(OBJ)
-- $(CC) -o $(TARGET) $(OBJ) $(LIBS)
-- strip $(TARGET)
-+ $(CC) $(LDFLAGS) $(OBJ) $(LIBS) -o $(TARGET)
-+
-+install: $(TARGET)
-+ mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/bin
-+ mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/share/man/man1
-+ install -m 0755 spectromatic $(DESTDIR)$(TOPLEVEL_HOME)/bin
-+ install -m 0644 man/spectromatic.1 $(DESTDIR)$(TOPLEVEL_HOME)/share/man/man1
-
- clean:
- $(RM) $(TARGET) $(OBJ)
-
- .c.o:
-- $(CC) $(CFLAGS) -c $<
-+ $(CC) $(CFLAGS) -I. -c $<
-
- .o:
- $(CC) $< $(LIBS) -o $@
diff --git a/sci-visualization/spectromatic/files/spectromatic-1.0-stringliteral.patch b/sci-visualization/spectromatic/files/spectromatic-1.0-stringliteral.patch
deleted file mode 100644
index d7233c1aab81..000000000000
--- a/sci-visualization/spectromatic/files/spectromatic-1.0-stringliteral.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff -ru spectromatic-1.0/spectromatic.c spectromatic-1.0-new/spectromatic.c
---- a/spectromatic.c
-+++ b/spectromatic.c
-@@ -21,6 +21,7 @@
- ****************************************************************************/
-
- #include <stdio.h>
-+#include <stdlib.h>
- #include <malloc.h>
- #include <png.h>
- #include <string.h>
-@@ -37,36 +38,36 @@
- void usage (char *pname)
- {
- fprintf (stderr,
--"
--Usage: %s [options] file.wav
--
--Options:
-- --window <size> FFT window size (default: 2048)
--
-- --step <size> Slide the window by <size> samples each time
-- (default: 200)
--
-- --inverse White/Colour-on-black
--
-- --logarithmic Intensity is calculated by
-- log10 (1 + 9 * (amplitude / max_amp)) -
-- better for visualising weaker signals
--
-- --combine XYZ Determines how a stereo signal is
-- represented as an RGB image. The argument is
-- a 3-character block, each character
-- corresponding to R, G and B components. It
-- may take values of L, R, A, D, X or Z,
-- meaning Left, Right, Average, Difference,
-- Cross-Correlation or Zero respectively.
--
-- --verbose Slightly less quiet
--
-- --version Print out the version
--
-- --help You're in it.
--
--", pname);
-+"\n"
-+"Usage: %s [options] file.wav\n"
-+"\n"
-+"Options:\n"
-+" --window <size> FFT window size (default: 2048)\n"
-+"\n"
-+" --step <size> Slide the window by <size> samples each time \n"
-+" (default: 200)\n"
-+"\n"
-+" --inverse White/Colour-on-black\n"
-+"\n"
-+" --logarithmic Intensity is calculated by\n"
-+" log10 (1 + 9 * (amplitude / max_amp)) -\n"
-+" better for visualising weaker signals\n"
-+"\n"
-+" --combine XYZ Determines how a stereo signal is\n"
-+" represented as an RGB image. The argument is\n"
-+" a 3-character block, each character\n"
-+" corresponding to R, G and B components. It\n"
-+" may take values of L, R, A, D, X or Z,\n"
-+" meaning Left, Right, Average, Difference,\n"
-+" Cross-Correlation or Zero respectively.\n"
-+"\n"
-+" --verbose Slightly less quiet\n"
-+"\n"
-+" --version Print out the version\n"
-+"\n"
-+" --help You're in it.\n"
-+"\n"
-+, pname);
-
-
- exit (-1);
diff --git a/sci-visualization/spectromatic/files/spectromatic-1.0-waveheaderstruct-amd64.patch b/sci-visualization/spectromatic/files/spectromatic-1.0-waveheaderstruct-amd64.patch
deleted file mode 100644
index 0c4253e7e765..000000000000
--- a/sci-visualization/spectromatic/files/spectromatic-1.0-waveheaderstruct-amd64.patch
+++ /dev/null
@@ -1,103 +0,0 @@
---- a/wave.c
-+++ b/wave.c
-@@ -1,11 +1,26 @@
- #include <stdio.h>
- #include <string.h>
-+#include <endian.h>
- #include "wave.h"
-
- int read_header (FILE *f, waveheaderstruct *header)
- {
-+ waveheaderstruct h;
- fseek (f, 0, SEEK_SET);
-- return fread (header, 1, sizeof (waveheaderstruct), f);
-+ size_t red = fread (&h, 1, sizeof (waveheaderstruct), f);
-+
-+ h.length = le32toh(h.length);
-+ h.length_chunk = le32toh(h.length_chunk);
-+ h.format = le16toh(h.format);
-+ h.modus = le16toh(h.modus);
-+ h.sample_fq = le32toh(h.sample_fq);
-+ h.byte_p_sec = le32toh(h.byte_p_sec);
-+ h.byte_p_spl = le16toh(h.byte_p_spl);
-+ h.bit_p_spl = le16toh(h.bit_p_spl);
-+ h.data_length = le32toh(h.data_length);
-+
-+ *header = h;
-+ return red;
- }
-
- int read_frames (FILE *f, int start, int length, char *data)
-@@ -52,12 +67,12 @@
-
- read_header (f, &header);
-
-- printf ("Length: %lu\n", header.length);
-- printf ("Length Chunk: %lu\n", header.length_chunk);
-+ printf ("Length: %lu\n", (unsigned long)header.length);
-+ printf ("Length Chunk: %lu\n", (unsigned long)header.length_chunk);
- printf ("Format: %u\n", header.format);
- printf ("Modus: %u\n", header.modus);
-- printf ("Sample Frequency: %lu\n", header.sample_fq);
-- printf ("Bytes per Second: %lu\n", header.byte_p_sec);
-+ printf ("Sample Frequency: %lu\n", (unsigned long)header.sample_fq);
-+ printf ("Bytes per Second: %lu\n", (unsigned long)header.byte_p_sec);
- printf ("Bytes per Sample: %u\n", header.byte_p_spl);
-- printf ("Data Length: %lu\n", header.data_length);
-+ printf ("Data Length: %lu\n", (unsigned long)header.data_length);
- }
---- a/wave.h
-+++ b/wave.h
-@@ -22,24 +22,25 @@
- #ifndef WAVE_H
- #define WAVE_H
-
--typedef unsigned long ulongT;
--typedef unsigned short ushortT;
-+#include <stdint.h>
-
-+#pragma pack(push,1)
- typedef struct { /* header for WAV-Files */
-- char main_chunk[4]; /* 'RIFF' */
-- unsigned long length; /* length of file */
-- char chunk_type[4]; /* 'WAVE' */
-- char sub_chunk[4]; /* 'fmt' */
-- unsigned long length_chunk; /* length sub_chunk, always 16 bytes */
-- unsigned short format; /* always 1 = PCM-Code */
-- unsigned short modus; /* 1 = Mono, 2 = Stereo */
-- unsigned long sample_fq; /* Sample Freq */
-- unsigned long byte_p_sec; /* Data per sec */
-- unsigned short byte_p_spl; /* Bytes per sample */
-- unsigned short bit_p_spl; /* bits per sample, 8, 12, 16 */
-- char data_chunk[4]; /* 'data' */
-- unsigned long data_length; /* length of data */
--} waveheaderstruct;
-+ uint8_t main_chunk[4]; /* 'RIFF' */
-+ uint32_t length; /* length of file */
-+ uint8_t chunk_type[4]; /* 'WAVE' */
-+ uint8_t sub_chunk[4]; /* 'fmt' */
-+ uint32_t length_chunk; /* length sub_chunk, always 16 bytes */
-+ uint16_t format; /* always 1 = PCM-Code */
-+ uint16_t modus; /* 1 = Mono, 2 = Stereo */
-+ uint32_t sample_fq; /* Sample Freq */
-+ uint32_t byte_p_sec; /* Data per sec */
-+ uint16_t byte_p_spl; /* Bytes per sample */
-+ uint16_t bit_p_spl; /* bits per sample, 8, 12, 16 */
-+ uint8_t data_chunk[4]; /* 'data' */
-+ uint32_t data_length; /* length of data */
-+} __attribute__ ((__packed__)) waveheaderstruct;
-+#pragma pack(pop)
-
- int read_header (FILE *f, waveheaderstruct *header);
- int read_frames (FILE *f, int start, int length, char *data);
---- a/spectromatic.c
-+++ b/spectromatic.c
-@@ -217,7 +217,7 @@
- if (header.modus == 2)
- ch2 = (double*) malloc (window_size * sizeof (double));
-
-- fprintf (stderr, "samples = %li, step_size = %i, window_size = %i\n", header.data_length / header.byte_p_spl, step_size, window_size);
-+ fprintf (stderr, "samples = %lu, step_size = %i, window_size = %i\n", (unsigned long)header.data_length / header.byte_p_spl, step_size, window_size);
-
- for (i = -window_size; i < window_size + (int)(header.data_length / header.byte_p_spl); i += step_size) {
- read_frames (f, i, window_size, data);