summaryrefslogtreecommitdiff
path: root/sci-visualization/tensorboard/tensorboard-2.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-14 17:36:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-14 17:36:29 +0000
commit0485fd7e57de60b61c04825f986bb3400bcf7116 (patch)
tree8bc2ab515d65bccf3fa878f133e82577074ee982 /sci-visualization/tensorboard/tensorboard-2.10.0.ebuild
parent3a5772102e4f2b6f9cc46f461c90970060ae0c5e (diff)
gentoo auto-resync : 14:02:2024 - 17:36:28
Diffstat (limited to 'sci-visualization/tensorboard/tensorboard-2.10.0.ebuild')
-rw-r--r--sci-visualization/tensorboard/tensorboard-2.10.0.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/sci-visualization/tensorboard/tensorboard-2.10.0.ebuild b/sci-visualization/tensorboard/tensorboard-2.10.0.ebuild
deleted file mode 100644
index 207c16f36c79..000000000000
--- a/sci-visualization/tensorboard/tensorboard-2.10.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_10 )
-inherit python-r1
-
-DESCRIPTION="TensorFlow's Visualization Toolkit"
-HOMEPAGE="https://www.tensorflow.org/"
-SRC_URI="https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl -> ${P}.zip"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-python/bleach[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.6.3[${PYTHON_USEDEP}]
- >=dev-python/google-auth-oauthlib-0.4.1[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/setuptools-41[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- >=dev-python/scipy-1.4.1[${PYTHON_USEDEP}]"
-BDEPEND="app-arch/unzip
- ${PYTHON_DEPS}"
-PDEPEND="sci-libs/tensorflow[python,${PYTHON_USEDEP}]"
-
-S="${WORKDIR}"
-
-src_prepare() {
- eapply_user
-
- sed -i -e '/_vendor.__init__/d' -e '/_vendor.bleach/d' -e '/_vendor.html5lib/d' -e '/_vendor.webencodings/d' \
- "${S}/${P}.dist-info/RECORD" || die "failed to unvendor"
- grep -q "_vendor" "${S}/${P}.dist-info/RECORD" && die "More vendored deps found"
-
- find "${S}/${PN}" -name '*.py' -exec sed -i \
- -e 's/^from tensorboard\._vendor import /import /' \
- -e 's/^from tensorboard\._vendor\./from /' \
- {} + || die "failed to unvendor"
-
- rm -rf "${S}/${PN}/_vendor" || die
-
- sed -i -e '/tensorboard-plugin-/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove plugin deps"
- sed -i -e '/tensorboard-data-server/d' "${S}/${P}.dist-info/METADATA" || die "failed to remove data-server deps"
- sed -i -e 's/google-auth-oauthlib.*$/google-auth-oauthlib/' "${S}/${P}.dist-info/METADATA" \
- || die "failed to relax oauth deps"
-}
-
-src_install() {
- do_install() {
- python_domodule "${PN}"
- python_domodule "${P}.dist-info"
- }
- python_foreach_impl do_install
-}