summaryrefslogtreecommitdiff
path: root/sci-visualization/xds-viewer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-visualization/xds-viewer
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-visualization/xds-viewer')
-rw-r--r--sci-visualization/xds-viewer/Manifest6
-rw-r--r--sci-visualization/xds-viewer/files/xds-viewer-0.6-fix-c++14.patch66
-rw-r--r--sci-visualization/xds-viewer/metadata.xml22
-rw-r--r--sci-visualization/xds-viewer/xds-viewer-0.6-r1.ebuild24
4 files changed, 118 insertions, 0 deletions
diff --git a/sci-visualization/xds-viewer/Manifest b/sci-visualization/xds-viewer/Manifest
new file mode 100644
index 000000000000..bb44e2c453be
--- /dev/null
+++ b/sci-visualization/xds-viewer/Manifest
@@ -0,0 +1,6 @@
+AUX xds-viewer-0.6-fix-c++14.patch 2139 SHA256 8e6aba22f4904ff29912af6f2c9c04340a3337d666fbd07dc88bac7adda12478 SHA512 2b6d1d5598a016c2806bd54a027b1b23bbfa78cca4e7293df9e80eef8fbed3b084f29d1c499670a5d4b83681c7761a13897c7ccbe78599f6a0bc1cb468121444 WHIRLPOOL 19927abc42984093c3732aacddcae7b310aadee1e3b2cab2beb4fc9b5f0f168eb3a325f7c5d18cdc4779e41ca10ec54fe8e3effc3aaa592103e3873a9740af7c
+DIST xds-viewer-0.6.tar.gz 408315 SHA256 a4088246f002fd33add8fe1ea5453696e2a3e01d4c1ae189a496274b46da5a75 SHA512 4a7798997147e569aeeabab958b41198da29d336273e4b16b8d3c8766f2a16256727e9620a91b8f202125c9f5daedbd37e79352bb563fd431475b806deb3629e WHIRLPOOL fb5aeb580b01b63b99a417b41b9e9b1649067e4e9fbd20825f08beca24cb17d729270efe07e1ad32cc4d8acd5ac71d5061ba935fbbe111e52db54466722f56f3
+EBUILD xds-viewer-0.6-r1.ebuild 566 SHA256 be13b963ee99fa66335c8684fbef66b6b5c456428708dcecfdcca0c4f7673145 SHA512 f85cc8c389b34a5f58a43b175c44363c1c9f6b3c06598a9a5ad9edc5da6e5745f580f0761981c5872d9da00913556243d442b3ed6fb93a8357bf48586bdff382 WHIRLPOOL e16431cad60cf9baebb25dfee9696b90948758ee939dc3d4c8504ebf6427b31b4feb4adc1620ef66c78203e9a6a83abff8a63218339ddc6e3f448d042d8dec97
+MISC ChangeLog 2752 SHA256 b8b9b2cc5374300cde76af41cf656967ad95d33da4fae6a73e321194d6a3f589 SHA512 a9344269a68f6915731316835db2debb68999400e78c1b45f0885673fce7a51c12c6fd1b58643eca138fdd80b89c9e7013da1beccb7083a71a3ae9f798cc85d6 WHIRLPOOL 1fdf372db266bacfc026996906c43fd6b15ac6033830bd548dd8d01aab0298e999e7bc51b39732b0f0b407fa91028c2c53c9c250c8b646744ce5a6b99ed594ce
+MISC ChangeLog-2015 1237 SHA256 111c018bf4d3c1c8a2a0987d2ef3318f1ad9551b30bf6ae819a7e915f8c0d56c SHA512 b3683b80e70f59f415e7d678be1dc84c65e4cef35392a613ddadfcbc0ebbd620342717957b211ca9e32078144d22ee433affdcfa9746ba400dea4e4002c8e560 WHIRLPOOL 90b208f82fcb284ae9fca0c2602dbfae722923c010d3d0be168373bc6d355de985b0981991357512f231367ce0b6b7cd28e819b38349fdaed26c60c39e79ea5c
+MISC metadata.xml 985 SHA256 6b30b862e36a453c3257749aa2cdf67c7b9f390078cd85da121bb8dc3b91fa4f SHA512 4daebbf5c5b83c76c77ad12467dbb9a5593f6a693acfdc027da7d3b215f53cacf7d4f2f1cc61f13e152e66a19c62d3715151bd9893495d67915d76b4e9d98b0d WHIRLPOOL 3698a029d945732264205ecae3d02c92e40f9d47cc36cd4adf38c1b40c55bc1165dac2be3b1e650a8cef8df3c0ed96a0090b3cefe54b638bbded90a30afd9ecd
diff --git a/sci-visualization/xds-viewer/files/xds-viewer-0.6-fix-c++14.patch b/sci-visualization/xds-viewer/files/xds-viewer-0.6-fix-c++14.patch
new file mode 100644
index 000000000000..612b5038c845
--- /dev/null
+++ b/sci-visualization/xds-viewer/files/xds-viewer-0.6-fix-c++14.patch
@@ -0,0 +1,66 @@
+Fix building with C++14, caused by invalid implicit T* -> bool conversions.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=598126
+
+--- a/src/CbfReader.cpp
++++ b/src/CbfReader.cpp
+@@ -315,12 +315,12 @@
+
+ for ( int i = 0;i < nx*ny;i++ )
+ {
+- if ( tapin.get( sc ) == 0 )return -4;
++ if ( !tapin.get( sc ) )return -4;
+ diff = sc;
+ if ( diff == -128 )
+ {
+- if ( tapin.get( uc0 ) == 0 )return -4;
+- if ( tapin.get( uc1 ) == 0 )return -4;
++ if ( !tapin.get( uc0 ) )return -4;
++ if ( !tapin.get( uc1 ) )return -4;
+ tmp0 = uc0;
+ if ( uc0 < 0 ) tmp0 += 256; // converting signed to unsigned char
+ diff = uc1;
+@@ -329,15 +329,15 @@
+ if ( diff > 32767 )diff -= 65536;
+ if ( diff == -32768 )
+ {
+- if ( tapin.get( uc0 ) == 0 )return -4;
+- if ( tapin.get( uc1 ) == 0 )return -4;
++ if ( !tapin.get( uc0 ) )return -4;
++ if ( !tapin.get( uc1 ) )return -4;
+ tmp0 = uc0;
+ if ( tmp0 < 0 ) tmp0 += 256; // converting signed to unsigned char
+ tmp1 = uc1;
+ if ( tmp1 < 0 ) tmp1 += 256; // converting signed to unsigned char
+ diff = tmp0 + 256 * tmp1;
+- if ( tapin.get( uc0 ) == 0 )return -4;
+- if ( tapin.get( uc1 ) == 0 )return -4;
++ if ( !tapin.get( uc0 ) )return -4;
++ if ( !tapin.get( uc1 ) )return -4;
+ tmp0 = uc0;
+ if ( tmp0 < 0 ) tmp0 += 256; // converting signed to unsigned char
+ tmp1 = uc1;
+@@ -359,7 +359,7 @@
+ {
+ std::ifstream::pos_type streamPos = tapin.tellg();
+
+- char binaryMarker[5] = {12, 26, 4, 213, '\0'};
++ char binaryMarker[5] = {12, 26, 4, (char)213, '\0'};
+ char buffer[5] = {0, 0, 0, 0, '\0'};
+
+ bool equal = true;
+@@ -448,13 +448,13 @@
+
+ int CbfReader::checkImageFormat( std::ifstream& tapin )
+ {
+- if ( tapin == 0 )return -2; // Cannot open image file
++ if ( !tapin )return -2; // Cannot open image file
+
+ { // Check image file format
+ std::string s( "###CBF: " );
+ char label[9];
+ for ( int i = 0;i < 8;i++ )
+- if ( tapin.get( label[i] ) == false )return -4; // Cannot read image file
++ if ( !tapin.get( label[i] ) )return -4; // Cannot read image file
+ label[8] = '\0';
+ std::string sLabel = ( std::string )label;
+
diff --git a/sci-visualization/xds-viewer/metadata.xml b/sci-visualization/xds-viewer/metadata.xml
new file mode 100644
index 000000000000..0177b9503629
--- /dev/null
+++ b/sci-visualization/xds-viewer/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ XDS-Viewer is a program for viewing X-ray diffraction and control
+ images in the context of data processing by the XDS Program Package
+ (external link). Potential users of the software are scientists
+ working in the field of crystallography. The XDS-Viewer is a
+ standalone program which has build-in support for a subset of the
+ Crystallographic Binary File Format CBF (external link). Other file
+ formats are supported through an external convertion program that
+ comes with XDS. XDS-Viewer will automatically invoke the convertion
+ program for images other than CBF.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xds-viewer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-visualization/xds-viewer/xds-viewer-0.6-r1.ebuild b/sci-visualization/xds-viewer/xds-viewer-0.6-r1.ebuild
new file mode 100644
index 000000000000..f331c821dc71
--- /dev/null
+++ b/sci-visualization/xds-viewer/xds-viewer-0.6-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="X-ray diffraction/control image viewer in the context of data processing by XDS"
+HOMEPAGE="http://xds-viewer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/libpng:0=
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( src/doc/. )
+PATCHES=( "${FILESDIR}"/${P}-fix-c++14.patch )