summaryrefslogtreecommitdiff
path: root/sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-10.1.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-15 16:36:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-15 16:36:08 +0000
commitdb3d7a26fc91ea36f0780dcc3bcc59efdab02d41 (patch)
treef1e4dcd66841437a53a8fad6c9efadbd060f692a /sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-10.1.16.ebuild
parent55cd3ff92ff96fafc75066838cfc2af06df3a296 (diff)
gentoo auto-resync : 15:11:2023 - 16:36:08
Diffstat (limited to 'sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-10.1.16.ebuild')
-rw-r--r--sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-10.1.16.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-10.1.16.ebuild b/sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-10.1.16.ebuild
new file mode 100644
index 000000000000..81b3505e76ec
--- /dev/null
+++ b/sec-keys/openpgp-keys-apache-tomcat/openpgp-keys-apache-tomcat-10.1.16.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP keys used by tomcat.apache.org"
+HOMEPAGE="https://tomcat.apache.org/download-90.cgi"
+SRC_URI="https://downloads.apache.org/tomcat/tomcat-$(ver_cut 1)/v${PV}/KEYS -> ${P}-KEYS.asc"
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+
+S="${WORKDIR}"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - tomcat-${PV}.apache.org.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}