summaryrefslogtreecommitdiff
path: root/sec-keys/openpgp-keys-crypto++/openpgp-keys-crypto++-20210416.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /sec-keys/openpgp-keys-crypto++/openpgp-keys-crypto++-20210416.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'sec-keys/openpgp-keys-crypto++/openpgp-keys-crypto++-20210416.ebuild')
-rw-r--r--sec-keys/openpgp-keys-crypto++/openpgp-keys-crypto++-20210416.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-crypto++/openpgp-keys-crypto++-20210416.ebuild b/sec-keys/openpgp-keys-crypto++/openpgp-keys-crypto++-20210416.ebuild
new file mode 100644
index 000000000000..87a8a0a4c1db
--- /dev/null
+++ b/sec-keys/openpgp-keys-crypto++/openpgp-keys-crypto++-20210416.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenPGP keys used to sign crypto++ releases"
+HOMEPAGE="https://cryptopp.com/signing.html"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+src_install() {
+ # Note: Currently Jeffrey Walton (noloader) makes releases, but may need to add
+ # others in future (listed on HOMEPAGE)
+ # (only one other fingerprint is given though and they haven't made a release in ages,
+ # so avoiding adding that for now.)
+ local files=(
+ "${FILESDIR}"/${PN}-noloader.asc
+ )
+
+ insinto /usr/share/openpgp-keys
+ newins - crypto++.asc < <(cat "${files[@]}" || die)
+}