summaryrefslogtreecommitdiff
path: root/sys-apps/agedu/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/agedu/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/agedu/files')
-rw-r--r--sys-apps/agedu/files/agedu-r9671-fix-automagic.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch b/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch
new file mode 100644
index 000000000000..8e0c6ea2969e
--- /dev/null
+++ b/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch
@@ -0,0 +1,44 @@
+diff -Naur agedu-r9671.orig/configure.ac agedu-r9671/configure.ac
+--- agedu-r9671.orig/configure.ac 2012-10-20 21:20:47.000000000 -0400
++++ agedu-r9671/configure.ac 2012-10-21 15:13:08.000000000 -0400
+@@ -10,8 +10,6 @@
+ AC_PROG_CC
+ AC_PROG_CC_C99
+ AC_PROG_INSTALL
+-AC_CHECK_PROG([HALIBUT],[halibut],[yes],[no])
+-AM_CONDITIONAL([HAVE_HALIBUT],[test "x$HALIBUT" = "xyes"])
+
+ # Checks for libraries.
+
+@@ -43,13 +41,28 @@
+
+ AC_CHECK_FUNCS([ftruncate fdopendir lstat64 stat64 memchr munmap select socket strcasecmp strchr strcspn strerror strrchr strspn strtoul strtoull connect inet_ntoa inet_addr gethostbyname getaddrinfo])
+
++AC_ARG_ENABLE([halibut],
++ AS_HELP_STRING([--disable-halibut],
++ [disable documentation with halibut (default off)]),
++ [halibut=$enableval],[halibut=no])
++
++if test "$halibut" = "no"; then
++ AM_CONDITIONAL([HAVE_HALIBUT],[false])
++else
++ AC_CHECK_PROG([have_halibut],[halibut],[yes],[no])
++ if test "$have_halibut" = "no"; then
++ AC_MSG_ERROR([halibut configured but not found])
++ fi
++ AM_CONDITIONAL([HAVE_HALIBUT],[true])
++fi
++
+ AC_ARG_ENABLE([ipv6],
+ AS_HELP_STRING([--disable-ipv6],
+- [disable IPv6 in the built-in web server]),
+- [ipv6=$enableval],[ipv6=$ac_cv_func_getaddrinfo])
++ [disable IPv6 in the built-in web server (default off)]),
++ [ipv6=$enableval],[ipv6=no])
+ AC_ARG_ENABLE([ipv4],
+ AS_HELP_STRING([--disable-ipv4],
+- [disable IPv4 in the built-in web server]),
++ [disable IPv4 in the built-in web server (default on)]),
+ [ipv4=$enableval],[ipv4=yes])
+ if test "$ipv6" = "no"; then
+ AC_DEFINE([NO_IPV6], [1], [define if IPv6 is disabled at configure time])