summaryrefslogtreecommitdiff
path: root/sys-apps/bar/bar-1.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/bar/bar-1.11.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/bar/bar-1.11.1.ebuild')
-rw-r--r--sys-apps/bar/bar-1.11.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/bar/bar-1.11.1.ebuild b/sys-apps/bar/bar-1.11.1.ebuild
new file mode 100644
index 000000000000..ff678910027e
--- /dev/null
+++ b/sys-apps/bar/bar-1.11.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Console Progress Bar"
+HOMEPAGE="http://clpbar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clpbar/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="doc"
+
+DEPEND="doc? ( >=app-doc/doxygen-1.3.5 )"
+RDEPEND=""
+
+src_prepare() {
+ sed -e '/^LDFLAGS/d' \
+ -e '/cd $(WEB_DIR) && $(MAKE)/d' -i Makefile.am || die
+ eautomake
+}
+
+src_configure() {
+ local myconf
+
+ # Fix wrt #113392
+ use sparc && myconf="${myconf} --disable-use-memalign"
+ econf ${myconf}
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+ if use doc; then
+ mkdir -p ../www/doxygen/${PV}
+ emake update-www
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS TODO TROUBLESHOOTING debian/changelog
+ if use doc ; then
+ dohtml -r ../www/doxygen/${PV}/html/*
+ fi
+}