summaryrefslogtreecommitdiff
path: root/sys-apps/baselayout/baselayout-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
commit22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (patch)
tree808b5701901fb54b53ec3ecf6f33272e933f3ea6 /sys-apps/baselayout/baselayout-9999.ebuild
parent91c0ec2d7067f6ab1ef578bd9967b32ca07eb502 (diff)
gentoo resync : 25.05.2018
Diffstat (limited to 'sys-apps/baselayout/baselayout-9999.ebuild')
-rw-r--r--sys-apps/baselayout/baselayout-9999.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/sys-apps/baselayout/baselayout-9999.ebuild b/sys-apps/baselayout/baselayout-9999.ebuild
index cef8791471ae..866701708dc6 100644
--- a/sys-apps/baselayout/baselayout-9999.ebuild
+++ b/sys-apps/baselayout/baselayout-9999.ebuild
@@ -17,7 +17,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="build kernel_FreeBSD kernel_linux usrmerge"
+IUSE="build kernel_FreeBSD kernel_linux +split-usr"
pkg_setup() {
multilib_layout
@@ -35,7 +35,7 @@ multilib_layout() {
# figure out which paths should be symlinks and which should be directories
local dirs syms exp d
for libdir in ${libdirs} ; do
- if ! use usrmerge ; then
+ if use split-usr ; then
exp=( {,usr/,usr/local/}${libdir} )
else
exp=( {usr/,usr/local/}${libdir} )
@@ -62,12 +62,12 @@ multilib_layout() {
# setup symlinks and dirs where we expect them to be; do not migrate
# data ... just fall over in that case.
local prefix prefix_lst
- if ! use usrmerge ; then
- prefix_lst="${EROOT}"{,usr/,usr/local/}
+ if use split-usr ; then
+ prefix_lst=( "${EROOT}"{,usr/,usr/local/} )
else
- prefix_lst="${EROOT}"{usr/,usr/local/}
+ prefix_lst=( "${EROOT}"{usr/,usr/local/} )
fi
- for prefix in "${prefix_lst}"; do
+ for prefix in "${prefix_lst[@]}"; do
if [ "${SYMLINK_LIB}" = yes ] ; then
# we need to make sure "lib" points to the native libdir
if [ -h "${prefix}lib" ] ; then
@@ -125,7 +125,7 @@ multilib_layout() {
fi
fi
done
- if use usrmerge ; then
+ if ! use split-usr ; then
for libdir in ${libdirs}; do
if [[ ! -e "${EROOT}${libdir}" ]]; then
ln -s usr/"${libdir}" "${EROOT}${libdir}"
@@ -145,7 +145,7 @@ pkg_preinst() {
# Also, we cannot reference $S as binpkg will break so we do this.
multilib_layout
if use build ; then
- if ! use usrmerge ; then
+ if use split-usr ; then
emake -C "${ED}/usr/share/${PN}" DESTDIR="${EROOT}" layout
else
emake -C "${ED}/usr/share/${PN}" DESTDIR="${EROOT}" layout-usrmerge
@@ -258,6 +258,11 @@ pkg_postinst() {
ewarn "Please run env-update then log out and back in to"
ewarn "update your path."
fi
+ # clean up after 2.5 typos
+ # https://bugs.gentoo.org/show_bug.cgi?id=656380
+ if [[ ${x} == 2.5 ]]; then
+ rm -fr "${EROOT}{,usr"
+ fi
done
if [[ -e "${EROOT}"etc/env.d/00basic ]]; then