summaryrefslogtreecommitdiff
path: root/sys-apps/biosdisk/biosdisk-1.01.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /sys-apps/biosdisk/biosdisk-1.01.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'sys-apps/biosdisk/biosdisk-1.01.ebuild')
-rw-r--r--sys-apps/biosdisk/biosdisk-1.01.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/biosdisk/biosdisk-1.01.ebuild b/sys-apps/biosdisk/biosdisk-1.01.ebuild
new file mode 100644
index 000000000000..f4ae904c895e
--- /dev/null
+++ b/sys-apps/biosdisk/biosdisk-1.01.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="FreeDOS based BIOS updating utility for Dell machines"
+HOMEPAGE="https://github.com/dell/biosdisk"
+SRC_URI="https://github.com/dell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-cdr/cdrtools
+ sys-boot/grub
+ sys-boot/syslinux
+"
+
+src_prepare() {
+ default
+
+ sed -e 's/biosdisk.8.gz/biosdisk.8/g' -e '/gzip/d' -i Makefile || die
+}
+
+src_install() {
+ default
+
+ keepdir /var/lib/biosdisk
+}