summaryrefslogtreecommitdiff
path: root/sys-apps/cpu-x
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-19 20:37:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-19 20:37:19 +0100
commit343082998723d09c7b354eb21ff4793c6d4fda3e (patch)
tree1ac116f7e87117a78651da3a40230efefd5bf847 /sys-apps/cpu-x
parentb1f2cdf56e5eea363adc4c1ea1bd418f65733a7a (diff)
gentoo auto-resync : 19:08:2022 - 20:37:18
Diffstat (limited to 'sys-apps/cpu-x')
-rw-r--r--sys-apps/cpu-x/Manifest3
-rw-r--r--sys-apps/cpu-x/cpu-x-4.3.1.ebuild80
-rw-r--r--sys-apps/cpu-x/metadata.xml47
3 files changed, 130 insertions, 0 deletions
diff --git a/sys-apps/cpu-x/Manifest b/sys-apps/cpu-x/Manifest
new file mode 100644
index 000000000000..e05f8b1906d5
--- /dev/null
+++ b/sys-apps/cpu-x/Manifest
@@ -0,0 +1,3 @@
+DIST cpu-x-4.3.1.tar.gz 1846968 BLAKE2B bcf13a302ad108f76d3c170993385178e7b44123af6b6f3192960f69d8ee493719a408ef4e95ee82e4cbf3f151fe4dcb91a9fc9d4e53c1170c95a9ed2ad3417b SHA512 43e7bc4b82a15545e4c2f69f598a94706ef2c5f5594ff50763f71722d1b98e6dd56e907a4f35917500debf11522c5908dbebf51f515fe5a51af7282254210bc1
+EBUILD cpu-x-4.3.1.ebuild 1677 BLAKE2B 2883a2b87640bbdafd2f56054a3e5c32154a95471b859abb39c7488be71d0efc5273066b19bc1d56e4b34c28cb07a6a90bd5416f4bd5bc64806c7a3e47990223 SHA512 7f9565d7d6b8a7992f415bbe8d58202cd98b402c270bbb7db4d0d48642c1dd86b5e6b97dc32e8421075b7c6b963ad53d1ab56084dd4602feccaf56f105b51d41
+MISC metadata.xml 2370 BLAKE2B edf7d35e28a2c5b60f8b6d6d7d616146c72fb937f07fe16e8d89f5e0522a4a8dfdbe838dcc1b9e57dea30f267e6e7e51b200a11f60b67ca528eb7851ad1b0a28 SHA512 026acb991c7a80c6ba84fe24b14ec7686ba9d389c94e9f6d2e25ff8c9cb8cd36fe795b571ccb02a0ae1335604d5074bf43373fbaa8388f9e6a446c326385f4a7
diff --git a/sys-apps/cpu-x/cpu-x-4.3.1.ebuild b/sys-apps/cpu-x/cpu-x-4.3.1.ebuild
new file mode 100644
index 000000000000..61d96cc1ce04
--- /dev/null
+++ b/sys-apps/cpu-x/cpu-x-4.3.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="CPU-X"
+
+inherit cmake gnome2-utils xdg
+
+DESCRIPTION="A Free software that gathers information on CPU, motherboard and more"
+HOMEPAGE="https://x0rg.github.io/CPU-X/"
+SRC_URI="https://github.com/X0rg/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="+cpu force-libstatgrab +gpu +gui +ncurses +nls opencl +pci test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ force-libstatgrab? ( sys-libs/libstatgrab )
+ !force-libstatgrab? ( sys-process/procps:= )
+ gui? ( >=x11-libs/gtk+-3.12:3 )
+ cpu? ( >=dev-libs/libcpuid-0.3.0:= )
+ gpu? ( >=media-libs/glfw-3.3
+ media-libs/libglvnd )
+ pci? ( sys-apps/pciutils )
+ ncurses? ( sys-libs/ncurses:=[tinfo] )
+ opencl? ( virtual/opencl )
+"
+
+DEPEND="
+ test? (
+ sys-apps/mawk
+ sys-apps/nawk
+ )
+
+ ${COMMON_DEPEND}
+"
+
+BDEPEND="
+ dev-lang/nasm
+ nls? ( sys-devel/gettext )
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DFORCE_LIBSTATGRAB=$(usex force-libstatgrab)
+ -DGSETTINGS_COMPILE=OFF
+ -DWITH_BANDWIDTH=$(usex bandwidth)
+ -DWITH_DMIDECODE=$(usex dmidecode)
+ -DWITH_GETTEXT=$(usex nls)
+ -DWITH_GTK=$(usex gtk)
+ -DWITH_LIBCPUID=$(usex libcpuid)
+ -DWITH_LIBGLFW=$(usex libglfw)
+ -DWITH_LIBPCI=$(usex libpci)
+ -DWITH_LIBSTATGRAB=OFF
+ -DWITH_NCURSES=$(usex ncurses)
+ -DWITH_OPENCL=$(usex opencl)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/sys-apps/cpu-x/metadata.xml b/sys-apps/cpu-x/metadata.xml
new file mode 100644
index 000000000000..52d661f4aca7
--- /dev/null
+++ b/sys-apps/cpu-x/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
+ <longdescription>
+ <pkg>sys-apps/cpu-x</pkg> is similar to CPU-Z (Windows), but, unlike
+ the latter, it is a Free and Open Source software, written in C and
+ designed for GNU/Linux. It can also be used in graphical mode by using
+ <pkg>x11-libs/gtk+</pkg>, than in text-based mode with the use of
+ <pkg>sys-libs/ncurses</pkg>.
+ </longdescription>
+ <longdescription lang="fr">
+ <pkg>sys-apps/cpu-x</pkg> est similaire à CPU-Z (Windows), mais,
+ contrairement à ce dernier, c'est un logiciel Libre et Open Source,
+ écrit en C et concu pour GNU/Linux. Il peut être aussi bien utilisé en
+ mode graphique en utlisant <pkg>x11-libs/gtk+</pkg>, qu'en mode textuel
+ avec l'utilisation de <pkg>sys-libs/ncurses</pkg>.
+ </longdescription>
+ <use>
+ <flag name="force-libstatgrab">Use <pkg>sys-libs/libstatgrab</pkg> to instead of <pkg>sys-process/procps</pkg></flag>
+ <flag name="cpu">Use the <pkg>dev-libs/libcpuid</pkg> library for CPU info</flag>
+ <flag name="gpu">Use the <pkg>media-libs/glfw</pkg> library for GPU info</flag>
+ <flag name="pci">Use the <pkg>sys-apps/pciutils</pkg> library for PCI info</flag>
+ <flag name="opencl">Use the <pkg>virtual/opencl</pkg> library</flag>
+ </use>
+ <use lang="fr">
+ <flag name="bandwidth">Intégrer bandwidth</flag>
+ <flag name="dmidecode">Intégrer dmidecode</flag>
+ <flag name="force-libstatgrab">Utiliser <pkg>sys-libs/libstatgrab</pkg> à la place de <pkg>sys-process/procps</pkg></flag>
+ <flag name="libcpuid">Utiliser la bibliothèque <pkg>dev-libs/libcpuid</pkg></flag>
+ <flag name="libglfw">Utiliser la bibliothèque <pkg>media-libs/glfw</pkg></flag>
+ <flag name="libpci">Utiliser la bibliothèque <pkg>sys-apps/pciutils</pkg></flag>
+ <flag name="opencl">Utiliser la bibliothèque <pkg>virtual/opencl</pkg></flag>
+ </use>
+ <upstream>
+ <maintainer status="active">
+ <name>X0rg</name>
+ </maintainer>
+ <changelog>https://raw.githubusercontent.com/X0rg/CPU-X/master/ChangeLog</changelog>
+ <doc>https://github.com/X0rg/CPU-X/wiki/</doc>
+ <bugs-to>https://github.com/X0rg/CPU-X/issues/</bugs-to>
+ <remote-id type="github">X0rg/CPU-X</remote-id>
+ </upstream>
+</pkgmetadata>